Virus/Trojan - 4.3 Update your Xpenology now


Recommended Posts

Hi gnoboot, I have successfully installed with alpha7 the dsm 5.0 beta, but when i try to install the 4.3-3827 (on formatted, clean hard drives) the Diskstation Assistant tells me that the Dsm 4.3-3827 is obsolete and i can install only from 5.0 4418 and up.

There is a way to install the 4.3-3827 ? What I'm doing wrong ?

 

Thank you again for your great work!

Link to post
Share on other sites

Hi gnoboot, I have successfully installed with alpha7 the dsm 5.0 beta, but when i try to install the 4.3-3827 (on formatted, clean hard drives) the Diskstation Assistant tells me that the Dsm 4.3-3827 is obsolete and i can install only from 5.0 4418 and up.

There is a way to install the 4.3-3827 ? What I'm doing wrong ?

 

Thank you again for your great work!

Link to post
Share on other sites
How would I go about upgrading to update 4 now that 4.3-3827 is available?

 

I'm switching the update 4 file in but it won't install them as it see's the newer version is available.. quite frustrating!

 

 

I managed to update by disconnecting from the internet and using the manual method. After you goto DMS update, it will say disconnected etc. I clicked manual DSM update then cancel and it somehow refreshed and used the local files. If you have problems updating because you have been infected (like i had), login via ssh and edit

 

/usr/syno/synoman/webman/modules/ControlPanel/modules/upgrade.cgi

 

then remove pipe '|' and the sed part off the file and save.

Link to post
Share on other sites
How would I go about upgrading to update 4 now that 4.3-3827 is available?

 

I'm switching the update 4 file in but it won't install them as it see's the newer version is available.. quite frustrating!

 

 

I managed to update by disconnecting from the internet and using the manual method. After you goto DMS update, it will say disconnected etc. I clicked manual DSM update then cancel and it somehow refreshed and used the local files. If you have problems updating because you have been infected (like i had), login via ssh and edit

 

/usr/syno/synoman/webman/modules/ControlPanel/modules/upgrade.cgi

 

then remove pipe '|' and the sed part off the file and save.

Link to post
Share on other sites

Is there any way to check, which version i am at? I've tried multiple times to update, but i'm not sure now.

I was hacked and have afterwards cleaned the files off, so it's now clean.

However i'd like to stay away from any future infections, so i'd like to be sure i'm now in the clear.

Link to post
Share on other sites

Is there any way to check, which version i am at? I've tried multiple times to update, but i'm not sure now.

I was hacked and have afterwards cleaned the files off, so it's now clean.

However i'd like to stay away from any future infections, so i'd like to be sure i'm now in the clear.

Link to post
Share on other sites

Fortunately mine didn't get hacked, however I would like to do an update.

 

When I tried to follow the instruction mentioned by costib, I am able to click on that "update now" button but it doesn't give me any response but only a blank window.

Anyone knows what's going on?

 

Vid describing the problem: http://www.youtube.com/watch?v=VC3_Gam9_48&feature=youtu.be

Link to post
Share on other sites

Fortunately mine didn't get hacked, however I would like to do an update.

 

When I tried to follow the instruction mentioned by costib, I am able to click on that "update now" button but it doesn't give me any response but only a blank window.

Anyone knows what's going on?

 

Vid describing the problem: http://www.youtube.com/watch?v=VC3_Gam9_48&feature=youtu.be

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.