Jump to content
XPEnology Community

Перенаправление HTTP на HTTPS


Recommended Posts

Здравствуйте,  в настройках сети стоит галка автоматически перенаправлять http на https, но почему то при входе через http браузеры выдают 

 

400 Bad Request

The plain HTTP request was sent to HTTPS port

Link to comment
Share on other sites

Только что, Olegin сказал:

А https перед адресом хрени набирать не пробовали? И еще, если на хосте не стоит ssl сертификат, то браузеры еще будут ругаться и на его отсутствие.

Да в том то и дело что если я вручную набираю https то он нормально заходит а вот автоматически не перенаправляет. Сертификат установлен и работает.

Link to comment
Share on other sites

Только что, Kizilkum сказал:

значит что то с адресом накосячили.

У меня по этому адресу работал owncloud на debian и нормально работает перенаправление. Так что с адресом не может ничего быть.

Link to comment
Share on other sites

тогда зачем вы тут тему создали?

или порт закрыт или адрес косячный, других вариантов просто нет

причем эти два фактора могут находиться в любой части цепочки между клиентом и сервером

Edited by Kizilkum
Link to comment
Share on other sites

Только что, Kizilkum сказал:

тогда зачем вы тут тему создали?

или порт закрыт или адрес косячный, других вариантов просто нет

потому что устанавливаю XPenology и на нем не работает перенаправление, поэтому и спрашиваю тут.

Link to comment
Share on other sites

4 минуты назад, USemmy сказал:

потому что устанавливаю XPenology и на нем не работает перенаправление, поэтому и спрашиваю тут.

У хрени как раз работает, только порт по https тот который вы настроили (по умолчанию был 5001). Настройте переадресацию в роутере (или что там у вас стоит на входе) 443->5001

Edited by Olegin
Link to comment
Share on other sites

2 минуты назад, Olegin сказал:

У хрени как раз работает, только порт по https тот который вы настроили (по умолчанию был 5501). Настройте переадресацию в роутере (или что там у вас стоит на входе) 443->5001

так там стоят настройки переадресации такие же как у owncloud были

Link to comment
Share on other sites

8 минут назад, USemmy сказал:

так там стоят настройки переадресации такие же как у owncloud были

 

с таким подходом прямой дорогой на овнклауд форум, спрашивать какие порты используются.

Link to comment
Share on other sites

1 минуту назад, Olegin сказал:

Только порты у owncloud и хрени по ssl случаем не разные?!

я поставил перенаправление портов на 5001 и теперь даже при вводе 5000 он нормально перенаправляет на 5001, но все равно если я введу не через https он выдает ошибку 400

Link to comment
Share on other sites

1 минуту назад, Lordbl4 сказал:

 

с таким подходом прямой дорогой на овнклауд форум, спрашивать какие порты используются.

зачем мне у них спрашивать если он работает как положено?

Link to comment
Share on other sites

1 час назад, Olegin сказал:

2 USemmy: Киньте таблицу маршрутизации на хрень в PM.

там как таковой маршрутизации нет есть прописанное перенаправление запросов по портам 80 443 5000 5001 на хрень

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...