qwertyqwerty

Questions avant migration de 5.2 à 6.1.x...

Recommended Posts

Bonjour à tous,

 

Après avoir lu différents posts sur le passage sur mon NAS de  DSM de 5.2 en 6.1.x via le loader de Jun que je souhaite réaliser, il me reste quelques parts d'ombre que je souhaiterais lever avant le "grand saut".

Tout d'abord, pas de questions directes sur le tutoriel de Polanskiman qui est admirablement réalisé, mais plutôt des questions annexes, qui pourront paraître anodines aux yeux d'experts sur le sujet, mais qui ne le sont pas pour le profane que je suis.

 

Ma configuration matérielle en bref :

- Carte mère MSI B150M PRO-VD D3 - Chipset B150 - Socket 1151,

- Processeur : Intel Pentium G4400,

- 3 HDD WD Red 6 To en 1 seul volume SHR, système de fichier : ext4.

 

Mes interrogations :

- 1/ Est-ce vraiment nécessaire de passer de 5.2 en 6.1.x, les évolutions du DSM sont-elles significatives pour un utilisateur que je qualifierais de lambda que je suis en terme de sécurité et fonctionnalité (stockage de données personnelles, photos, rushs vidéos, multimédia, utilisation de l'applicatif DSVideo principalement, partage de dossiers "privés" pour chaque membre de la famille) ? L'avis de tous qui ont réalisé ce passage peut être intéressant.

-2/ Si pour une raison x ou y, après avoir réalisé l'installation en 6.1.x, on décide de remettre l'ancienne clé USB qui a l'ancien loader en 5.2 (surtout si l'installation en 6.1.x a échouée), le NAS sera-t-il-opérationnel au premier reobot ? J'avoue que je n'ai pas très bien compris ce que faisait la clé de boot en terme d'écriture des fichiers de configurations, si cela se faisait sur la clé, ou bien sur les HDD., ou les 2 ! Nota, j'ai bien prévu de conserver l'ancienne clé en 5.2, et d'en avoir une neuve en 6.1.x.

-3/ J'ai réalisé une sauvegarde de la configuration, sous DSM 5.2, à quoi servirait-elle ? Si tout ça passe bien lors de ma migration, si j'ai bien compris, cette sauvegarde ne devrait pas servir. Dans quel cas servirait-elle alors ?

-4/ La perte du mot de passe administrateur que j'ai pu voir sur d'autres forums m'inquiète, avec réinitialisation via le port série que je n'ai pas sur la carte mère...

   - 4.a/ Ai-je raison de m'inquiéter ? 

   - 4.b/ Comment utiliser la commande "sudo -i" ? Via un émulateur tel que Putty ? Oui mais avec quel compte, le "admin" ne fonctionnant pas si j'ai tout compris? En Telnet ou SSH ? Faut-il passer par une liaison série ?

   - 4.c/ En cas de problème, faut-il investir sur une carte série RS232 sur le NAS, ainsi que sur le PC qui devrait prendre le contrôle avant d'avoir une liaison série entre les deux machines ?

   - 4.d/ Vous l'avez bien compris, là, j'ai complètement décroché. Si quelques âmes pouvaient éclaircir ma lanterne, elles seraient les bienvenues.

-5/ Pour le Ramdisk personnalisé extra.lzma, j'avoue que là aussi, ma compréhension est proche de zéro ! Je ne devrais pas en avoir besoin, étant sur un processeur Intel, ai-je raison au moins sur ce point ? J'espère que oui, sinon mes cheveux n'ont pas fini de blanchir pour me pencher sur ce problème, si j'ai un problème de driver...

-6/ Je compte installer un quatrième HDD (même volume, toujours en SHR), vaut-il mieux le faire sous DSM 5.2, ou 6.1.x, ou bien cela n'a pas d'importance ?

 

D'avance Merci à tous pour vos retours.

 

Share this post


Link to post
Share on other sites
On 12/17/2017 at 4:53 PM, qwertyqwerty said:
1/ Est-ce vraiment nécessaire de passer de 5.2 en 6.1.x, les évolutions du DSM sont-elles significatives pour un utilisateur que je qualifierais de lambda que je suis en terme de sécurité et fonctionnalité (stockage de données personnelles, photos, rushs vidéos, multimédia, utilisation de l'applicatif DSVideo principalement, partage de dossiers "privés" pour chaque membre de la famille) ? L'avis de tous qui ont réalisé ce passage peut être intéressant.  

 

 Pas vraiment. Il y a certaines avancées surtout dans la gestion des backup et autres appli Synology. DSM 5.2 marche bien et il y a encore des personnes qui l'utilisent. Question sécurité Synology a récemment mis à jour DSM 5.2 avec des updates de sécurité. L'interface est globalement la même aussi. Pour votre utilisation 5.2 devrait suffire.

 

 

 

On 12/17/2017 at 4:53 PM, qwertyqwerty said:
-2/ Si pour une raison x ou y, après avoir réalisé l'installation en 6.1.x, on décide de remettre l'ancienne clé USB qui a l'ancien loader en 5.2 (surtout si l'installation en 6.1.x a échouée), le NAS sera-t-il-opérationnel au premier reobot ? J'avoue que je n'ai pas très bien compris ce que faisait la clé de boot en terme d'écriture des fichiers de configurations, si cela se faisait sur la clé, ou bien sur les HDD., ou les 2 ! Nota, j'ai bien prévu de conserver l'ancienne clé en 5.2, et d'en avoir une neuve en 6.1.x.

DSM est installé sur les disques dure et non sur la clef USB. La clef usb sert a démarrer DSM uniquement. Dans une vraie box Synology il y a une puce intégré dans la carte mere qui fait la même chose. Le loader ne fait que émuler cette puce.

Si l'installation est initialisée (c'est à dire que vous avez fourni le fichier PAT et avez confirmé) cela ne sera plus possible d'utiliser votre clef usb avec Xpenoboot 5.2 car DSM 6 s'installera sur les disques dures. En somme tant que DSM n'est pas installer sur les disques dur vous pouvez remettre votre clef usb avec Xpenoboot 5.2

 

 

 

On 12/17/2017 at 4:53 PM, qwertyqwerty said:
3/ J'ai réalisé une sauvegarde de la configuration, sous DSM 5.2, à quoi servirait-elle ? Si tout ça passe bien lors de ma migration, si j'ai bien compris, cette sauvegarde ne devrait pas servir. Dans quel cas servirait-elle alors ?

Elle servira que si vous restez en 5.2. Une nouvelle re-installation de 5.2 par example. Il ne faut pas utiliser la sauvegarde de configuration de DSM 5.2 sur DSM 6.

Une fois sur DSM 6 faite une sauvegarde de la configuration.

 

 

 

On 12/17/2017 at 4:53 PM, qwertyqwerty said:
-4/ La perte du mot de passe administrateur que j'ai pu voir sur d'autres forums m'inquiète, avec réinitialisation via le port série que je n'ai pas sur la carte mère...    - 4.a/ Ai-je raison de m'inquiéter ? 

   - 4.b/ Comment utiliser la commande "sudo -i" ? Via un émulateur tel que Putty ? Oui mais avec quel compte, le "admin" ne fonctionnant pas si j'ai tout compris? En Telnet ou SSH ? Faut-il passer par une liaison série ?

   - 4.c/ En cas de problème, faut-il investir sur une carte série RS232 sur le NAS, ainsi que sur le PC qui devrait prendre le contrôle avant d'avoir une liaison série entre les deux machines ?

   - 4.d/ Vous l'avez bien compris, là, j'ai complètement décroché. Si quelques âmes pouvaient éclaircir ma lanterne, elles seraient les bienvenues.

 

Si vous faites les choses comme il faut je ne vois pas pourquoi vous perdrez votre mot passe. Si cela vous tracasse créez 2 comptes admin. Pas de carte série nécessaire. Cela ne marchera pas de toute façon car il faut que le port série soit reconnu par le Bios. Votre carte comporte un header serie donc vous avez deja un port serie. Le fabriquuant n'a juste pas fourni le cable avec le port mais le port série y est bel et bien.

Pour les commandes linux je recommande de faire un peu de google et de vous éduquez un peu sur comment marche les commandes. Cela vous sera utile.

 

 

 

On 12/17/2017 at 4:53 PM, qwertyqwerty said:
5/ Pour le Ramdisk personnalisé extra.lzma, j'avoue que là aussi, ma compréhension est proche de zéro ! Je ne devrais pas en avoir besoin, étant sur un processeur Intel, ai-je raison au moins sur ce point ? J'espère que oui, sinon mes cheveux n'ont pas fini de blanchir pour me pencher sur ce problème, si j'ai un problème de driver...

Le ramdisk contient des drivers (modules) permettant a du materiel d'être reconnu par DSM. Cela est parfois nécessaire car DSM n'intègre que les drivers (modules) du materiel incorporé dans une vraie Box Synology. Ce qu'il y a de plus important lors de l'installation avant toute chose c'est la carte réseau et le contrôleur de disque. Sans drivers pour la carte réseau pas d'accès réseau. Sans driver pour le contrôleur disque, pas de donnée.

Dans votre cas vous avez un carte réseau RTL8111H. Le driver pour cette carte je pense est normalement le module r8168.ko et est inclu dans le ramdisk personnalisé de IG-88

 

 

 

On 12/17/2017 at 4:53 PM, qwertyqwerty said:
6/ Je compte installer un quatrième HDD (même volume, toujours en SHR), vaut-il mieux le faire sous DSM 5.2, ou 6.1.x, ou bien cela n'a pas d'importance ?

Faites le avant, même si cela n'a pas vraiment n'importance.

 

 

Conclusion: avant de vous lancez et de regretter, faites tout simplement un test avec un disque vierge. Simplement éteignez vos Box, retirez tous les disques en mémorisant bien leur ordre de connection sur la carte mere. Mettez un disque dure vierge, branchez la clef usb avec le loader de Jun pour DSM 6 et avec le ramdisk personnalisé. Démarrez. Vous verrez bien si ca marche ou pas.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir,

 

Merci Polanskiman pour ces réponses pertinentes.

 

L'idée de faire un test sur un disque vierge est vraiment une bonne idée qui ne m'était pas venue à l'esprit, d'autant qu'il devrait y en avoir un dans la hotte du Père Noël :D. Si ça se passe bien, je tenterais alors peut-être le drop de la mise à jour.

 

Petite question complémentaire, la mise à jour, si elle se passe bien, permet de récupérer tous les partages des fichiers, avec le mêmes droits d'accès, ou bien faut-il tout refaire à l'aide du compte administrateur ?

 

Encore Merci.

Share this post


Link to post
Share on other sites

Bonsoir à tous,

 

Je poursuis ma volonté de mettre à jour en passant de 5.2 à 6.1x, mais je n'ai osé franchir le pas ne sachant pas quoi donner comme information au moment de valider l’installation.

 

L'état de ce qui a été réalisé :

- Création de la clé de boot en 6.1.x OK,

- Sortie des 3 HHD pour tester la configuration avec un 4° HDD vierge en 6.1.x (fichier "DSM_DS3615xs_15217.pat").

- Test réalisé fonctionnel OK sur le 4° HDD vierge.

- Remise en place de l'ancienne clé HDD de boot en 5.2 + 3 anciens HDD OK.

- Sauvegarde de la majeure partie des données OK.

 

- C'est à partir de là que mes questions commencent à se poser :

    - Remise en place de la clé de boot 6.1.x qui a servi aux tests OK.

    - 1/ Lors du boot, 1° question : Je pense que le choix à utiliser est le premier "Baremetal with Jun's Mod ver 1.02b", je ne pense pas qu'il faille choisir le second "... Reinstall" ?

    - 2/ Une fois le boot lancé, avec la première option, et avoir lancé le Web Assistant, j'ai le statut "pouvant être migré", et là 2 choix s'offrent à moi via un clic droit : "Connecter" ou "Installation", lequel choisir ?

    - 3/ Si on choisi "Connecter", une boite de dialogue indiquant ce message " Nous avons détecté que les disques durs de votre DS3615xs actuel a été supprimé à partir d'un précédent DS3615xs et l'installation d'un tout nouveau DSM est demandée avant de continuer." Ce message me faisant peur, je n'ai pas osé continuer en cliquant sur le bouton "Installer". J'ai donc éteins le NAS. La raison de mon inquiétude, je n'ai supprimé aucun disque dur ! Sans doute cette peur est inutile, mais je préfère faire appel aux spécialistes de ce forum avant de faire des bêtises.

    - Remise en place de la clé de boot 5.2, et reboot, RAS le NAS fonctionne normalement en 5.2.

 

- 4/ Ce message concernant la "suppression de disques durs" est-elle normale ? Ne faut-il pas recréer une nouvelle clé de boot 6.1x, le test réalisé précédemment n'aurait-il pas inscrit des données sur la clé mémorisant l'utilisation d'un seul HDD, et lors de la mise en place avec les 3 HDD de données, cela aurait-il pu provoquer ce message suspect à mes yeux ?

 

D'avance Merci pour vos retours afin de me rassurer sur mes 4 questions inutiles, ou bien de me dire où j'ai pu réaliser une erreur.

Share this post


Link to post
Share on other sites

Bonsoir à tous,

 

Mes questions précédentes étaient inutiles, après multiples recherches sur le web, le messages qui m'a inquiété " Nous avons détecté que les disques durs de votre DS3615xs actuel a été supprimé à partir d'un précédent DS3615xs et l'installation d'un tout nouveau DSM est demandée avant de continuer." était tout à fait normal, un clic sur installer, et la mise à jour se fait toute seule, en prenant bien soin de lire les questions avant de répondre, et de bien choisir la mise à jour du système.

Je n'ai vu que trop tard le petit bouton 'installation manuelle" ou quelque chose du genre, et j'ai donc du attendre le chargement automatique du .pat, alors que j'avais bien chargé ce fichier auparavant !!!

L'augmentation du Volume est en cours avec le 4° HDD. Petit détail, il me semblait que pour réaliser cette augmentation de volume, nous trouvions dans la version 5.2 le menu "Gérer" dans la partie "Volume" du "Gestionnaire de stockage", alors que je ne l'ai trouvé qu'actif (le menu "Gérer") dans la partie "Groupe Raid" dans cette version 6.1.4.

La mise à jour avec le DSM DSM 6.1.4-15217 Update 5 demandée après installation (la dernière à jour à l'écriture de ce post) s'est bien passée.

Ma température du processeur est toujours figée vue par DSM à 40°C vu dans le "Centre d'infos" du "Panneau de configuration", petit bug ou manque de driver, mais anodin.

 

Que cette petite expérience puisse profiter à tous, avec comme bonne idée de tester la mise à jour de DSM et loader avec un HDD neuf avant de réaliser une augmentation de Volume.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now