greg.one

Atheros Alt1c.ko

Recommended Posts

I have had difficulty getting my onboard network chip recognised by Jun's latest loader 1.02b.

 

While the Alt1c.ko module was in the extra.lmza it didn't work. I recompiled the driver against the latest source and it now works for me.

 

http://s000.tinyupload.com/?file_id=95307107807868237014

 

Is the url.

 

Another issue I discovered which may or may not help someone else is that I checked my MAC address in Win 7, recorded it and edited the grub file. After further trouble shooting I was still unable to find the installation on the network, I then loaded on Ubuntu 16.04. Checking the network MAC in Ubuntu provided a completely different MAC address -  the assumption would be that windows spoofs the MAC for some reason? 

 

I don't know if there's anyway of checking the 'real' MAC address within windows, I used the Ubuntu one with the recompiled module and put it all in synoboot and now it gets discovered on the network.

 

I still have to load in 6.1 pak file. 

 

Thanks to IG-88 and Jun for all the tips scattered around the forum enabling me to get this far. 

Edited by greg.one

Share this post


Link to post
Share on other sites

on what loader of the three hardware types did you test?

whats the latest source for you? the actual synology kernel source 15152 or a source from external like atheros?

the module in question is provided by jun, i only exchange them if there are reported problems like the ixgbe.ko with the new 4.2 extra.lzma

if its just the 15152 from synology i already have the modules as they are in the synology default config when compiling, its just a few seconds to make them part of the 4.2 release and you can test it then

Share this post


Link to post
Share on other sites

Hi,

Juns loader 1.02b had the driver in already but it was not discoverable on the network.

I just used the 15152 bromolow source with the included driver. Nothing new.

It's for the 3615xs hardware.

I put it on the extra.lrma and it was discoverable on the network.

Thanks

Greg

Sent from my D5803 using Tapatalk

Share this post


Link to post
Share on other sites

thanks i will replace it in all the versions with a freshly compiled one in the 4.2 version (planed for this evening)

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.