IG-88

Driver extension jun 1.02b/DSM6.1.x for 3615xs / 3617xs / 916+

Recommended Posts

2 часа назад, flyride сказал:

Try loader 1.02b, DSM 3615 6.1.7 update 3 (15284), no extra.lzma

 

Thanks for reply.

I have tried different loaders starting xpenoboot 5.2-5967.1. No hard disk found without modified extra.lzma(the whole problem is in intel c602 chipset). The motherboard use Intel® Rapid Storage Technology (Intel® RSTe) to connect hard drives(via Mini-SAS SFF-8087), there is also has Intel ESRT2 (based on LSI), but it does not have pass-through access mode, and even a virtual disk is not defined in DSM.

 

1133337837_.thumb.png.36781d055c4b39dd69729531e54c9aa9.png

 

Edited by AlterEgo

Share this post


Link to post
Share on other sites

Use AHCI mode if you can.  Discrete LSI controllers work with the 3615 image but I don't know if ESRT2 is supported differently.

 

Share this post


Link to post
Share on other sites
10 часов назад, flyride сказал:

Use AHCI mode if you can.  Discrete LSI controllers work with the 3615 image but I don't know if ESRT2 is supported differently.

 

AHCI Capable Sata Controller has only two ports, not enough for me. But you are right, I have no problems with this controller.

My tests show that esrt2 is not compatible with DSM. Looks like I'll have to use a discrete HBA card from LSI or other brand.

Edited by AlterEgo

Share this post


Link to post
Share on other sites

hi. hp DL380 gen9.  1.02b Loader for dsm6.1 3617sx with extra.lzma 4.8. 

problem is no hdd.

 

slot 0 is p440ar, no hdd attach.

slot 3 is p840, 9 disks(1.8T x 6=raid5, 300G x 3=raid5).

so how do i set sataport map in grub.cfg?

sataportmap=0002 ? 02 ?how can i do?

 

Share this post


Link to post
Share on other sites

 

Hello there, Can we add things to the driver

PCI\VEN_10EC&DEV_8136 Device Names:

infoRealtek RTL8101 Family PCI-E Fast Ethernet NIC (NDIS 6.0)
infoRealtek RTL8101E Family PCI-E Fast Ethernet NIC (NDIS 6.0)
infoRealtek RTL8139/810x Family Fast Ethernet NIC

Share this post


Link to post
Share on other sites

I-219V is 8086 15bc for me it does not seem to be seen anyone have this NIC working and tell me what I a missing trying extra.lmz but no go. Any Help is greatly appreciated. Is this the 2019 driver can it be added?

Share this post


Link to post
Share on other sites

I look around about missing symbols and try do something like this:

 

https://github.com/blondak/xpenology-kernel-symbols

 

because i'm on HP N40L i'm waiting for pci-e serial card to debug this, but feel free to try it too, it exports missing symbols to be able compile ata drivers (now i have probably kernel panic) but after inserting xpenology.ko i'm able insert modules which uses syno_libata_index_get.

Share this post


Link to post
Share on other sites
On 11/27/2017 at 12:39 AM, IG-88 said:

cxgb3: Chelsio Communications T3 10Gb (firmware needed), N310E/B320E/S302E

 

Hello. I've been planing to upgrade my XP Nas with a faster Transferconnection to move some large files from PC to them. So my nas runs very well since a couple of years. But only with lan. So for other connections to any windows server i use a Chelsio N320SE-SR. Is it not the same T3 Model ? And what exactly did i need to use this card with my xp nas? Whats mean firmware needed?

 

 

Share this post


Link to post
Share on other sites
12 hours ago, Spitzbube1984 said:

Whats mean firmware needed?

its more like a reminder to check the log about messages about missing firmware files

the extra.lzma does contain fw files for cxgb3, you can check by opening the file with 7z, under /usr/lib/firmware you will see the files provided ans in your cas you wil see a folder with the name cxgb3 that contains files, no guarantee that it will work for your card, for some cards with the same name there is different hardware, the driver supports it but it will need matching firmware so its possible that one card works an the other will complain about missing firmware files

Share this post


Link to post
Share on other sites

Plz add lan driver for DSM6.2.x for 3615xs updated and stopped working please save me! there is important data! i have JUN'S LOADER v1.03b - DS3615s 

Share this post


Link to post
Share on other sites
On 9/15/2019 at 10:54 PM, ruslan11 said:

DSM6.2.x for 3615xs

 

i haven't done anything for a while but there is still no new kernel source from synology and the old beta source is about 2 years old now

there are two possible reasons why the old 6.1 drivers do not work with 6.2, the driver signing is kicking in so all non synology drivers will not work or there are differences in kernel source (or kernel options) that do not match

i'd suggest you downgrade to 6.1 or put in a nic that is working ootb with the drivers synology delivers with its dsm

like intel e1000e or igb or  ixgbe, maybe a older Tehuti based 10G card will do (i still have one that i bought as qnap add on card)

e1000e: Intel PCIe PRO/1000 82563/82566/82567/82571/82572/82573/82574/82577/82578/82583/Gigabit CT Desktop Adapter/PRO/1000 PT/PF/I217-LM/V/I218-V/LM/I219 LM/V

igb: Intel Gigabit Ethernet 82575/82576/82580/I350/I210/I211

ixgbe: Intel 10 Gigabit

Tehuti tn40xx

i guess older Gigabit CT Desktop nic's will be available as they were around in numbers (i still have one of this too for testing)

in general all cards listed by synology as compatible with 3615 will do, so you might go to the synology website an check that out

 

don't expect any new drivers in the next 1-2 month, my ASRock C2550D4I died and i still have to use the hardware of my backup system but i'm still waiting for the intel 9100T cpu to hit the market to build a new "primary" system, i will look into drivers and do tests when that new hardware is complete (its just the cpu that is missing)

 

 

Edited by IG-88

Share this post


Link to post
Share on other sites

My NIC on motherboard is Realtek Gigabit Ethernet RTL8110SC, why still can't detect the station ?

 

Note-My PC :

Motherboard Gigabyte GA-MA69VM-S2

CPU AMD Athlon X2 5200+

Xpenology = DS3615xs 6.1 Jun's Mod V1.02-alpha

 

please help me

Edited by Polanskiman
No need for quoting the OP. Read the rules of the forum.

Share this post


Link to post
Share on other sites
9 hours ago, rianarea said:

My NIC on motherboard is Realtek Gigabit Ethernet RTL8110SC, why still can't detect the station ?

the driver is supported and present (r8169)

i'd suggest you use a different pci/pcie card to get it up and running and check the log alter installation about the onboard nic

the other was is much more comlicated as it needs a serial (null modem) cable from your nas to another machine to see the local console so you can check wahts writen on the local console when driver laods and you also can login and check the log

 

beside this there are other things depending on your it knowledge

check that dhcp in local network is working, use synology assistant program (download from synology) to find dsm systems in network, check if led on nic are on/blinking (in most cases there are led's for link status), try another system like a live linux to boot and use network

 

Share this post


Link to post
Share on other sites

that's what's left (old extra.lzma v3.0 and 3.2)

http://s000.tinyupload.com/?file_id=09441430823897482943

might not work at all, no support, no further tests from my side as i don't have the old 6.1 build environment and it takes more time to work for 6.2 then expected

when it comes to "more universal" then the 6.0 was capable of more hardware then 6.1/6.2 and when in comes to a recent DSM (6.2) then ahci controllers are the way to go (imho)

https://xpenology.com/forum/topic/19854-sata-controllers-not-recognized/?tab=comments#comment-122709

 

Share this post


Link to post
Share on other sites
13 часа назад, IG-88 сказал:

that's what's left (old extra.lzma v3.0 and 3.2)

http://s000.tinyupload.com/?file_id=09441430823897482943

might not work at all, no support, no further tests from my side as i don't have the old 6.1 build environment and it takes more time to work for 6.2 then expected

when it comes to "more universal" then the 6.0 was capable of more hardware then 6.1/6.2 and when in comes to a recent DSM (6.2) then ahci controllers are the way to go (imho)

https://xpenology.com/forum/topic/19854-sata-controllers-not-recognized/?tab=comments#comment-122709

 

Unfortunately, not working properly. My NAS show HP logical volume now, but with zero size. See screenshorts. And this volume not showing in fdisk into console.

Снимок экрана_2019-12-04_09-57-04.png

Снимок экрана_2019-12-04_09-57-28.png

 

May you have a old "cciss" kernel module for this loader?

 

Edited by RodionD

Share this post


Link to post
Share on other sites
On 12/3/2019 at 8:07 PM, IG-88 said:

no support, no further tests from my side

sorry if want to you need to do it on your own

there will be a hpsa driver from the kernel in the next extra.lzma for 3615/17 and thats from my side for now

maybe you change to open media vault?

Share this post


Link to post
Share on other sites

Hi IG-88 , thank you very much for the work done, I use and say kind words to you ) I have a question. My favorite version is 6.1.7 3615sx ,it is not capricious and I bet on almost everything . Here is decided to do edit in image on your example in this topic. Everything worked !!! I wanted to ask, in a few words, how this loader is better from jun 1.0.2 b?! It has more drivers and is more versatile ?! Thank you again for your hard work !!

Share this post


Link to post
Share on other sites

Hello everyone, im currently trying out on my Synology device to expand a single x1 slot to multiple x1 slots (board from aliexpress).

 

the chipset on the expansion board is Pericom Pericom PI7C9X bridge chip.

 

Could anyone make me a extra.lzma with the current given extra.lzma that exists, including my bridge chip ?

This would be nice, as i run out of pci slots but my cpu is able to handle more, so given that we can include this driver all custom case build synology machines like mine can raise more and more pci expension cards (sata controllers etc).

 

You could send it to me in a pm or post it here, i would very much appreciate it if it could be done in a rapid urge, as im very excited to do this ''testing'' around.

(expension board; https://nl.aliexpress.com/item/4000625549082.html?spm=a2g0s.9042311.0.0.511b4c4d1hUeSW)

 

Thank you.

Share this post


Link to post
Share on other sites
Posted (edited)

I forgot to mention im running ds3615xs. Is this also in the kernel? Or do i need a extra.lzma?

 

Edit : misread your responce thank you for helping in advance. I really shouldnt stay more awake at 1am 😂

Edited by CreerNLD
Too sleepy didnt see well ^^

Share this post


Link to post
Share on other sites
Posted (edited)

from the link

The device is supported by kernel versions 2.6.4 and newer

what i wrote

1 hour ago, IG-88 said:

should be already in the kernel (3.10.105 for 3615/17, 4.4.59 for 918+)

 

>2.6.4 and 3615 uses kernel 3.10.105 -> ...

 

only thing from the link ist a pci/pcie bridge and you are looking to a divice with a pcie/pcie bridge, maybe you information about the chip misses something (like more numbers and letters)

 

Edited by IG-88

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.