Xpenology and SAS Controller - HBA


Recommended Posts

I would disable as much ports (usb and onboard SATA) as you can.

 

then work from there

 

1st set the SATA / SAS / msata ports....eg work out how many and convert to hex

2nd then E-SATA if you need it.

3rd then usb ports

 

if there is just one esata port use 0x1xxxxx, that is 1 x esata port and the xxxxx are the hex code you used for the SATA etc.

 

it's confusing and complicated fudge.... but once you get it right will work fine.

 

also I would suggest not hiding the usb stick (eg entering PID and VID in menu_nano.lst file) until you have sorted the above out.

as then you can see in storage manager if the usb port is getting detected as a SATA port with you hex codes.

 

once sorted, then go back and hide the usb stick

Link to post
Share on other sites
  • 2 months later...

Hi Stanza,

 

you wrote, that you are using a "Dell H200 SAS Controller Flashed to LSI-9211-8i IT Firmware"

 

I have the same DELL H200 Controller.

 

My plan is to use this controller in my new hardware based NAS Box based on a AsRock Q2900M Mainboard.

 

 

Could you please send me a Link to a detailed Guide how to crossflash this H200 to a working LIS Firmware?

 

I would like to use the latest available DSM 5.1 5022 Update 3 version.

 

Thanks a lot

 

cheers

 

Merlin

Link to post
Share on other sites
Hi Stanza,

 

you wrote, that you are using a "Dell H200 SAS Controller Flashed to LSI-9211-8i IT Firmware"

 

I have the same DELL H200 Controller.

 

My plan is to use this controller in my new hardware based NAS Box based on a AsRock Q2900M Mainboard.

 

 

Could you please send me a Link to a detailed Guide how to crossflash this H200 to a working LIS Firmware?

 

I would like to use the latest available DSM 5.1 5022 Update 3 version.

 

Thanks a lot

 

cheers

 

Merlin

 

You can easily find how to do this if you just Google it... :wink:

 

To make it extra easy for you check this link:

 

http://blog.michael.kuron-germany.de/20 ... nt-page-1/

Link to post
Share on other sites
Hi Stanza,

 

you wrote, that you are using a "Dell H200 SAS Controller Flashed to LSI-9211-8i IT Firmware"

 

I have the same DELL H200 Controller.

 

My plan is to use this controller in my new hardware based NAS Box based on a AsRock Q2900M Mainboard.

 

 

Could you please send me a Link to a detailed Guide how to crossflash this H200 to a working LIS Firmware?

 

I would like to use the latest available DSM 5.1 5022 Update 3 version.

 

Thanks a lot

 

cheers

 

Merlin

 

You can easily find how to do this if you just Google it... :wink:

 

To make it extra easy for you check this link:

 

http://blog.michael.kuron-germany.de/20 ... nt-page-1/

 

afaik currently i would NOT recommend to use P20 fw on LSI HBA's.... http://xpenology.com/forum/viewtopic.php?f=2&t=4985

 

btw...in some weeks i'll get my new HBA LSI-9300-16i... hope it'll be supported by current drivers

Link to post
Share on other sites

Thanks ROKH and snoopy78

 

I already knew this BLOG Post from Michael Kuron Site.

The reason why I was asking here in this Thread was the fact that it was already mentioned, that the P20 is maybe not the best Firmware. Additionally, I searched Youtube and I found the procudure for a H310. It was a little bit different as decribed in this article.

 

And it was good to ask. Now I got a Link (thanks snoopy) where more details were described.

Now I know how to crossflash AND which Firmware I have to flash (P19).

 

 

Thanks again!

 

merlin

Link to post
Share on other sites
  • 2 weeks later...

just an question to all the guys using an HBA..

 

i've got my new system where i have

10* SATA on MB X9SRL-F

8* SAS/SATA on M1015 with IT flash

 

now i got for a real great price (but i need 2 wait for some more weeks) the latest LSI 9300-16i HBA

 

does anyone know how the DSM will behave with more than 26 HDD's?

how's the calculation then?

Link to post
Share on other sites
  • 3 weeks later...

Think from memory I gave more than 26 a whirl once.

Had to change the maxdisks setting but it seemed fine.

 

MDADM has a limit on the max drives in a mirror set.... so that might be the limitation...

 

eg /dev/md0 and /dev/md1 (OS and swap space) are mirror sets which go across all drives......

 

.

Link to post
Share on other sites
  • 1 month later...

I have the same issue.

I have 4 disk connect to Intel C602 configured to AHCI and 8 disk connect to LSI 2308 IT mode.

It only recognize 5 of them. Also I have changed the value in synoinfo.conf and hence you see disk 22 with usb.

Anyone else have same issue? I could not upload the img...

Link to post
Share on other sites

here is my output from dmesg:

[ 4.568985] sd 1:0:0:0: [sdb] Attached SCSI disk

[ 5.087602] sd 6:0:0:0: [sdg] Attached SCSI disk

[ 7.907754] sd 7:0:0:0: [sdh] Attached SCSI disk

[ 8.107983] sd 7:0:1:0: [sdi] Attached SCSI disk

[ 8.397332] sd 7:0:2:0: [sdj] Attached SCSI disk

[ 8.657683] sd 7:0:3:0: [sdk] Attached SCSI disk

[ 8.934245] sd 7:0:4:0: [sdl] Attached SCSI disk

[ 9.177030] sd 7:0:5:0: [sdm] Attached SCSI disk

[ 9.399217] sd 7:0:6:0: [sdn] Attached SCSI disk

[ 9.645346] sd 7:0:7:0: [sdo] Attached SCSI disk

 

[ 4.035990] ata1: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600100 irq 88

[ 4.035995] ata2: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600180 irq 88

[ 4.035998] ata3: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600200 irq 88

[ 4.036001] ata4: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600280 irq 88

[ 4.036004] ata5: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600300 irq 88

[ 4.036007] ata6: SATA max UDMA/133 abar m2048@0xd1600000 port 0xd1600380 irq 88

[ 4.047231] ata7: SATA max UDMA/133 abar m8192@0xd1500000 port 0xd1500100 irq 89

Link to post
Share on other sites
  • 3 months later...

Is there no chance in the world to get more than a total of 12 INTERNAL SATA disks up and running in this last code: DSM_DS3615xs_5592 + Update3.

Have 16 SATA disks installed andbooted on USB stick and installed....but only see 12 internal disks the rest..is not visual. Even after my knowledge all year 2014 to edit hexcodes I add to have 22 disks but still only showing 12...only difference I get is that the usb stick get higher number and that Disk manager Overview says 11 slots free. :smile:

 

Do I really need to mount my internal drives through the back and connect them to external ESATA ports?

Link to post
Share on other sites
Is there no chance in the world to get more than a total of 12 INTERNAL SATA disks up and running in this last code: DSM_DS3615xs_5592 + Update3.

Have 16 SATA disks installed andbooted on USB stick and installed....but only see 12 internal disks the rest..is not visual. Even after my knowledge all year 2014 to edit hexcodes I add to have 22 disks but still only showing 12...only difference I get is that the usb stick get higher number and that Disk manager Overview says 11 slots free. :smile:

 

Do I really need to mount my internal drives through the back and connect them to external ESATA ports?

 

I had power problem inside chassi. I just check all and change hexcode to 22 disks then all is fine.

Link to post
Share on other sites
Is there no chance in the world to get more than a total of 12 INTERNAL SATA disks up and running in this last code: DSM_DS3615xs_5592 + Update3.

Have 16 SATA disks installed andbooted on USB stick and installed....but only see 12 internal disks the rest..is not visual. Even after my knowledge all year 2014 to edit hexcodes I add to have 22 disks but still only showing 12...only difference I get is that the usb stick get higher number and that Disk manager Overview says 11 slots free. :smile:

 

Do I really need to mount my internal drives through the back and connect them to external ESATA ports?

 

I had power problem inside chassi. I just check all and change hexcode to 22 disks then all is fine.

Link to post
Share on other sites
  • 4 weeks later...
  • 8 months later...

need help.

 

ata13: DUMMY

ata14: DUMMY

 

System:

Intel Core i7-5820K

Gigabyte GA-X99-UD4 Mainboard Revision 1.1

10 Ports 6Gbps AHCI SATA III Host Adapter

XPEnology DSM 5.2-5592

 

ata1-10 Mainboard work well

ata11,12,15,.......16,17,18,19,20 on Sata-Cards work well.

 

I from German, my english is not very good

Link to post
Share on other sites
  • 1 month later...

Hi there,

 

anyone focused the Issue that the changed lines in synoinfo.conf are missing/changed after reboot ?

I cant figure it out, some posts before it was mentioned for /etc but not for etc.defaults

 

thanks for a reply on this matter !

Link to post
Share on other sites

if u only modify the /etc/synoinfo.conf. values..it's active immediately...BUT u need to edit the /etc.defaults/synoinfo.conf too...to make them permanent (reboot permanent)....

 

for me (variables for my system) i run this for both files to modify it permanently...

 

"

cat synoinfo.conf>synoinfo.conf.bak | sed -i -e 's/internalportcfg="0xfff"/internalportcfg="0x0fffff"/' -e 's/esataportcfg="0xff000"/esataportcfg="0x00000"/' -e 's/usbportcfg="0x300000"/usbportcfg="0x300000"/' -e 's/maxdisks="12"/maxdisks="21"/'synoinfo.conf

"

Link to post
Share on other sites
  • 3 months later...

This thread seems to be the closest to my problem as I can find. I have a 45Drives Storinator enclosure that I am "still" trying to get working with the DSM software. I have tried modifying the internalportcfg, esataportcfg, and usbportcfg data multiple times to no avail.

 

Most of the time, I can get it all to work as long as the system doesn't restart. As soon as it restarts, I lose all the system configuration and customizations and thus the system asks me to reinstall DSM.

 

I have attached the dmesg output if anyone at all can be of some assistance in getting this working.

https://www.dropbox.com/s/5inl0ou1eu7wp ... g.txt?dl=0

Link to post
Share on other sites
  • 3 weeks later...

Hello all,after crash i reinstalled 5.2-5644 update 5

tried to changed etc/synoinfo and et/defaults/ synoinfo

but no luck till now whenpreviosly it worked fine with my values

but i can see that these are in /satashare1-2/etc.defaults

where is it going wrong

changed max disks to 24 as well

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.