hussain

[HowTo] self-boot XPEnology

Recommended Posts

hi all

 

so this is a quick guide on how to make xpenology booting itself without usb bootloader, just like any other linux os.

 

first you need two things:

 

1- xpenology installed already

2- ubuntu or any other live distro that has gparted and syslinux.. it's ubuntu gnome 13.10 in my case.

 

now follow my steps:

 

1- boot into ubuntu live and start gparted

2- now choose the xpenology hard disk from the top right drop-down menu

 

image.png

 

3- now we need to select an unallocated space and create a fat32 partition like so

 

image.png

 

image.png

 

4- now hit apply all operations

5- now we need to manage flags on our new partition and enable boot flag

6- make a note of our new partition, in my case it's /dev/sda4

 

image.png

 

7- now close gparted, and open terminal

8- now we need to install syslinux on our new partition, so we type: sudo syslinux /dev/sda4

9- now we need to mount the partition so we copy our config, kernel and ramdisk.

i find the easiest way to mount a fat32 with read/write permission is by mounting it with disks in ubuntu:

 

image.png

 

10- now, once mounted, copy rd.gz and zImage which can be found in your usb loader into it

11- and create a file named syslinux.cfg contains:

 

default xpenology
label xpenology
menu label ^XPEnology
kernel zImage
append initrd=rd.gz root=/dev/md0 ihd_num=0 netif_num=1 syno_hw_version=DS3612xs mac1=080027649673 sn=A5GAN01967

 

12- changing the mac address and whatever parameters that suites you, and that would be all!

13- now reboot and boot from your harddrive.

 

 

regards

 

Hussain

Share this post


Link to post
Share on other sites

I get "Boot Error".

I even tried to take the ISO you made and write it on 120MB usb, and then using DD to clone it into the 134MB small paratition, I still got the same error when trying to boot from the hard drive.

wihout syslinux , I would get some other error, so its not the syslinux.

Tried many different types of configs to work on in the syslinux.cfg, and still cant seems to make it work, though with your ISP on the 128MB usb it worked like a charm.

 

any idea why?

Share this post


Link to post
Share on other sites

Got the same "Boot Error" issue on a physical machine.

On a virtual VMware machine it works as described!

(Tried with DSM 5.0 by the way.)

Share this post


Link to post
Share on other sites

I'll make the same assumptions as the OP.

You have a working NAS with an optical drive and a console.

 

1. Boot a live CD with gparted. I used the live CD iso from gparted.

2. Copy the boot partition (16Mb) from your current boot device to unallocated space on your first hard disk and flag as bootable.

Note the partition. In my case it was /dev/sda4 If yours is different, adjust the next steps accordingly.

3. Remove the live CD and boot from your current boot device.

4. At the GRUB boot screen, press 'c' and enter the following:

grub> root (hd0,3)

grub> setup (hd0)

grub> {Esc}

5. Resume booting from your current boot device.

6. Login as root. With DSM5 beta I can do this at the console. With 4.3 I use PuTTY.

7. Type fdisk -l to verify your new boot partition.

8. Mount the partition and edit grub.conf as follows:

DiskStation> mount /dev/sda4 /mnt

DiskStation> vi /mnt/boot/grub/grub.conf

change 'root (hd0,0)' to 'root hd(0,3)'

9. Poweroff, remove your current boot device, and boot from the hard disk.

Share this post


Link to post
Share on other sites

What are the downsides of this? Isn't the whole idea of the thumnbstick the ability for DSM to failover to any HD?

Share this post


Link to post
Share on other sites

The instructions from don389 is working fine on my physical hardware with DSM 5. thx :grin:

But I'm not shure if this will be a real advantage. For testing purpose a big deal but your're most flexible with a thumb drive.

Share this post


Link to post
Share on other sites