davurleon

N36L not taking disk 2-4

Recommended Posts

Hi!

 

I have recently deleted all of my disks by error and now need to setup this server anew, however, even though I am using Jun's 1.0b and it boots and seems to be working, somehow I cannot add disks 2-4 to my SHR.

They are added, and then dissappear just for the system to say that it failed, the only disk I can connect and make the system on is nr. 1, I even tried switching them around and still only nr. 1 can be made to work, what can have gone wrong?

I did switch off C1E of course, and the server is reachable I just cannot add disks.

Share this post


Link to post
Share on other sites

To check - you can see all disks in Storage Manager, but if you try to add them to a raid/shr it fails?

I don't have an N36, but had a similar problem on a bare metal system, drives would not add to expand a volume. What worked for me was to create separate volumes on each disk, then delete them, then I could add all the drives to the raid/shr. Don't know why this worked, guessing something to do with disks being initialised/partitioned and some unknown other 'magic' happening to allow the raid creation/build process to work.

You might want to check the smart status of the drives too, a failing one might interrupt the build process

 

Share this post


Link to post
Share on other sites

DSM6x do not support SHR "out of the box".

 

Quote

 

SHR on dsm6:

edit synoinfo.conf located in /etc.defaults/synoinfo. conf

 

comment out / delete

supportraidgroup="yes"

 

then add

support_syno_hybrid_raid ="yes"

 

 

 

Share this post


Link to post
Share on other sites

I have already enabled SHR, it seems as if disks 2-4 are on "non-working" ports or something, can I have made some mistake setting up the BIOS of my N36L?

Share this post


Link to post
Share on other sites

Hi again

 

I have a modded BIOS yes, set to ACHI.

The really weird part is that I tried booting the server with Windows 10 and if I run Device Manager there it says that the HDDs 2-4 are "offline" somehow, never seen that before...

Share this post


Link to post
Share on other sites

So incredibly silly, I had chosen to make the harddrives JBOD on my RAID card in an earlier installation, it was this that made them not able to be added to the server...

Something learnt today!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now