Jump to content
XPEnology Community

Ryzen 1600 X370 i211 NIC -- Success!


Recommended Posts

There seems to be a lot of questions around Ryzen, Intel's i211's and other AMD related posts but not a ton of answers to those questions.


I spent about 8 hours getting this to work and wanted to share some tips.



I originally used the 1.01 (6.0.2) JUNS loader guide and that DID NOT work. I tired the extra.lzma and also tried it with both NICs plugged in, booting to both the Intel and AMD grub... Nothing worked. It would Post, load the GRUB loader and then find.synology.com couldn't find anything.


I then used the 1.02B (6.1.3) JUNS loader guide and that worked like a charm. Make sure to the use Intel NIC port.


Also, a couple notes of my own that I couldn't find any answer to but would have like to have known when I was having issues with the 6.0.2 loader.


  • The VID and PID must be correct. The guide states this and this is because after you install DSM, DSM uses the USB drive and will look for the VID and PID.
  • The SN as far as I can tell could be anything. This is used for Synology services such as QuickConnect. DO NOT USE Quickconnect (I'll be honest here, I'm new to this and Quickconnect is a Synology service and based on what everyone including mods on here say, dont use it!)
  • The MAC address: I used my actual MAC address of my NIC... not the auto-generated one. I got this when I enabled PXE Boot because I didnt have an OS prior to install (I used https://jsfiddle.net/7Lorpu77/ to generate a SN, FYI, again it could be anything...)
  • JUN stated some issues around "C1E function". I did run into a weird issue during my initial install and disabled this as a knee-jerk reaction. I will do more testing and see if I notice any issues. This will turn the multiplier down to 6x in an "unloaded" state to save on power which is a good thing most of the time for a NAS. Not even sure if this will work while I manually set the multiplier.


The last thing I will note is my system specs:


  • GA-AX370-Gaming K7 (rev. 1.0)
  • Ryzen 1600 with Stock Cooler
  • 8GB DDR4 3000
  • 8GB SanDisk USB Drive
  • Corsair 500W 80+ PSU


**I bought a Ryzen for future growth as this is for my Homelab. I can use this as a HomePC, HTPC, or my gaming PC in the future and the Mobo/CPU will be plenty speedy. With that said, it is OVERKILL. I undervolted the Ryzen and slowed it down to 1.1V VCore (from 1.22500 IIRC) and also set the Multiplier and FSB to 20x100MHZ for a total for 2000mhz. This dropped the idle temp about 3* Celcius and also the running Wattage by about 10W. I plan to continue to test with this and drop it some more. With a cheap video card and one 1TB HDD, this setup is pulling around 58W idle.


As you can see in the image it shows up as an i3 and only 2 core are showing as working but when I SSH into the DSM, 8 of the 12 cores are working. :91_thumbsup:






Edited by cableguy
added C1E info + Loader version info
  • Like 1
Link to comment
Share on other sites

I haven't been home in a few days but I just VPN'd into my box and everything looks good. Almost 3 days of uptime and communication to another box running VM's looks good.


I havent had time to work with the C1E but will keep this thread up to date with issues and updates.

Link to comment
Share on other sites

  • 4 weeks later...
On 11/1/2017 at 12:18 AM, cableguy said:

Just updated to 6.1.3 Update 8 and all seems good and well.


Also lower m voltage some more - Running 1.025 vCore voltate and .8875 vcore SOC (whatever that is). Both are lower than stock. Still running 20x100mhz = 2000mhz.


Please report working/non-working update in the intended forum, that is:


It makes it easier for everyone to know what works and what doesn't in a single topic.

Link to comment
Share on other sites

  • 8 months later...
On 10/25/2017 at 10:31 PM, cableguy said:


As you can see in the image it shows up as an i3 and only 2 core are showing as working but when I SSH into the DSM, 8 of the 12 cores are working. :91_thumbsup:



That's awesome! Planning to get a Ryzen myself, so this is pretty comforting.


But can you fully utilize all cores in VMM? Since DSM sees the machine as having only 2 cores.

Link to comment
Share on other sites

  • 1 year later...

i had the exact same issue, i have a MSI B350m motar motherboard

i just spent a couple of hours going through the "new" loaders. none of them worked.  i'd always get to the "screen will stop updating shortly" point, but it wouldn't show up in the finder, or get an IP address at all.

i then tried the 1.02b loader, and it works a charm!  i've got a dual port intel nic in there, and as long as i plug into that, it works!  didn't have to disable anything, or change any settings.

i havent actually installed it yet, i've just got it to finally get an IP address, so fingers crossed it keeps working!

literally 5 min later.  I GOT THE 918 loader working! :D:D

Edited by willba4
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...