Jump to content
XPEnology Community

Synology DS3612xs - DSM 4.2 build 3202

Recommended Posts


my old system use below


IDE controller ALi M5229 PCI Bus Master IDE Controller

SCSI/RAID controller D347PRT SCSI Controller

SCSI/RAID controller ULi SATA/RAID Controller (M1573)


is it possible?


This box not only old but also very very old.

Not supported.

Link to comment
Share on other sites

RTL8169 - not working

D-Link DGE-530T rev B1 (Marvell 88E8001-LKJ1) - no link, no leds

D-Link DGE-528T rev A1 (D-link DLG10028A) - linked, but no ping, leds always on

noname gigabit cards from ebay on the Realtek RTL8111E, DL - no link, no leds


M/b Intel D525MW, DSM 4.2 build 3202


Your MB have one PCI slot and LOM need r8169.ko, all your list card are not supported in my build.

The fastest way to you is: insert Intel PRO-1000 PCI series NIC (e1000)


Thanks for answer

But LAN-card Intel PRO-1000 PCI are very expensive (~40USD)

M/b D525MW+2Gb RAM I bought for 800RUR (~26USD)

Your proposal does not suit me, please, add support this LAN-card on next revision

Link to comment
Share on other sites

@ HExus whats your problem with the Intel 525MW , normally the onboard Lan will work ?


normaly should folling networking cards working


-Intel 1000 PRo serie

-Realtek® 8111E

-Realtek® RTL8110SC

-Intel® Gigabit-Ethernet-Controller 82567LM

-Intel 82571EB

Link to comment
Share on other sites

Hi, i have problem on installation of xpenology system, my material is


core 2 duo E6550 & Asus P5E3 deluxe wifi i write img disk (just .img file in the rar) with Win32DiskImager, the system started but it block in Loading the kernel ...


with the ver 4.2 i have error message (cheksum invalid) and with 4.1 no error message but the os not start (block in booting kernel)


thx for help me :smile:

Link to comment
Share on other sites

  • 2 weeks later...
Is it support APU such as E-350?

Yes. Have tried it successfully on ASUS E35M1-I (AMD E-350)


Thanks for info, will try it.


This is what i have:

CASE: Cooler Master Elite 120 Advanced

CPU: AMD E-350 1,6Ghz Dual Core - Zacate (comes with the MB)

MB: Gigabyte E-350N (17cmx17cm mITX with 4 SATA ports, CPU included, Dual Channel 1066 RAM)

RAM: GeIL Black Dragon 16GB (2 x 8GB. Cheap. ZFS on FreeNAS was needing lots of RAM)

FAN: Noctua NF-S12B FLX (replaced the side 80mm fan with this one. It's really silent and has exceptional performance)

PSU: Seasonic S12II-430 Bronze 430W (overkill, but the fan doesn't spin and when it spins, it also helps the ventilation)

HDD1: Western Digital RED (WD30EFRX)

HDD2: Western Digital RED (WD30EFRX)

HDD3: Seagate Barracuda (ST3000DM001)

HDD4: Seagate Barracuda (ST3000DM001)


Additionally, these following 3 items are not compatible:


2). USB 3.0 Network Adapter 10/100/1000Mbps Gigabit LAN, RJ45

3). APC UPS ES700 VA


Sound meter: 37dBi (nice and quiet)

Watt meter: 55W in full load (wasn't really keen to measure it in idle)

Link to comment
Share on other sites



Is anybody able to help with the issue I am having which is stopping hibernation, within /var/log/messages I receive the following error over and over:


May 21 22:46:08 getty[9875]: console: TCGETS: Input/output error^M



Link to comment
Share on other sites

I succeed to install DSM 4.1 into VirtualBox, but I wasn't able to install DSM 4.2 into VirtualBox... until I found that a .IMG file could be converted into a .VDI file.

The command line to convert is :


VBoxManage convertdd DS3612xs_3202-Repack.img DS3612xs_3202-Repack.vdi


So now I'm happy to have a DSM 4.2 in VirtualBox.


Thanks guys for all your work ! It's so cool...

Link to comment
Share on other sites

This is a fantastic project, keep up the good work!


I wrote "TheBay" BIOS for HP Microserver series, to enable AHCI, but I have put that on hold at the moment till I get an N54L.


I found a perfect hardware combination for this version over the weekend and built a box running 4.2 an hour or so including assembly.


I can confirm the ASUS M5A97 LE R2.0 AMD AM3+ works perfectly and very cheap £55, it has 6x SATA 6gb/s, compatible Realtek NIC and even USB 3.0 support works perfectly!


CPU I used AMD FX6-6300 6 Core (95w Tdp) £100


Also this board supports ECC Unregistered/Unbuffered RAM


Running 7x Hitachi 5K3000 2TB's and really happy with performance, I just added an Intel Based HP HP NC360T Dual Nic which I can confirm works perfectly!


I have also added a HP NC360T (Intel) Dual NIC (PCIe 4x) which is supported out of the box :smile:



This all works so well I am selling my SuperMicro Superserver with E3-1230v2 and 32gb RAM with LSI 9207i (LSI2308) and dual redundant PSU. I was using ZFS/Solaris but much prefer the Xpenology for home use.

Link to comment
Share on other sites


Thank for your amazing work :smile:


I want to add some built in drivers in this kernel, but every kernel I compil bug :

boot is ok, install my modified .pat file ok, machine restart, boot and then poweroff/restart itself after few minutes.

I can't find the right toolchain (3.2.30 x64 or bromolow) on sourceforge nor the GPL sources for the 3202branch, so I compil with the 3201 available on sourceforge (I think this is why my kernel sucks) :sad:


I have some questions:

- What toolchain / GPL sources (arch and version) did you use to build this kernel ?

- How to create the grub_cksum.syno file (Encrypted checksum) ?

- In your futur release can you include the .config file ?




Link to comment
Share on other sites


I have some questions:

- What toolchain / GPL sources (arch and version) did you use to build this kernel ?

- How to create the grub_cksum.syno file (Encrypted checksum) ?

- In your futur release can you include the .config file ?


You should read this: http://xpenology.com/wiki/en/building_xpenology


A1. I didn't recompiler the kernel for this build, because when I repack it, Synology still not release the GPL/ToolChain for DSM 4.2-3202.

A2. This is not necessary file, just remark it from the grbu index file and can pass it, this file just for booting purpose for make sure the rd.gz and zImage not modified.

A3. As A1, so no .config file to provide, I just add some NIC drivers and repack the .pat file, so just named it as "Repack" version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...