Jump to content
XPEnology Community

SOLVED: What's the maximum number of drives?


Recommended Posts

G'day all,


Just wondering what is the max number of drives I can use to setup a decent Xpenology box?


Currently I have 2 Xpenology boxes up and running fine. (HP EX490's)


I have the following hardware and would like to combine it (either real or virtual) into a giant Xpenology NAS


Supermicro 15 bay SAS/ SATA case

Supermicro 8 bay SAS/SATA case

Intel 6 bay case


Looking to do the following


Intel case with 6 internal SATA plus an external sas card, connected to both Supermicro cases via sas expanders


So that would give me approx 30 drives


Would the number be to high?


Eg is the limit say 16drives max?





Edited by Guest
Link to comment
Share on other sites

what I would really like to know is has anyone been sucessful with getting the EX495 eSata Port Multiplier working?


I have an EX495 which I've read works perfectly as a Xpenology setup. But I need more than 4 drives. I have a sandigital 4bay esata which i'd like to find out if it works (without having to tear apart my setup to find out)

Link to comment
Share on other sites

I have 2x EX490's


One with whsv1

One with Xpenology


The One with whsv1 has a 4 bay addonics esata box attached working fine...


Need to copy off it and set it up as a second Xpenology box....then I can let you know I guess.


As I also would like to know if it will detect as being able to make an 8 drive volume.... Or only as 2 separate 4 drive volumes.



Link to comment
Share on other sites

Had a quick play with it tonight. on both the EX490 and the N40L


Couldn't get it up and running on the N40L...


Disk 1 would light up, but thats as far as it got...



DSM fully loaded up, but no extra drives found.

Drive 1 Lit up and flashed etc.....


Will have to get some more play time and hook up my cable that gives me Monitor and keyboard again to see what it's actually doing


Weird that it gets further than the N40L... but thats a good sign :grin:


played with the /etc/synoinfo.conf file and changed some things (internalports esataports usbports etc) but still no go. Tho I am SHIT at binary / hex stuff so probably didn't do it right.


Hardware physically supports the combo and it works fine as a 4 bay port multiplied for WHSv1 fine




Link to comment
Share on other sites

ok hooked up a monitor.


seems to try and load si21xx.ko module


But I believe the EX490 has a Silicon Image SiL3531 chipset for the ESATA


Maybe later when I get time I will try a different Xpenology version to see if one has the correct driver? :?:


** Update

actually I turned off the extenal E-SATA box and saw errors fly up the screen. about ata7


turn it back on and saw




will work some more on this



Link to comment
Share on other sites

no, somethings amiss with the driver


still only recognises 1 drive of the 4 drives


[   43.413284] sata_sil24 0000:02:00.0: version 1.1
[   43.413299] sata_sil24 0000:02:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   43.413461] sata_sil24 0000:02:00.0: setting latency timer to 64
[   43.413678] scsi6 : sata_sil24
[   43.413825] ata7: SATA max UDMA/100 host m128@0xfeaffc00 port 0xfeafc000 irq 18
[   45.545028] ata7: SATA link up 3.0 Gbps (SStatus 123 SControl 0)
[   46.560499] ata7.15: Port Multiplier 1.1, 0x1095:0x3726 r23, 1 ports, feat 0x1/0x9
[   46.561839] ata7: Apply Synology fast PMP boot
[   46.869104] ata7.00: hard resetting link
[   47.207190] ata7.00: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   52.209222] ata7.00: qc timeout (cmd 0x27)
[   52.209333] ata7.00: failed to read native max address (err_mask=0x4)
[   52.209414] ata7.00: HPA support seems broken, skipping HPA handling
[   52.209498] ata7.15: hard resetting link
[   54.341028] ata7.15: SATA link up 3.0 Gbps (SStatus 123 SControl 0)
[   55.356392] ata7: Apply Synology fast PMP boot
[   55.663103] ata7.00: hard resetting link
[   56.284102] ata7.00: After hardrest, set SRST timeout to 5HZ
[   56.295035] ata7.00: softreset failed (SRST command error)
[   56.295124] ata7.00: softreset failed, set srst fail flag
[   56.295228] ata7.00: reset failed (errno=-5), retrying in 10 secs
[   65.663087] ata7.00: hard resetting link
[   66.001188] ata7.00: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[   66.001304] ata7.00: link reset sucessfully clear error flags
[   66.003042] ata7.00: ATA-8: ST31000340NS, SN06, max UDMA/133
[   66.003134] ata7.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[   66.018160] ata7.00: configured for UDMA/100
[   66.018299] ata7: EH complete
[   66.018462] scsi 6:0:0:0: Direct-Access     ATA      ST31000340NS     SN06 PQ: 0 ANSI: 5
[   66.018728] sd 6:0:0:0: [sdg] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[   66.018894] sd 6:0:0:0: [sdg] Write Protect is off
[   66.018979] sd 6:0:0:0: [sdg] Mode Sense: 00 3a 00 00

Link to comment
Share on other sites

  • 2 weeks later...

Congrat on your 29 drive setup.


Could you share how did you do it?


Like cboy, I would like to have my estat box work with xpenology. But do not have luck so far.


Thank you in advance!




OK. I saw your other post: viewtopic.php?f=2&t=2028&p=9934#p9934

I have a HP n40l, which has an esata port that should work as port multiplier, but I have not able to make it work with the 5bay sandigital esata enclosure yet.

Link to comment
Share on other sites

  • Create New...