• 0
Water

My Nas not appear in network location

Question

Hi,

I don't know why my nas not appear at Network locations section of "This Computer", I can add my Nas shared folder as network drives normaly, but my Nas Icon not appear, take a look at this image to see what icon I talk about:

2X7tWww.jpg

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1

@Water The Media Server package needs to be installed and running for that icon to come up. If it's not the case then install it in the Package Center first. Then on your computer go to the Computer tab in Windows Explorer >Access Media > Connect to a media server. Let it install. When finished refresh the window and voila.

 

Google could have help: https://forum.synology.com/enu/viewtopic.php?t=109576

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 10/3/2017 at 9:28 AM, sbv3000 said:

Check that you have SSDP discovery enabled in File Services>Advanced

It enabled but the icon is still missing :(

 

On 10/3/2017 at 9:59 AM, toastboy said:

Making sure desktop and NAS were on the same Workgroup worked for me once upon a time

The Nas and my PC at the same workgroup but the icon is still missing :(

Share this post


Link to post
Share on other sites
  • 0

It's not really an issue of why shouldn't the PC see the NAS but more why SHOULD it. There are a bunch of things that have to be set up right for the PC to see the NAS.

 - they must both have a file sharing protocol enabled (the PC is the client, the NAS is the server). this is typically SMB or CIFS. it's hard to believe it's disabled on the PC, but it is not on by default on the NAS. double check that file sharing protocols are enabled and all sub requirements such as workgroups match up.

 - they must be able to physically see each other on the network. you must be able to ping back and forth. typically they're on the same subnet, e.g., 192.168.1.* with the same net mask (255.255.255.0). keep in mind ping commands can get bounced by the nas. you could temporarily enable ssh, but you need to determine that the boxes can see each other.

 - there must be no intervening device such as a firewall blocking the two from seeing each other. windows PCs, Synology NAS and many routers have built-in firewalls which may prevent traffic. while you're getting this worked out try disabling the firewall on the PC, the NAS, and any intervening network device.

- authentication: SMB still requires authentication, a user and password, that has been set up on the NAS (unless you're using LDAP on the NAS for your users but that seems unlikely given the problem you're having)

 

bottom line you need to prove to yourself that it should work and not assume it will. If you determine your NASes IP, and go to Windows Explorer, and put in //<ip of NAS>, what happens?

Share this post


Link to post
Share on other sites
  • 0
34 minutes ago, aol said:

bottom line you need to prove to yourself that it should work and not assume it will. If you determine your NASes IP, and go to Windows Explorer, and put in //<ip of NAS>, what happens?

 

First, thank you very much for your information!

As I said in my first post, I can access my Nas shared folders normally as network drives and I can ping my NAS and I can access my Nas from //<ip of NAS>

but the problem is that the main NAS icon is not appears in Network Locations section of This Computer window, Take a look at this image to see what icon I'm talking about:

image.thumb.jpeg.a5b63fb5501539abba1c878315b79423.jpeg

Share this post


Link to post
Share on other sites
  • 0
26 minutes ago, bearcat said:

@Water is your network configured as "Privat", "Work" or "Public" ?

And is your "Network discovery" enabled on your computer ?

 

 

Public network and Network discovery is enabled :(

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, Water said:

Public network and Network discovery is enabled :(

 

There you might have your problem, do NOT use "Public".

Edited by bearcat

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, bearcat said:

 

There you might have your problem, do NOT use "Public".

I change the network type to private but the problem did not solved :(

Share this post


Link to post
Share on other sites
  • 0

@Water

Make sure the below services are enabled and set to Automatic on your computer:
Computer Browser
DHCP Client
DNS Client
Network Connections
Network Location Awareness
Remote Procedure Call (RPC)
Server
TCP/IP Netbios helper
Workstation
SSDP Discovery
UPnP Device Host

 

btw: could you post a picture, like the other one, showing exactely how your computer is showing the icons?

and another, showing how your Fileservices/SMB is configured yon your XPE box?

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, bearcat said:

@Water

Make sure the below services are enabled and set to Automatic on your computer:
Computer Browser
DHCP Client
DNS Client
Network Connections
Network Location Awareness
Remote Procedure Call (RPC)
Server
TCP/IP Netbios helper
Workstation
SSDP Discovery
UPnP Device Host

 

btw: could you post a picture, like the other one, showing exactely how your computer is showing the icons?

and another, showing how your Fileservices/SMB is configured yon your XPE box?

I check the services but didn't help,

I want to explain what the problem is:

in the Network my NAS appears normally as PC not as Storage device, take a look at this image, the NAS name is BASHAR:

59d74263a47de_Layer0.png.646507532d8cf17b6e9b1d59d74c968a.png

 

 

But in "This PC", the NAS icon not appears like in the image in the first post, take a look at this image to see that these is not NAS icon in This PC screen:

win10_im_backup_9.png.687ca0e0b1787f580e8b2906e8d42cc7.png

 

Please note that I can Add my shared folders as network drives, but I want this icon of NAS to appear automaticlly in This PC screen:

 

9571dfd3-1c99-4ebe-98c0-3984f73cb740.jpg.21dfac01a574ba213e560241b43aa130.jpg

 

Edited by Water

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Polanskiman said:

@Water The Media Server package needs to be installed and running for that icon to come up. If it's not the case then install it in the Package Center first. Then on your computer go to the Computer tab in Windows Explorer >Access Media > Connect to a media server. Let it install. When finished refresh the window and voila.

 

Google could have help: https://forum.synology.com/enu/viewtopic.php?t=109576

You are amazing, Thank you very much for you efforts!

I will try and I hope it will work

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.