Jump to content
XPEnology Community

Pi-hole Docker


Recommended Posts

Bonjour,

 

Ma config : N40L Baremetal, Jun's 1.02B DSM 6.1.3-15152 update 4

Je voudrai faire tourner un serveur PI-Hole.

 

Debian Croot, on oublie

Virtual Box, on oublie (me demande à chaque fois Python alors qu'il est installé et qu'il tourne, j'ai aussi Python3, c'est peut-être ça ??)

Docker j'y arrive pas :-( je suis en brêle pour Linux ...

Je télécharge l'image, je la lance et puis je ne sais pas comment changer le fichier de config pour pouvoir mettre mon IP.  Je lance le terminal, je clique sur créer, j'ai donc un terminal "bash" mais je ne trouve pas ce que je dois modifier...  J'ai fait pas mal de recherche mais la plupart des tuto sont sur une instal sur Raspian et les tuto sur docker sont trop avancés pour moi .. il y a bien le script de config sur Github mais même ça je sais pas comment faire (ça situe mon niveau Linux). Quelqu'un peut il m'aider à faire ça (trouver le conf et l'éditer), je dois modifier quelque chose dans les paramètres quand je crée mon container ?

 

Merci d'avance :|

 

 

Link to comment
Share on other sites

oui juste ca

bien faire attention au port

et tu peux rajouter une variable WEBPASSWORD avec le mot de passe de ton choix pour pouvoir te loguer sur l'interface web de pi hole dans mon cas sur le port 8000 donc "http://192.168.1.10:8000/admin"

 

pihole.PNG

Edited by cseb
Link to comment
Share on other sites

Merci mais je n'arrive à rien ..... quand je crée mon container, dans les variables d'environnement, j'indique : /etc/pihole/docker_run.sh start pour qu'il lance le script que j'ai trouvé sur Github https://github.com/diginc/docker-pi-hole/blob/master/README.md . Le container se crée mais se plante et redémarre sans fin ... Tu n'aurais pas le script que tu fais tourner pour que je le modifie par rapport à mon cas ...

Link to comment
Share on other sites

Merci de ton aide en tout cas ;-)

Donc tu n'a rien modifié dans volume, tu as ajouté 8000 pour le port 80 à la place de auto et tu as simplement mis ServerIp=<http://192.168.1.10:8000/admin> et WEBPASSWORD=<toto12345> dans variables et c'est tout ? J'ai essayé comme ça mais rien à faire ... j'ai aussi essayé en retirant le =, le http, les <>, etc ...:cry::cry:

 

Et les autres variables (dns, timezone, etc) tu as modifié ça depuis l'interface graphique ?

Edited by math316
info manquantes
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...