valix13

DSM 4.3 ESXi OVF

Recommended Posts

Bonjour et merci !

 

Une question : est-elle basée sur la dernière 4.3-3810 par Trantor ?

viewtopic.php?f=14&t=1700

 

Si c'est le cas je pensais qu'il devait produire un buid pour esxi d'abord...

Share this post


Link to post
Share on other sites

Le week-end a été productif :smile:

La migration de 4.2-3202 vers cette 4.3-3810lle ci s'est bien passée.

 

J'étais curieux de savoir à quoi servait le 2e dd virtuel IDE, de 8Go. J'ai joué un peu avec et ...

il est là pour éviter que l'init du DSM ne casse l'amorce (premier dd) ?! :lol:

 

En tout cas pas de souci majeur lors de la migration grâce à une sauvegarde config + données importantes au préalable sur un disque USB.

 

J'ai du réinstaller par contre :

- les paquets (+ re-entrer les adresses de dépôts community)

-> a noter que plex a été immédiatement opé après l'install du paquet :smile:

- les taches de sauvegarde

- mon bureau, tout était réinitialisé du fond d'écran aux raccourcis - bien que tous les utilisateurs aient été tous récupérés

- les paramètres du serveur multimédia (encodage audio...)

 

A noter :

- qu'ils est possible d'appliquer la mise à jour Synology 4.3-3810-Update1 depuis le panneau de configuration, s'agissant d'un hotfix sans modification de l'amorce.

- la restauration de la config depuis le disque USB a pris un certain temps, 1h quasiment !

- que si on souhaite restaurer mysql, il faut au prélable l'activer dans les paramètres Web

 

 

Voilà c'est tout pour l'instant de mémoire :mrgreen:

 

Bon courage à ceux qui vont s'y lancer !

 

---

Edit :

Juste un souci, dés le premier démarrage j'ai l'avertissement 'le volume est planté' dans le widget 'santé du sytème'.

 

+ de détails dans le gestionnaire :

Lorsque vous retirez les disques durs, notez qu'au moins un disque système [Disque 2] doit être conservé pour que le système fonctionne normalement. [...]

 

La réparation dans le gestionnaire de disques fait repasser l'état à normal, mais l'avertissement revient au prochain démarrage.

Ca n'empeche pas l'accès aux disques heureusement mais ce n'est pas rassurant :-|

 

Le disque 2 est celui de 8go (ide), prédéfini dans le template, qui n'était pas présent dans mes configs en 4.2...

Share this post


Link to post
Share on other sites

Bonjour,

 

lorsque je cherche à télécharger le fichier OVF, on me demande une clé de décryptage.

 

Est-ce qu'il serait possible de l'obtenir par MP ?

 

Merci bcp !

Share this post


Link to post
Share on other sites

Bonjour, la clé est incluse dans le lien.

 

Relancez le téléchargement.

 

cordialement,

Valix.

Share this post


Link to post
Share on other sites

J'ai essayé avec IE10 au lieu de firefox 25, et ca a marché !

 

Merci beaucoup bonne soirée.

Share this post


Link to post
Share on other sites

Merci Djey

 

Peux tu préciser ce que tu as fait pour appliquer la mise a jour 4.3 depuis la 4.2 ?

 

Le week-end a été productif :smile:

La migration de 4.2-3202 vers cette 4.3-3810lle ci s'est bien passée.

 

J'étais curieux de savoir à quoi servait le 2e dd virtuel IDE, de 8Go. J'ai joué un peu avec et ...

il est là pour éviter que l'init du DSM ne casse l'amorce (premier dd) ?! :lol:

 

En tout cas pas de souci majeur lors de la migration grâce à une sauvegarde config + données importantes au préalable sur un disque USB.

 

J'ai du réinstaller par contre :

- les paquets (+ re-entrer les adresses de dépôts community)

-> a noter que plex a été immédiatement opé après l'install du paquet :smile:

- les taches de sauvegarde

- mon bureau, tout était réinitialisé du fond d'écran aux raccourcis - bien que tous les utilisateurs aient été tous récupérés

- les paramètres du serveur multimédia (encodage audio...)

 

A noter :

- qu'ils est possible d'appliquer la mise à jour Synology 4.3-3810-Update1 depuis le panneau de configuration, s'agissant d'un hotfix sans modification de l'amorce.

- la restauration de la config depuis le disque USB a pris un certain temps, 1h quasiment !

- que si on souhaite restaurer mysql, il faut au prélable l'activer dans les paramètres Web

 

 

Voilà c'est tout pour l'instant de mémoire :mrgreen:

 

Bon courage à ceux qui vont s'y lancer !

 

---

Edit :

Juste un souci, dés le premier démarrage j'ai l'avertissement 'le volume est planté' dans le widget 'santé du sytème'.

 

+ de détails dans le gestionnaire :

Lorsque vous retirez les disques durs, notez qu'au moins un disque système [Disque 2] doit être conservé pour que le système fonctionne normalement. [...]

 

La réparation dans le gestionnaire de disques fait repasser l'état à normal, mais l'avertissement revient au prochain démarrage.

Ca n'empeche pas l'accès aux disques heureusement mais ce n'est pas rassurant :-|

 

Le disque 2 est celui de 8go (ide), prédéfini dans le template, qui n'était pas présent dans mes configs en 4.2...

Share this post


Link to post
Share on other sites

Voici mon plan de migration (encore au stade de beta :smile: ) :

 

  • 1. déployer le fichier OVF et tester la nouvelle version sans les données (ou avec des données de test) dans une vm dédiée
  • 2.a Sauvegarder la conf xpenology à migrer
    b Sauvegarder les données sur disque externe
  • 3. stopper ttes les vms xpenology
  • 4.a dupliquer la vm de tests, la copie sera celle utilisée comme cible de la migration
    b vérifier les paramètres de cette nouvelle vm (cpu, ram, etc)
    c déplacer les disques de stockage de la VM à migrer vers le controleur SCSI de la nouvelle VM
  • 5. démarrer la nouvelle VM
  • 6. accéder au DSM
  • 7.a restaurer la conf sauvegardée (disque externe) : prend + de 30 min
    b Ajouter les repos DSM additionnels
    c Reinstaller les paquets
  • 8. faire la mise à jour update 1 par le panneau de configuration

 

En espérant que cela aide ...

Share this post


Link to post
Share on other sites

Bonjour,

même pas de souci de volume planté après le redémarrage ? :???:

 

Chez moi il apparaît à chaque démarrage, dés que j'ajoute un ou plusieurs disques SCSI à la VM et que je crée un volume.

 

J'ai également la v5.5, que j'administre depuis le vsphere client.

Share this post


Link to post
Share on other sites

Un grand merci à toi Valix13 !!!!! 3 jours que je me prenait la tête, je tombe sur ta release et tadaa, ca marche nickel !

 

Bravo

Share this post


Link to post
Share on other sites

Bonjour !

 

Merci pour ce partage superbe nouvelle j'utilisais 4.2 sous virtual Box sans soucis et j'ai décider de passer sur ESXI et tester ton OVF j'ai reussi à la deployer malheuresement je n'arrive pas a ajouter de HDD (comme tu dit pour les data) et lorsque j'essaye d'initialiser les disque qui sont précrée dans le ovf ce la ne fonctionne pas sur syno...

Désole je suis un peu novice sur ESXI serait il possible qu'une âme charitable fasse un tuto pour installer cette OVF avec les HDD que l'on veux utiliser sous ESXI?

 

Merci à vous !

 

Cordialement.

Share this post


Link to post
Share on other sites

Bonjour wolf,

 

tu n'as pas à initialiser les disques présents sur le modèle OVF que tu as déployé. Ce sont des disques système sur contrôleur IDE.

Les données sont stockées sur des disques attachés à un contrôleur SCSI virtuel.

 

Quand tu dis que tu n'arrives pas à ajouter de HDD, tu t'y prends comment ( et avec message d'erreur ?)

ou es-tu déjà bloqué sans savoir comment ajouter un vmdk :?:

 

De quels disques physiques disposes-tu pour tes données ?

 

Sache que tu as deux grandes possibilités :

- soit tu crées des espaces de stockage sur tes disques physiques avec le vsphere client (cela va les formater intégralement en VMFS) et tu crées ensuite autant de disques virtuels que tu le souhaites pour les rattacher à la machine virtuelle.

- soit tu demandes à ce que l'intégralité de chaque disque soit mappé dans ta machine virtuelle. C'est du RDM, et cela nécessite au préalable d'exécuter une commande sur le shell esxi pour chaque disque, afin de créer le lien.

 

J'ai personnellement opté pour la seconde possibilité pour limiter la segmentation et faciliter la gestion.

Share this post


Link to post
Share on other sites

bonsoir Djey !

 

Merci pour ta réponse en effet je n'avais pas saisi a quoi servait les 2 disque dur "précrée".

J'ai 4 disque de 2 to sur ma machine que j'ai ajouter en tant que banque de de donnée sur vsphere et j'ai ainsi pu crée mes disque de DATA.

Je suis intéresser par ta deuxième solution pourrait tu m'en dire plus et quel est la commande a taper afin de pouvoir l'utiliser?

 

Une question : après avoir initialiser mon disque sur syno il aparrait comme étant du SSD (ce n'est biensur pas le cas ) chez toi aussi ?

ET j'ai le même soucis que toi si j'arrete la vm et que je la relance j'ia une erreur sur le disque comme quoi il est planté.

 

Merci encore pour ta réponse rapide !

 

Cordialement.

Share this post


Link to post
Share on other sites

Pas de soucis !

 

J'ai également 4 disques, 2x2to venant d'un nas syno et 2x3to achetés pour mon serveur sous ESXi.

 

La deuxième méthode évite de devoir créer d'énormes fichiers virtuels sur chaque disque, supprimant au passage une couche entre la machine virtuelle et la machine physique.

D'ailleurs, tu confies toujours à xpenology la gestion du RAID sur tes 4 disques, (RAID 1, RAID, 5, SHR) .

 

Le RDM se gère de façon tout à fait transparente. La seule 'difficulté' est donc de devoir passer par la ligne de commande, comme décrit ici :

http://blog.davidwarburton.net/2010/10/ ... -for-esxi/

Le but de la manip est que, pour chaque disque dur à mapper, tu obtiennes un fichier VMDK, qui sert juste de lien entre ta VM et le disque en question. C'est ce même VMDK que tu devras indiquer dans la config de ta vm, comme tu le ferais pour un 'gros' vmdk créé et alloué sur le datastore.

 

Attention, cela implique que ces VMDK de lien soient accessibles depuis l'hyperviseur esxi !

Conséquence : tu dois disposer d'un datastore hébergé sur un support supplémentaire (j'ai chez moi un disque dur de 250go à cet effet). Et déposer ces VMDK fraîchement créés dans le datastore.

Du coup, si tu ne peux rajouter ce 5e disque, tu vas devoir 'sacrifier' un de tes 4 disques pour faire un datastore et c'est dommage. :sad:

Il y a peut être une autre possibilité mais je ne suis pas assez calé en la matière... peut être est-il possible de le faire avec une clé USB dédiée ?! à tester.

 

Une question : après avoir initialiser mon disque sur syno il aparrait comme étant du SSD (ce n'est biensur pas le cas ) chez toi aussi ?
C'est le cas, et même avant d'initialiser. Depuis la 4.3 (et peut etre même avant), syno gère l'installation de disques SSD en + du système afin d'accélérer la machine. A mon avis la config xpenology interne lui fait seulement croire qu'il a du SSD en face. Rien de bien grave en somme :wink:

PS: il est également possible de cacher ces disques 1 et 2 du gestionnaire de disques avec une petite manip ... vu qu'ils ne servent à rien sous le DSM.

 

ET j'ai le même soucis que toi si j'arrete la vm et que je la relance j'ia une erreur sur le disque comme quoi il est planté.
Merci, je me sens moins seul du coup :lol:

Une version peaufinée pour nos ESXi par Trantor lui-même devrait sortir sous peu, tout le monde croise les doigts pour qu'elle résolve aussi ces petits désagréments.

 

Bon courage !

 

---

Edit :

J'ai ouvert un thread au sujet de l'erreur de volume planté :

viewtopic.php?f=2&t=1796

Share this post


Link to post
Share on other sites

Merci pour ces Infos je vais me pencher la dessus et merci pour le lien !

Ha oui je suis preneur de la methode pour masquer les DD !

 

Par contre quelqu"un a remarquer des problème pour tt ce qui est disque externe (usb , HDD externe) moi aucun ne sont reconnu...

Pourtant sur la vm le controleur usb est bien présent...

Share this post


Link to post
Share on other sites
Merci pour ces Infos je vais me pencher la dessus et merci pour le lien !

Ha oui je suis preneur de la methode pour masquer les DD !

Modifie dans les fichiers /etc/synofinfo.conf et /etc.defaults/synoinfo.conf : la clé internalportcfg

Pense à faire avant des sauvegardes de ces fichiers, qui sont plutot critiques !

 

Chez moi après modif :

internalportcfg="0xffc"

C'est de l'hexa, en binaire cela donne 1111 1111 1100 (la calculatrice Windows est mon amie :smile: )

 

Le bit 1 correspond à un disque visible, le 0 le cache donc. A lire de droite à gauche !

J'ai donc passé les 2 derniers bits à droite de 1 à 0 pour masquer respectivement les disques 1 et 2.

 

Ensuite on reconvertit tout ça en hexa, on inscrit la valeur sans oublier les guillemets et le 0x, on sauve puis reboot !

 

 

Par contre quelqu"un a remarquer des problème pour tt ce qui est disque externe (usb , HDD externe) moi aucun ne sont reconnu...

Pourtant sur la vm le controleur usb est bien présent...

As tu également ajouté le périphérique USB dans la config de ta VM sous vSphere client ? le contrôleur seul ne suffit pas. vSphereClient détecte les périphériques branchés et t'indique s'ils sont prêts à être connectés à ta VM, ou déjà connectés à une autre (éventuellement).

Share this post


Link to post
Share on other sites
As tu également ajouté le périphérique USB dans la config de ta VM sous vSphere client ? le contrôleur seul ne suffit pas. vSphereClient détecte les périphériques branchés et t'indique s'ils sont prêts à être connectés à ta VM, ou déjà connectés à une autre (éventuellement).

 

Il m’étais impossible d'ajouter de periphérique USB j'ai redémarrer mon ESXI et tout est rentré dans l'ordre !

 

Merci encore à toi!

Share this post


Link to post
Share on other sites

Bonsoir !

 

Encore quelques question.. :grin:

Le vpn n'a pas l'air de fonctionner est ce que pour vous tout fonctionne ?

j'ai essayer Openvpn , PPTP pas possible de se connecter j'ai bien les ports ouverts sur mon routeur.

en PPTP à partir de mon telephone android je me connecte sinon a partir de pc /mac impossible...

test effectuer à partir de plusieurs machine et a des endroits différents.

 

Cordialement.

Share this post


Link to post
Share on other sites

coucou

 

super pour le boulot, merci a toi

 

j'ai aussi le probleme de volume planté a chaque reboot, meme si j'ai caché les deux premiers disque.

que faire ? :smile:

Share this post


Link to post
Share on other sites

Que faire ? :grin:

 

attendre que Trantor (ou quelqu'un d'autre) intègre une solution, il est au courant du souci.

Sinon je peux vivre avec, ça tourne sans problèmes.

Share this post


Link to post
Share on other sites
coucou

 

super pour le boulot, merci a toi

 

j'ai aussi le probleme de volume planté a chaque reboot, meme si j'ai caché les deux premiers disque.

que faire ? :smile:

Petit up pour annoncer que cela a été résolu chez moi, j'ai migré hier vers cette version dédiée à ESXi:

viewtopic.php?f=14&t=1939

 

La migration à version homologue s'est passée sans douleur, mis à part le fait que les disques 1 et 2 étant masqués, je n'ai pas pensé à restaurer le masque avant de booter sur la nouvelle amorce. Du coup j'avais le volume en état cassé,le DSM accessible mais sans mes données :grin:

Il a suffi de restaurer le masque dans les synoinfo.conf et de redémarrer,puis de restaurer la configuration des utilisateurs + répertoires partagés.

Moralité : toujours réaliser une petite sauvegarde, cela m'a fait gagner du temps par la suite alors que je ne pensais pas en avoir besoin ! :wink:

 

Aussi, le contrôleur SCSI paravirtuel est correctement géré dans ce build.

Share this post


Link to post
Share on other sites

La version ESXi faite par Trantor a été spécialement adaptée pour tourner sur l'hyperviseur, contrairement à ce template OVF (qui fonctionne bien sûr, mais avec quelques bugs et limites).

En gros :

 

+ ajout de pilotes (ex: support du controleur SCSI paravirtuel)

+ correction du pb de volumes endommagés

+ ...

 

L'avantage de cet OVF réside en la facilité d'installation, parfait pour tester la version 4.3 du DSM. C'est tout pré-configuré, simplifiant la vie pour ceux désirant y aller doucement en virtu !

Je l'ai pris au départ car c'était alors la seule édition installable sur du Vmware avec mon niveau de connaissances. Puis j'ai migré récemment sans anicroche :grin:

Share this post


Link to post
Share on other sites