Установка XPEnology в VirtualBox


Recommended Posts

Virtualbox установлена в Nas4free. Создал машину. При запуске получаю - "This kernel requires an x86-64 CPU. but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for youf CPU."

Сиcтема:

x64-full на Intel® Core i3-3220 CPU @ 3.30GHz

ASUSTeK COMPUTER INC. P8H77-I Bios: 0814 08/24/2012

FreeBSD 9.1-RELEASE (reldate 901000)

Link to post
Share on other sites

Проверьте кто поставил в VirtualBox, перезагрузка из веб интерфейса Synology нормально отрабатывает? У меня при перезагрузке выдаёт:

Системный раздел (Root) на DiskStation поврежден. Система может не загружаться.

Если просто выключить и потом включить, то ошибок не выдаёт и продолжает работать нормально.

Link to post
Share on other sites
  • 2 weeks later...
Проверьте кто поставил в VirtualBox, перезагрузка из веб интерфейса Synology нормально отрабатывает? У меня при перезагрузке выдаёт:
Системный раздел (Root) на DiskStation поврежден. Система может не загружаться.

Если просто выключить и потом включить, то ошибок не выдаёт и продолжает работать нормально.

 

Похоже это происходит после того как была произведены какие то действия с дисками (например добавление нового или изменение рэйда) судя по тому что часто выдает ошибку 22, то скорее всего после дисковых операций гробиться загрузчик. Если ничего не делать ( с дисками) то вроде все после перезагрузки нормально.

Link to post
Share on other sites
  • 1 month later...
Virtualbox установлена в Nas4free. Создал машину. При запуске получаю - "This kernel requires an x86-64 CPU. but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for youf CPU."

 

ВиртуалБокс стоит на Win7? все вроде сделал по мануалу.

В итоге тажа выдача

"This kernel requires an x86-64 CPU. but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for youf CPU."

Где собака зарыта?

Link to post
Share on other sites

Получилось. Надо настройки VirtualBox менять - вместо "Other Linux" указать "Arch Linux 64 bit" и тогда процессор распознается как правильный и все устанавливается ок.

Link to post
Share on other sites
  • 4 weeks later...

Повторю свое сообщение тут (т.к. написал его не в той теме)

Здравствуйте. Ставлю на VirtualBox, при инсталяции выдает ошибку форматирования "Не удалось отформатировать диск". Это из-за неподдерживаемой сетевой карты? (стоит realtek 8168)

 

XPEH:

Если ставишь на VirtualBox, то физическая сетевая карта только должна поддерживаться основной ОС. Внутри виртуальной машины используется все равно другая, эмулируемая. Ошибка форматирования скорее всего связана с типом дискового контроллера. Попробуй synoboot диск подключить к виртуальному IDE (PATA) адаптору, а диск для хранения данных с виртуальному SATA адаптору.

 

nkh:

Я вроде так и сделал, (как в описании).

 

upd:

попробовал поставить на работе, была такая же ошибка. Но, после не знаю чего :???: (вообще, я отключил поддержку USB и убрал галочку "Абсолютные устройства позиционирования", но потом и ставя эти галочки системы ставились без проблем, поэтому до конца сказать что повлияло пока не могу), форматирование прошло успешно и система поставилась.

Попробую на домашнем...

Link to post
Share on other sites
  • 4 weeks later...

Случилась непонятная трабла. все ок работало, нет проблем. В один прекрасный момент черт дернул пробить систему ауслогистиком бутспид. Ну оно там типа пооптимизировало, и после всего этого после перезагрузки машина работает, ейные машинные службы тоже, но не пускает в веб-админку, а также по фтп и по путти - пишет "у вас нет прав на использование данного устройства, обратитесь к администратору". Где может быть зарыта собака, плиз гуру подскажите ибо в этих виртуальных сетях нуб-нубом..

 

Может оно каким-то образом залочило айпишник, подскажите как на виртуалке сделать сброс системы на дефолтные настройки?

 

PS проблема решена - зашел извне другим компом и почистил список блокировок, там оно забило каким-то образом внутренний айпишник старшего брата

Link to post
Share on other sites
  • 1 month later...

(Разобрался со всем самостоятельно, диски которые sata надо создавать на том же диске, я монтировал диски которые лежали на другом физическом диске.) :oops:

Оставлю свой вопрос, вдруг кому пригодится.

Не могу установить

При устанавки DSM пишет ошибку:

Ошибка сервера (код ошибки 38)

Если Вы выполняете установку через беспроводное сетевое подключение, перейдите на кабельное подключение Ethernet на DiskStation и клиентском ПК и повторите попытку.

При установке произошла ошибка. Сервис Telnet DiskStation включен для определения ошибок. Настройте маршрутизатор для переадресации порта 23 на DiskStation и обратитесь в службу поддержки Synology"

VirtualBOX стоит на Ubuntu 13.04, менял сетевые карты, контроллеры дисков, не помогает. :???:

Как только доходит до момента форматирования диска, сразу выпадает эта ошибка, может сталкивался кто?

ff4849ac4b2c2ed2ae988acc1777d0b9.png

 

ps

Заметил еще одну проблему, mac адрес сетевой карты XPEnology при запуске с данного диска имеет собственный номер,

если в настройках сетевой карты VirtualBOX не поменять его, тогда IP XPEnology не будет соответствовать настройкам вашего DHCP сервера.

Узнать mac адрес можно запустив Synology Assistant и вписать в настройках сетевой карты VirtualBOX.

Но мне не помогло решить проблему с диском, на домашней странице XPEnology показывает, что: На DS3612xs не найден жесткий диск

Edited by Guest
Link to post
Share on other sites
  • 1 month later...
  • 1 month later...
Получилось. Надо настройки VirtualBox менять - вместо "Other Linux" указать "Arch Linux 64 bit" и тогда процессор распознается как правильный и все устанавливается ок.

 

Win7 32

VirtualBox 4.3.0

 

Нет такого пункта "Arch Linux 64 bit"

Link to post
Share on other sites
Получилось. Надо настройки VirtualBox менять - вместо "Other Linux" указать "Arch Linux 64 bit" и тогда процессор распознается как правильный и все устанавливается ок.

 

Win7 32

VirtualBox 4.3.0

 

Нет такого пункта "Arch Linux 64 bit"

 

Разобрался, была отключена виртуализация в биосе

Link to post
Share on other sites

Коллеги, у меня NAS работал года два под windows (Комп на Атоме, 2Гб оперативки) причем сам комп подключен к телеку как медиаплеер, теперь вот попробовал установить XPEnology на голое железо - все тоже работает отменно, но видяха и отличная аудиокарта пропадает и я задумался о запуске XPEnology в VM под Windows чтобы сохранить медийный функционал. Опыта с виртуалками у меня совсем нет, подскажите:

Будет ли скорость работы с НАС медленее под виртуалкой, будут ли дополнительные сложности в работе?

Link to post
Share on other sites
  • 5 weeks later...

Не въеду никак в одну вещь, почему то некоторые выложенные тут версии дают нормальный IP адрес при первом запуске и дают к себе подключится, а некоторые дают адрес вида 169.254.XXX.XXX. На своем компе прошивка может поставится нормально, на другом выдает адреса 169.254.XXX.XXX, в чем причина кто-нить знает? :shock:

Edited by Guest
Link to post
Share on other sites
Коллеги, у меня NAS работал года два под windows (Комп на Атоме, 2Гб оперативки) причем сам комп подключен к телеку как медиаплеер, теперь вот попробовал установить XPEnology на голое железо - все тоже работает отменно, но видяха и отличная аудиокарта пропадает и я задумался о запуске XPEnology в VM под Windows чтобы сохранить медийный функционал. Опыта с виртуалками у меня совсем нет, подскажите:

Будет ли скорость работы с НАС медленее под виртуалкой, будут ли дополнительные сложности в работе?

На Атоме с 2ГБ оперативной памяти, скорость на виртуальной машине будет меньше. Какие из возможностей XPEnology вы надеетесь использовать дополнительно и не могут быть заменены просто родными Windows приложениями? NAS это очень специализированная система. Она изначально не предназначена как замена десктопу.

Link to post
Share on other sites

Запрашиваю помощь. Может быть я один такой глупый и для остальных этот супер простой вопрос даже не возникает..

Отчего IP адрес при запуске становится 169.254.164.175? все вродь делаю по инструкции, установить не получается

Link to post
Share on other sites
Запрашиваю помощь. Может быть я один такой глупый и для остальных этот супер простой вопрос даже не возникает..

Отчего IP адрес при запуске становится 169.254.164.175? все вродь делаю по инструкции, установить не получается

Этот IP адрес сетевая карта получает если не находит настоящий DHCP сервер. Попробуй настроить в VirtualBox MAC адрес сетевой карты такой же как прописан в vender файле устанавливаемой версии.

Link to post
Share on other sites

Вот это был дельный совет! Нужно было посмотреть МАС сетевой карты при запуске системы и вбить его в настройки моста вместо "стандартного" 00113208D62A

Благодарю, выручил!

Link to post
Share on other sites
  • 2 weeks later...

Всё делаю по инструкции, но после 4 этапа (в synology assistent 4.Установка DSM) виртуалка перезагружается и пишет:

"grub loading Stage 1.5. Grub loading, please wait ... Error 22"/

Подскажите, пожалуйста, в чём может быть проблема?

 

устанавливаю отсюда XPEnology DS3612xs DSM 4.3 build 3810++ (repack v1.0) отсюда viewtopic.php?f=14&t=1700

хостовая ось - windows 7 x64

virtual box - 4.3.2 r90405

Link to post
Share on other sites
  • 4 months later...

Нужна помощь.Не понимаю почему нет устройства в сетевом окружении.Могу соединяться только по протоколу afp.Система стоит на ubuntu 12.04. Самба включена.Где копать ,наверно в настроиках сети.Из дома приложу скрины.

 

Отправлено с моего RMD-758 через Tapatalk

Link to post
Share on other sites

Попробуй установить на vmWare

 

Для Linux доступна vmWare, не смотря на то что браз под VMware vSphere ESXi, он прекрасно и на воркстайшн работает.

Посмотри на gnoboot, спасибо разработчикам!

5ю ставил все работает и откатывался на 4.3 данные не потерялись, только настройки слетели и права доступа к шарам.

С VirtualBox не все гладко, но работет!, бесят ограничения что должна быть включена аппаратная виртуализация и 4 Гб рам.

К то му же с такими настройками у меня не рабоает Parallels, вылетает нах сразу после запуска Vbox!

 

 

если нужен подробный видео мануал, сниму и выложу

Link to post
Share on other sites

Так в в том-то все и дело стоит gnobot 10.5 dsm 5.0 обновление 2.Подцеплен диск как raw на 3 тб.Все работает замечательно только нет самбы.Непонимаю.Память выставил 2 ГБ.

 

Отправлено с моего RMD-758 через Tapatalk

Link to post
Share on other sites
Так в в том-то все и дело стоит gnobot 10.5 dsm 5.0 обновление 2.Подцеплен диск как raw на 3 тб.Все работает замечательно только нет самбы.Непонимаю.Память выставил 2 ГБ.

 

Отправлено с моего RMD-758 через Tapatalk

самбу перезапускал ? попробуй перезапустить и права доступа посмотри. у меня было такое после миграции.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.