[Tuto] Installer/Migrer DSM 5.2 à 6.1.x (Loader Jun)


Recommended Posts

Après remplacement de la carte réseau interne par une Intel (Yosoo Intel I350-T4 PCI-Express) j'ai pu me connecter à l'interface du Synology.

Données OK

Mais quelques problèmes subsistent :

Le panneau de configuration Réseau/Interface réseau ne s'affiche pas tout le temps... (il faut redémarrer) et quand il s'affiche et que je veux apporter des modifications, celles-ci ne s'enregistrent pas (plusieurs appuis sur "appliquer") idem pour mettre à jour les réglages "Services de fichiers" : je coche la case AFP, puis appliquer et là -> erreur il manque des champs à remplir (SMB) alors que service non activé. Je rempli ces champs, je fais appliquer... dés que je sors du panneau : msg vous n'avez pas sauvegardé !!!

De plus des applis disparaissent du lanceur

 

Très bizarre.

MERCI pour votre aide.

 

On 11/1/2018 at 2:16 PM, maconly34 said:

Migration de 5.2 to 6.2

Loader Jun 1.03b (DS3615) et DSM_DDSM_23739.pat

Matériels

- Carte mère MSI HM97M-E35 dernier bios à jour (16-02-2016)

- Processeur i5-4460 3.2 GhZ

- Carte réseau Realtek PCIe GBE Fam Yosoo Intel I350-T4 PCI-Express

Quote

 

MERCI. Je passe la commande 😎

Je ferais un petit compte rendu dès la réception et mise en place.

 

Edited by maconly34
Link to post
Share on other sites
On 8/24/2018 at 12:42 AM, arkim said:

Bonjour à tous,

 

Voilà comme beaucoup j'ai brické mon nas suite à une mise à jour en 6.2 .

 

Apres de nombreuses lectures, j'ai simplement suivi les tutos de @Polanskiman(cf sa signature) qui fait vraiment un boulot de malade (avec @jun of course).

 

Du coup, si vous êtes comme moi :

 

1/ Prenez un cd ubuntu live et changer le fichier /etc.defaults/VERSION du nas brické en la dernière version de votre dsm qui fonctionnait ( pour moi 6.1.7)

2/ refaites votre clé usb , c'est très important (pour mon cas loader 1.02b ) , votre ancienne clé ne fonctionne plus (le loader pour être précis) 

3/ le nas vous demandera une installation en gardant vos fichiers et votre configuration.

 

Et bingo le tour est joué 

 

merci aussi à @IG-88 pour les drivers ;-) 

Bonsoir

 

J'ai mis à jour mon Nas avec la version DSM 6.2.1-23824, cela fonctionnait au début, du moins c'est ce que j'ai crue. En fait, au bout d'un moment les paquets du DSM se ferment tout seul, puis le Nas ne répond plus.

 

Si je force le redémarrage, cela fonctionne pendant un certain temps .....

 

Auriez vous une idée?

 

Merci beaucoup d'avance pour votre aide

Link to post
Share on other sites

bonsoir,

petit retour d’expérience

je me suis enfin décidé a migrer de dsm 5.2 a 6.1.7 mon hp microserveur gen8 pour le mettre a jour , et passer entre autre a  domoticz 4.9700  hebergé  et pour la gestion des cam ip,

et en suivant a la lettre le tuto de Polanskiman , ca cest deroulé sans accrocs. un grand merci a toi pour ce super tuto

j'ai passé 3 fois plus de temps a refaire remonter les infos de domoticz vers ma tablette .

pour info il faut installer le paquet my DomoAtHome 0.2.39 pour dsm 6.2 sinon ca ne marche pas

by

Capture.PNG

Link to post
Share on other sites
On 11/17/2018 at 12:37 AM, maconly34 said:

C'est ça, uniquement la configuration. Fais toi quelques copies d'écran des différents réglages et dossier partagés etc.

Bonjour

 

J'ai procédé ainsi, cela m'a demandé pas mal de temps de reconfiguration mais cela fonctionne.

 

merci encore

Link to post
Share on other sites
Le 17/11/2018 à 22:48, zorglup a dit :

bonsoir,

petit retour d’expérience

je me suis enfin décidé a migrer de dsm 5.2 a 6.1.7 mon hp microserveur gen8 pour le mettre a jour , et passer entre autre a  domoticz 4.9700  hebergé  et pour la gestion des cam ip,

et en suivant a la lettre le tuto de Polanskiman , ca cest deroulé sans accrocs. un grand merci a toi pour ce super tuto

j'ai passé 3 fois plus de temps a refaire remonter les infos de domoticz vers ma tablette .

pour info il faut installer le paquet my DomoAtHome 0.2.39 pour dsm 6.2 sinon ca ne marche pas

by

 

Hello,

Par expérience c'est une très mauvaise idée de vouloir mutualiser Domoticz sur son NAS... Si DSM plante ou pire si ton gen8 plante toute ta domotique est HS et, par exemple, tu te retrouves avec tes volets qui ne marchent plus! (c'est du vécu^^). C'est pourquoi je suis passé sur un raspberryPi-3 pour domoticz. Et là plus de souci et encore moins pour la gestion des paquets ;)

Link to post
Share on other sites
Le 20/11/2018 à 17:49, nicoueron a dit :

 

Hello,

Par expérience c'est une très mauvaise idée de vouloir mutualiser Domoticz sur son NAS... Si DSM plante ou pire si ton gen8 plante toute ta domotique est HS et, par exemple, tu te retrouves avec tes volets qui ne marchent plus! (c'est du vécu^^). C'est pourquoi je suis passé sur un raspberryPi-3 pour domoticz. Et là plus de souci et encore moins pour la gestion des paquets ;)

salut nicoueron

merci pour ton retour ,ma démarche est inverse a la tienne sur Raspberry je n'ai eu que des problèmes ,sur deux ans d’utilisation je ne suis pas arrivé a fiabiliser le système ,obliger de rebooter le système au moins une fois par semaine ,un coup plus de gestion de temp  /plus d'ouverture du portail /base de données hs .... pourtant j'ai 3 rasp pour différentes utilisations et seul domoticz m 'a posé problème  .De l'autre coté en 2 ans d'utilisation de xpenology  (sans domoticz) j'ai jamais eu un plantage donc a voir

Link to post
Share on other sites
  • 3 weeks later...
il y a 16 minutes, digueche a dit :

Bonjour,

Je suis en 6.0.2 sur MSI N3150 ICO avec 8Go ram et 2x 3To WD red, ma question est : puis-je mettre ajours jusqu'à la version 6.2 avec le loader adéquat, le cas échéant m'indiquer svp la version max à laquelle je peux passer.

 

Bonjour,

Il va te falloir acheter une carte réseau avec contrôleur Intel car sur ta carte mère c'est un Contrôleur Realtek® RTL8111G Gigabit LAN qui n'est pas compatible avec la version 6.2 de DSM

Link to post
Share on other sites

Bonjour à tous,

Possesseur d'un N54L, j'ai suivi ce tuto. Après insertion de la clé et démarrage de la bête, passé l'écran dos + splashscreen HP j'ai qu'un écran noir, pas de menu Grub ni rien. Écran noir, impossible d'aller plus loin. J'ai désactivé l'option dans le BIOS (processeur AMD Turion), malgré tout je reste bloqué. Une idée ??

Link to post
Share on other sites
Le 13/12/2018 à 17:10, stefauresi a dit :

 

Bonjour,

Il va te falloir acheter une carte réseau avec contrôleur Intel car sur ta carte mère c'est un Contrôleur Realtek® RTL8111G Gigabit LAN qui n'est pas compatible avec la version 6.2 de DSM

bonjour,
il y a des chance que realtek devienne compatible ? car avec ma carte j4205, mon seul port pci-e est prit par un double sata.

Edited by Flo00719
Link to post
Share on other sites

bonjour,

 

On 12/14/2018 at 7:43 PM, Flo00719 said:

bonjour,
il y a des chance que realtek devienne compatible ? car avec ma carte j4205, mon seul port pci-e est prit par un double sata.

1- je compte ajouter une carte 2 sata  pci-e, quelle chips sont compatible stp.

 

 

On 12/13/2018 at 5:10 PM, stefauresi said:

 

Bonjour,

Il va te falloir acheter une carte réseau avec contrôleur Intel car sur ta carte mère c'est un Contrôleur Realtek® RTL8111G Gigabit LAN qui n'est pas compatible avec la version 6.2 de DSM

2- si je ne peux pas passer à 6.2 quel est la version max compatible avec ma configue

 

Vous remerciant d'avance.

Link to post
Share on other sites
On 12/13/2018 at 5:10 PM, stefauresi said:

 

Bonjour,

Il va te falloir acheter une carte réseau avec contrôleur Intel car sur ta carte mère c'est un Contrôleur Realtek® RTL8111G Gigabit LAN qui n'est pas compatible avec la version 6.2 de DSM

 

salut,

Est-ce que je peux passer à la 6.1.7  avec ma configuration ?  Si oui, avec quel loader svp.

 

celle ci :

 

On 12/13/2018 at 4:50 PM, digueche said:

Bonjour,

Je suis en 6.0.2   DS3615xs   sur MSI N3150 ICO avec 8Go ram et 2x 3To WD red, ma question est : puis-je mettre ajours jusqu'à la version 6.2 avec le loader adéquat, le cas échéant m'indiquer svp la version max à laquelle je peux passer.

 

vous remerciant d'avance ;)

Edited by digueche
Link to post
Share on other sites
  • 2 weeks later...

Salut, 

Moi je suis passer sous dsm principalement pour les certificat let's encrypt. 

Si ton dsm 5.2 te convient bien, peu d'intérêt à migrer. 

 

Lit les actu sur la sorti de dsm6, tu y trouvera les nouveautés et tu verra bien s'il y a des choses qui t'intéresse 😊

Link to post
Share on other sites
il y a 2 minutes, EVOTk a dit :

Salut, 

Moi je suis passer sous dsm principalement pour les certificat let's encrypt. 

Si ton dsm 5.2 te convient bien, peu d'intérêt à migrer. 

 

Lit les actu sur la sorti de dsm6, tu y trouvera les nouveautés et tu verra bien s'il y a des choses qui t'intéresse 😊

 

 

je viens de lire 2 -3 choses sur le net et c'est vrai que ça apporte des choses dont je ne me sers pas 

Merci pour la réponse ;)

 

Link to post
Share on other sites

Bonjour à tous,

 

C'est avec beaucoup d'humilité que je viens demander votre aide, tout en félicitant les maîtres d'oeuvre de ce travail.

 

J'ai réalisé un Xpenology l'an dernier sur un Dell Optiplex 780. Je ne me souviens plus exactement comment j'avais fait, mais j'avais utilisé XPEnoboot et la version de DSM était 5.2-5644.

 

Il y a quelques semaines, mon application Plex sur AndroidTV a cessé de fonctionner à moins d'être mise à jour : sur DSM, la mise à jour de Plex ne pouvait se faire qu'avec la migration vers DSM 6.xx.

 

Je suis donc tombé sur ce tuto de Polanskiman que j'ai lu, relu et suivi à la lettre : j'ai conservé la clef usb avec DSM 5.2 et ai mis la nouvelle. Synology Assistant a bien trouvé le NAS mais, à chaque essai, l'installation échouait avec un message d'erreur (j'ai refait la manip avec vid pid). De mémoire, erreur 13 ou 21 (je ne suis pas sûr).

 

Après ça, je ne sais pas exactement ce que j'ai fait par ignorance et/ou par bêtise. Si je rejoue le film :

1) j'ai enlevé la clef contenant le loader Jun et ai remis l'ancienne ==> impossible de retrouver l'ancienne installation.

2) j'ai essayé d'utiliser le mode Debug de la 5.2 ==> échec

3) en passant par Synology Assistant, j'ai retenté l'installation de DSM_DS3615xs_15217.pat... Sauf que je me suis mélangé les pédales et que c'était sur la clef USB XPEnoboot 5.2 :( . Chose étrange, il n'y a pas eu cette fois-là de message d'erreur : DSM 6.1.4-15217 s'est bien installé en sautant les étapes 2 et 3 ainsi que la dernière (sens interdits grisés).

 

J'ai alors rebooté le NAS en mettant cette fois-ci la clef USB avec le loader Jun et ai choisi la première ligne DS3615xs 6.1 Baremetal with Jun's mod 1.02b. Après le Booting the kernel de l'écran suivant, plus rien.

 

Je suis donc retourné dans Synology Assistant qui trouve bien mon NAS et qui a semble-t-il fait la màj puisque le 5.2-5644 a été remplacé par le 6.1.4-15217.

 

 

En double cliquant dessus, je tombe sur une page qui s'ouvre dans mon navigateur et qui me propose (encore) une installation. A ce moment, j'ai commencé à flipper car une phrase dit Nous avons détecté que les disques durs de votre DS3615xs actuel a été supprimé à partir d'un précédent DS3615xs et l'installation d'un tout nouveau DSM est demandée avant de continuer. Cela signifie-t-il que toutes mes données sont perdues ?

 

Si je clique sur Installer, que je choisis l'option migration, un message d'erreur est généré vers 45% (erreur 13).

 

Bref, je sais que je ne suis clairement pas au niveau, la lecture des 11 pages du topic m'a plus déprimé qu'autre chose et le vocabulaire que vous utilisez reste très opaque. Je suis conscient que j'ai fait n'importe quoi et vous prie de m'excuser pour ce post : toutefois, si vous acceptiez de m'aider, je vous en serais extrêmement reconnaissant car toute ma famille utilise le NAS et y conserve la plupart de ses données !

 

Merci d'avance.

 

 

 

 

Link to post
Share on other sites

Le fait qu'il demande de réinstaller DSM à partir d'un autre matos n'écrase pas les données. Ces dernières étant situées sur une autre partition. Au pire tu te retrouveras avec un DSM vierge de toute configuration mais les données, elles, seront toujours présentes.

 

Après en cas d'erreur d'installation, en général, le pb vient de la configuration de la clé USB. Il faut bien suivre à la lettre le tuto de Polanskiman, quitte à recommencer plusieurs fois avec d'autres clé usb. Après les derniers loader sont capricieux selon le matos, notamment au niveau de la carte réseau. Il ne faut pas hésiter à tester avec le le fichier extra.lzma : https://xpenology.com/forum/topic/9508-driver-extension-jun-102bdsm61x-for-3615xs-3617xs-916/?do=findComment&comment=81686

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.