Polanskiman

[Tuto] Installer/Migrer DSM 5.2 à 6.1.x (Loader Jun)

Recommended Posts

11 hours ago, windaube21 said:

je ne sais pas si c'est bien ou mal mais sur une machine "poubelle" je suis passer de 6.1.4 a 6.1.5 en ds3615 .... visiblement RAS

 

le tuto n'est pas a jour ou on attend des retours pour validé cette version ??

 

Je ne mets pas à jour le tuto à chaque fois qu'une mise à jour sort sinon je passerais mon temps à cela et je passe déjà trop de temps à administrer le forum à mon gout.

Avant de faire une quelconque mise à jour il est plus que fortement conseillé de venir sur le forum pour vérifier que c'est OK. Voir le forum Anglais, section Critical Updates.

Pour ce qui est de 6.1.5, oui il n'y a pas de problème.

Share this post


Link to post
Share on other sites

Merci a toi @Polanskiman, j'ai fait la maj vers 6.1.5 sans gros probleme.

 

Seul soucis rencontrer c'est wordpress qui indiquer une Erreur 500, après quelques recherche j'ai réussi a la résoudre en activant les 

 

Si sa peu aider certain il faut aller dans WebStation > Parametre PHP > Selectionner le profile PHP utilisé et cliquer sur Modifierensuite dans les Extensions sélectionné tout :)

Share this post


Link to post
Share on other sites
Le 24/02/2018 à 14:36, EVOTk a dit :

Si sa peu aider certain il faut aller dans WebStation > Parametre PHP > Selectionner le profile PHP utilisé et cliquer sur Modifierensuite dans les Extensions sélectionné tout :)

Attention à la charge mémoire dans ce cas. Il vaut mieux activer les extensions dont tu as seulement besoin.

Share this post


Link to post
Share on other sites
Il y a 6 heures, nicoueron a dit :

Attention à la charge mémoire dans ce cas. Il vaut mieux activer les extensions dont tu as seulement besoin.

Sur un petit Synology peut être, sur un xpe avec mon G4400 3.3 pas de différence mais merci de la précision 

Share this post


Link to post
Share on other sites
Le 14/09/2017 à 11:20, Polanskiman a dit :

 

Oui, Il suffit de suivre la procédure suivante:

 

1 - Eteindre la machine et retirer le clef USB

2 - Faire un nouveau loader avec v1.02b et éditer le fichier grub.cfg (S/N, MAC, vid/pid ...)

3 - Brancher le nouveau loader avec 1.02b et rallumer la machine

4 - Utiliser Synology Assistant ou find.synology.com pour trouver la machine sur le réseau

5 - Migrer la machine come indiquer à l'écran en utilisant le fichier .pat de DSM 6.1.x précédemment téléchargé

6 - Laisser faire l'installation

7 - Vous devriez normalement être sous DSM 6.1.x 

 

Faites attention à ce que votre machine soit compatible (voir liste de modules). Si vous avez utilisé le ramdisk par defaut du loader v1.01 alors cela ne devrait poser aucun problème. Si par contre vous avez utiliser le ramdisk personnalisé sous v1.01 car le ramdisk par default ne marchait pas alors il est fort possible que votre machine ne soit pas reconnue avec le loader v1.02b. LISEZ LISEZ LISEZ

 

NOTE IMPORTANTE: Jun a clairement indiqué, que son loader v1.02b n'est pas 100% compatible avec AMD. Néanmoins il "semblerait" que cela marche si la fonctionnalité C1E dans le bios est désactivée. Je conseille donc de faire une installation test sur un disque vierge avant.

Bonjour,

 

Merci pour les tuto et merci pour ce forum =>  XPENOLOGY à  changer ma vie avec les NAS PC  ;)

 

Pour ma part j'ai réussi a migrer de DSM 6.0.2 vers DSM 6.1.4-15217 Update 1 sur un AMD juste en désactivant  C1E et C6 dans le BIOS de ma carte mere MSI.

J'ai voulu essayer sans éditer le fichier grub.cfg (S/N, MAC, vid/pid ...) sur une machine test, et à ma grande surprise j'ai migré sans aucun problème avec le  loader  v1.02b et le .pat pour DS3615xs.

 

Du coup j'ai renouveler l’opération sur le PC  avec 8 terra et avec toutes mes données en RAID5 . J'ai bien transpiré mais ça a aussi fonctionné sans aucun pb.

 

Merci à tous

 

Ps: le fait d'avoir réaliser la manip sans avoir éditer le fichier grub.cfg (S/N, MAC, vid/pid ...) n'engage que moi et mes machines.  Je ne peu que vous conseiller de suivre les tutos à la lettre

Edited by dpcinfo

Share this post


Link to post
Share on other sites

Bonjour,

 

Je possède un serveur HP Prolians 3 avec je possède 3 HDD et 2 SDD.

Le premier SSD est utilisée pour l’installation du système Synology & le second pour un cache SSD en lecture sur l'un de mes disques.

 

Les HDDs sont positionnées dans des baies allouées dans le serveur. 

Les SSDs sont connectés à un contrôleur SATA 3 que j'ai rajouté au serveur.

 

Sous version Xpenology (DSM 5.2), tous les disques durs sont reconnus et fonctionne parfaitement.

Le système est  opérationnel depuis maintenant bientôt 2 ans.

 

Cependant, lors de la mise à jour vers DSM 6.2, l'installation se passe correctement.

Mais lors du Boot sur DSM, tous mes disques sont présents sauf les SSD (en somme, uniquement les 3 hdds sont reconnues).

Le contrôleur SATA reconnaît les deux SSD connectés lors du boot du serveur.

 

De plus, lorsque je viens à DOWNGRADE en version 5.2, l'ensemble des disques apparaît à nouveau (comme si je n'avais rien fais).

 

Quelqu'un à déjà rencontré un problème similaire lors de la migration vers DSM 6.2 ?

Est-il toujours possible de spécifier l'installation de DSM sur un de mes SSD (comme sur DSM 5.2).

 

En vous remerciant pour les réponses accordées.

 

 

PS : Je vous fournirai des screenshots par la suite si mon problème n'est pas assez clair !

Edited by WestFR
Plus d'infos

Share this post


Link to post
Share on other sites

Peut-être que je me trompe, mais pour moi "installer DSM sur un SSD" ne veut rien dire puisque DSM s'installe sur toute la grappe des disques.

Le seul vrai avantage du SSD dans ce cas est effectivement le cache SSD déclaré à posteriori dans DSM. 

 

Pour info et à titre personnel, sous ESXi je n'ai jamais réussi à déclarer mon SSD comme étant un cache pour DSM, j'ai dû le déclarer comme cache au niveau d'ESXi.

Share this post


Link to post
Share on other sites

bonjour,

est-ce qu'une machine avec disque dur SATA et BIOS permettant le mode AHCI est obligatoire ?

La machine est assez légère, mais a l'avantage d'être complètement silencieuse, en l'absence de ventilateur:

 

- Processeur: VIA C3 1GHz
- Mémoire: DDR-SDRAM 512 Mo PC3200
- Disque dur: 120 Go IDE
- Carte graphique: VIA UNICHROME PRO (intégrée)
- Carte Mère: VIA EPIA PD10000  

 

La clé USB boote correctement, mais lorsque le message apparait (l"écran ne sera plus mis à jour ...) plus rien ne se passe, pas d'activité sni sur la clé USB ni sur le disque dur. Evidemment, find.synology.com ne trouve rien.

 

Essayé les deux boot-loaders: celui de Jun et celui modifié par Genesys pour utiliser le MBR, résultat identique.

 

Dois-je changer de machine ou y a-t-il une solution ?

 

Merci.

Share this post


Link to post
Share on other sites
Il y a 14 heures, mim67 a dit :

- Processeur: VIA C3 1GHz
- Mémoire: DDR-SDRAM 512 Mo PC3200
- Disque dur: 120 Go IDE
- Carte graphique: VIA UNICHROME PRO (intégrée)
- Carte Mère: VIA EPIA PD10000  

 

Lol, pour une config légère c'est même très légère et je diraist TRES ANCIENNE! Déjà que le support des CPU AMD n'est pas garantie alors du VIA C3...  

Share this post


Link to post
Share on other sites
Il y a 7 heures, nicoueron a dit :

 

Lol, pour une config légère c'est même très légère et je diraist TRES ANCIENNE! Déjà que le support des CPU AMD n'est pas garantie alors du VIA C3...  

Oui, merci nicoueron, je crois que je peux oublier cette config, c'est bien ce que je subodorais !

Je vais m'orienter vers autre chose d'un peu plus musculeux, Intel semble avoir moins de problème avec XPEnology.

 

Share this post


Link to post
Share on other sites
Le 16/03/2018 à 19:03, mim67 a dit :

Oui, merci nicoueron, je crois que je peux oublier cette config, c'est bien ce que je subodorais !

Je vais m'orienter vers autre chose d'un peu plus musculeux, Intel semble avoir moins de problème avec XPEnology.

 

Ce qu'il faut voir, c'est que je suis le premier à dire que recycler nos vieilles machines vers un NAS est plutôt judicieux mais disons qu'il y a des limites! Typiquement mon 486DX2 66MHz est à la benne depuis longtemps et pourtant c'est du Intel^^

Share this post


Link to post
Share on other sites

Bonsoir à tous, énorme merci à la communauté qui m'a permis d'installer DSM sur mon petit zotac ion itx n330 (overclock à 2Ghz)  avec 4Go de RAM . Tuto très clair et précis. Pour le moment tout fonctionne bien. A bientôt 

Share this post


Link to post
Share on other sites

Bonjour a tous et merci pour ce post.

Cependant j'ai un problème.

J'ai un nuc premier generation i3 4go de ram et un ssd de 120go sous windows 10 qui me sert plus. Je veux donc le convertir en nas et brancher un disque dur externe dessus.

J'ai crée la clé usb (carte sd de 16go), boot dessus, depuis mon mac via le site de synology assistant, je vois bien le nas, mais quand je veux faire l'installation j'ai l'erreur 35, impossible de formater le disque dur.

Que puis je faire?

Merci d'avance.

Share this post


Link to post
Share on other sites
12 hours ago, Jef Dc said:

Bonjour a tous et merci pour ce post.

Cependant j'ai un problème.

J'ai un nuc premier generation i3 4go de ram et un ssd de 120go sous windows 10 qui me sert plus. Je veux donc le convertir en nas et brancher un disque dur externe dessus.

J'ai crée la clé usb (carte sd de 16go), boot dessus, depuis mon mac via le site de synology assistant, je vois bien le nas, mais quand je veux faire l'installation j'ai l'erreur 35, impossible de formater le disque dur.

Que puis je faire?

Merci d'avance.

 

 

Le SSD a t-il été formaté au préalable?

 

Share this post


Link to post
Share on other sites

Non, il y avait Windows 10 dessus. 

Depuis j’ai installé Openmediavault, mais j’aime pas du tout. 

J’ai réessayé d’installer Xpenology mais toujours le même résultat....

Share this post


Link to post
Share on other sites
53 minutes ago, Jef Dc said:

Non, il y avait Windows 10 dessus. 

Depuis j’ai installé Openmediavault, mais j’aime pas du tout. 

J’ai réessayé d’installer Xpenology mais toujours le même résultat....

 

Formatez le SSD complètement si possible au format ext3 sinon fat. Assurez vous qu'il n'y est aucune partition.

https://www.synology.com/en-global/knowledgebase/DSM/tutorial/General/What_can_I_do_when_I_get_the_error_message_quot_Failed_to_format_disk_quot_when_formatting_data_partition_during_the_setup

Share this post


Link to post
Share on other sites

bonjour

 

pour l’erreur 35 synology a une page :

https://www.synology.com/fr-fr/knowledgebase/DSM/tutorial/General/What_can_I_do_when_I_get_the_error_message_quot_Failed_to_format_disk_quot_when_formatting_data_partition_during_the_setup

 

en gros tu dégage toute les partitions, et meme pas sur que cela fonctionne pour deux raison :

 

1 - un SSD "imite" le comportement d'un HDD a plateau, il est possible que certaine commandes que DSM envoie ne soit pas pris en charge ( la roulette russe des fabriquant de SSD et des chipset SATA )

 

2-  je ne sais pas si synology prévois l'usage d'un ssd en stockage ...en cache ssd pas de souci

 

en plus un sdd :

- a une duré de vie limité en fonction du nombre d’écriture

- n'a aucun avantage de vitesse dans un NAS car l’élément limitant est la partie reseau ( sauf si tu a une carte 10Gb )

- a une tailles assez petite et le GB est tres chère

 

j'ai le meme petit nuc que toi, dedant on peut mettre que du 2.5"" et un seul HDD mais par contre il y a 2 port SATA

sincèrement prend toi deux boitier externe pour HDD 3.5" avec une interface esata et 2cables esata<>sata

l'alimentation du nuc est trop juste pour ces disques et surtout tu pourra faire un moin un RAID 1 pour garantir un minimum de sécurité

le nuc consomme que 20W en charge maximum pour fair un nas c'est juste une très bonne basse

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai malheureusement fait la mise a jour en DSM 6.2-23739  avec june1.02

est il possible de retourner en arrière downgrade en 6.1.7 ?

 

Merci

Share this post


Link to post
Share on other sites
Il y a 2 heures, zzuutt a dit :

Bonjour,

 

J'ai malheureusement fait la mise a jour en DSM 6.2-23739  avec june1.02

est il possible de retourner en arrière downgrade en 6.1.7 ?

 

Merci

 

Bonjour,

 

Tu peux essayer de booter avec le nouveau June 1.03a2 https://mega.nz/#F!BtFQ2DgC!JgomNP3X8V9EuwxL4TXbng

Car pour downgrade il faut nécessairement avoir accès en SSH pour modifier /etc.defaults/VERSION

Share this post


Link to post
Share on other sites
Il y a 3 heures, stefauresi a dit :

 

Bonjour,

 

Tu peux essayer de booter avec le nouveau June 1.03a2 https://mega.nz/#F!BtFQ2DgC!JgomNP3X8V9EuwxL4TXbng

Car pour downgrade il faut nécessairement avoir accès en SSH pour modifier /etc.defaults/VERSION

 

Bonjour,
Merci

mais ma version est DS3615xs. La version June 1.03a2 est pour DS918 je ne sais pas si elle convient.

j'ai tenté de booter avec mais je reste bloqué sur l'ecran "Screen will stop updating...."

l'assistant trouve rien

 

Est il possible de reinstaller la 6.1.7 ? avec June 1.02 comment procéder ?

si je boote sur le cle june1.02,  il charge le kermel et reboote un moment après

 

Merci

Share this post


Link to post
Share on other sites
il y a 32 minutes, zzuutt a dit :

 

Bonjour,
Merci

mais ma version est DS3615xs. La version June 1.03a2 est pour DS918 je ne sais pas si elle convient.

j'ai tenté de booter avec mais je reste bloqué sur l'ecran "Screen will stop updating...."

l'assistant trouve rien

 

Est il possible de reinstaller la 6.1.7 ? avec June 1.02 comment procéder ?

si je boote sur le cle june1.02,  il charge le kermel et reboote un moment après

 

Merci

 

Malheureusement impossible si tu n'as aucun accès via SSH a ton NAS  

Share this post


Link to post
Share on other sites
Il y a 4 heures, stefauresi a dit :

 

Malheureusement impossible si tu n'as aucun accès via SSH a ton NAS  

 

Merci :(

je vais attendre le nouveau boot

Share this post


Link to post
Share on other sites

Bonjour

 

Si on est passé en version 6.2 sur un Gen 8, que l'on veut faire un downgrade et repasser en 6.1.7-15284, quelle est la procédure à suivre ?

 

Si on change le /etc.defaults/VERSION, que doit on mettre dedans, et y a t il autre chose à faire ?

 

Cela va t il debricker le NAS ? De nouveau accessible via Syno assistant ?

 

Peut on faire ce changement directement en accédant au disque (Disque branché sur un pc directement avec lecture des partitions EXT3/4 ?

 

Le downgrade reinitialise t il tous les parametres (Compte Photostation par exemple) ?

 

Ma config est un disque systeme, et 4 Disque en Raid pour les données.

 

 

Merci d'avance de vos réponses !

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Tu les la version que tu souhaite installer soit 6.1.7....

Non rien d'autre ensuite tu boot sur la clé usb avec le Bo loader et tu suis la procédure. 

Pas de perte de config dans la théorie 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now