Polanskiman

[Tuto] Installer/Migrer DSM 5.2 à 6.1.x (Loader Jun)

Recommended Posts

On 08/10/2017 at 6:17 PM, fabriceunko said:

 

bonsoir, je vais tenter de faire la migration de 6.0.2 à 6.1 sur un HPgen 8

mais j'ai deux questions avant de me lancé .

au niveau 3 il faut choisir quel option dans le menu? le choix 1 ou re-install?..

et le fichier pat je peux le mettre sur une autre clef usb?

 

Bonjour, j'ai pris le risque de faire la migration, celle ci a bien réussi. par contre après le reboot impossible de trouvé le nas. si quelqu'un peux m'aider? merci d'avance, tout cela sur un gen8.

 

finalement j'ai rebooter 2 fois et j'ai fini par le retrouvé. cela semble fonctionner parfaitement.

Edited by fabriceunko
mise a jours

Share this post


Link to post
Share on other sites
On ‎07‎/‎10‎/‎2017 at 12:08 PM, Polanskiman said:

 

Votre problème est résolu?

Désolé pour le temps de réponse.
Pour le coup j'ai relancé une installation propre, tout est passé et fonctionnel.

 

Essayé de migré un second serveur, en désactivant le https, et en remettant les ports par défaut avant la migration c'est passé aussi bien que j'ai absolument pas le même message de boot du loader sur le serveur

 

Suis actuellement sur l'update 6 sur les 2 serveurs.

Merci pour le taff !

Share this post


Link to post
Share on other sites

Vendredi, je suis passé en update 7.

Ça fonctionne, sauf que j'ai un disque dur qui m'a lâché au même moment.

Apres le disque changé, tout est opérationnel (sans perte de fichiers) Merci Xpenology et Synology.

Capture.PNG

Edited by MicroFire

Share this post


Link to post
Share on other sites

Bonjour à tous,

merci encore pour ce super boulot. Cela fait maintenant quelques années que j'utilise xpenology 5.2 sur un N54L et je voudrais monter en version 6. Or, je cale sur une question bête. Dés que j'éssaie de monter le fichier img pour éditer le grub.cfg  avec osfmnt, mon windows veut formater l'image. Si je génère la clé, je vois bien la partition efi mais impossible de l'éditer .

Que faire ?

Merci d'avance

Share this post


Link to post
Share on other sites

Je me réponds à moi même. En fait la clé était lisible directement à partir du file station

Share this post


Link to post
Share on other sites
3 hours ago, Al73 said:

Je me réponds à moi même. En fait la clé était lisible directement à partir du file station

Salut ! j'ai un HP N54L également, est ce que la MAJ s'est bien passée ?? Je me tate à faire la migration :)

 

Merci !

Share this post


Link to post
Share on other sites

Pour ma part, j'ai un N40L( processeur AMD du coup )

J'ai du désactiver dans le BIOS le paramètre C1E.

Une fois cela fait, j'ai pu trouver mon NAS sur l'assistant synology.

 

Par contre, après install, certains services tournent : SMB, plex, transmission, mais pas d'administration via le Web !

 

J'ai du relancer l'installation avec le fichier PAT donné dans le tuto pour le retrouver mais à présent, ca roule ;)

 

Share this post


Link to post
Share on other sites

Merci encore pour le gros boulot fourni!!!  Je ne peux plus me passer de mon xpenology monté dans une tour serveur..

 

Pour ma part maj depuis le 5.2 5967 vers 6.1.3 update 4 actuellement... franchement nickel... juste la création de la clé usb avec les infos nécessaires (pid vid) boot sur la clé... synology assistant trouve bien un serveur a migré... mise du .pat dans le logiciel et en avant !! RAS aucune pertes de données juste la perte des configurations du nas (paramètres réseaux et utilisateurs a reconfigurer..)

 

 

Edited by speeder974
Detail

Share this post


Link to post
Share on other sites

Hello,

 

Mon petit retour sur le passage en DSM6.

 

Tout d'abord j'ai retiré tous mes disques et la clé USB pour vérifier que ca roule a peu prêt sans casser l'existant. Clé USB neuve et un vieux disque de PC portable pour le test.

 

Déjà la partie hardware :

CM : ASRock AM1B-ITX

CPU : AMD Athlon 5350 (2.05 GHz)

 

Quand je lis le tuto, partir avec un CPU AMD n'est pas un avantage. Pour commencer j'ai pas trouvé l'option C1E dans le BIOS.

 

Remarque 1 : J'ai pris le launcher du 3617, du coup ajustement sur le fichier .PAT. Il clairement écrit qu'il s'agit d'une version "alpha"

Remarque 2 : J'ai pas trouvé le fichier extra.lzma, surement parce que j'ai pris le bon launcher.

 

Sinon tout c'est bien passé, j'ai même tenté de faire immédiatement la dernière MAJ du DSM via l'interface classique, ca semble ok, je me retrouve en update 8.

 

J’ai galéré a créer le volume car mon disque a des secteurs défectueux, j’ai du virer les warnings pour créer le raid group et le volume.

 

1er test : La partie acces externe, connexion vers mon compte syno sans problème.

2ème test : Utilisation de la partie Cloud Sync. Pas de problème.

 

J’arrête pour ce soir !

 

Que testeriez-vous comme point critique ?

 

Pour réutiliser mes disques qui étaient en RAID sous la version DSM 5, vous me conseillez quoi ?

 

Si vous avez des questions/conseils, n’hésitez pas

 

Par exemple est ce qu'il déconseillé de partir sur la version 3617?

 

Bonne soirée !

Edited by deyko

Share this post


Link to post
Share on other sites
On 10/26/2017 at 4:37 AM, deyko said:

Déjà la partie hardware :

CM : ASRock AM1B-ITX

CPU : AMD Athlon 5350 (2.05 GHz)

 

Quand je lis le tuto, partir avec un CPU AMD n'est pas un avantage. Pour commencer j'ai pas trouvé l'option C1E dans le BIOS.

 

Parce que cela est une fonctions que l'on ne trouve pas sur tous les bios. Sur les HP comme par exemple N40L ou N54L oui. J'ai mis une note dans le tuto pour clarifier.

 

On 10/26/2017 at 4:37 AM, deyko said:

Remarque 1 : J'ai pris le launcher du 3617, du coup ajustement sur le fichier .PAT. Il clairement écrit qu'il s'agit d'une version "alpha"

 

Qu'est ce qui est une version alpha? Le dernier loader en date, v1.02b, n'est pas au stade alpha mais beta comme la lettre finale l'indique.

 

On 10/26/2017 at 4:37 AM, deyko said:

Remarque 2 : J'ai pas trouvé le fichier extra.lzma, surement parce que j'ai pris le bon launcher.

 

Le fichier extra.lzma est deja inclu dans les loader. Si vous faites référence au ramdisk personnalisé extra.lzma_v3 celui ci ne s'applique que pour le loader DS3615xs mais j'ai clairement mentionné qu'il est actuellement hors ligne pour des raisons de débugage. Personne que je sache n'a fait de ramdisk personnalisé pour les loader DS3617xs et DS916+.

 

On 10/26/2017 at 4:37 AM, deyko said:

Pour réutiliser mes disques qui étaient en RAID sous la version DSM 5, vous me conseillez quoi ?

[...]

Par exemple est ce qu'il déconseillé de partir sur la version 3617?

 

Déjà je conseille de brancher les disques dans le même ordre dans lequel ils étaient. Cela évitera une dégradation.

Je conseille aussi d'utiliser DS3615xs. Pas trop d'avantage à utiliser le DS3617xs et surtout beaucoup plus de personnes qui l'utilisent. Vous ne verrez que 2 coeurs mais cela est cosmétique. DSM utilisera les 4.

Je conseil un backup aussi si possible.

Enfin, même si ce tuto indique comment faire une migration de DSM5.2 à DSM6.1 il est toujours préférable de faire une installation fraiche lorsque l'on passe d'une version major à une autre. Cela évite de trainer des bugs, surtout en étant sur une XPEnology. Cela à pour conséquence la perte de toute la configuration/app mais au moins pas de bug potentiels. Les données personnelles ne sont pas touchées car elle sont sur un partition différente que DSM.

Share this post


Link to post
Share on other sites

Hello,

 

Merci de ton retour.

 

Je parle de version "alpha" car c'est ce qui indiqué lorsqu'on branche un écran sur le NAS lorsqu'il tourne. 

Mon loader provient de :

https://mega.nz/#F!BtFQ2DgC!JgomNP3X8V9EuwxL4TXbng!R4VmQbaC

J'ai comparé la signature du fichier avec celui là :

https://mega.nz/#!OZhyWDjD!GHQIQcixNhz0EEQvA70sdZU67pgvZ0ndLtmPUlVNMtM

Les deux signatures md5 sont les mêmes.

 

A quel rythme évolue les version en générale? Est ce qu'on peut espérer une version finale d'ici peu ?

Je vais tenter de faire une installation fraîche mais ce n'est pas facile d'avoir plusieurs To de dispo en spare :)

 

En tout cas j'ai été étonné avec quelle simplicité l'installation a pu se faire en suivant le tuto. En gros en 15mn c'était installé !

 

Merci pour le travail réalisé.

Si je peux aider, n'hésitez pas. Je n'ai pas de données pour le moment sur le NAS, je tourne toujours avec un disque de dépannage.

 

Bonne journée !

Edited by deyko

Share this post


Link to post
Share on other sites
1 hour ago, deyko said:

Je parle de version "alpha" car c'est ce qui indiqué lorsqu'on branche un écran sur le NAS lorsqu'il tourne. 

Mon loader provient de :

https://mega.nz/#F!BtFQ2DgC!JgomNP3X8V9EuwxL4TXbng!R4VmQbaC

J'ai comparé la signature du fichier avec celui là :

https://mega.nz/#!OZhyWDjD!GHQIQcixNhz0EEQvA70sdZU67pgvZ0ndLtmPUlVNMtM

Les deux signatures md5 sont les mêmes.

 

Si vous faites référence à la phrase: "Note: this is an alpha build, for testing purpose only." alors c'est que Jun a simplement oublié de mettre à jour le fichier info.txt. Par contre si vous voyez 1.02a ou v1.02a2 en lieu et place de ce qui est indiqué dans l'image ci dessous alors c'est que vous êtes entrain d'utiliser la version v1.02a ou v1.02a2 et non v1.02b et je vous conseille de refaire la clef usb avec l'une des 2 images dans les liens ci-dessus sachant que v1.02a ou v1.02a2 sont obsolète et contiennent des bugs.

59b918576ab4a_ScreenShot2017-09-12at5_18_08PM.jpg.a28433c5e952a9b852eee74be651549b.jpg

 

1 hour ago, deyko said:

A quel rythme évolue les version en générale? Est ce qu'on peut espérer une version finale d'ici peu ?

Je vais tenter de faire une installation fraîche mais ce n'est pas facile d'avoir plusieurs To de dispo en spare :)

 

Cela dépend. 1 ou 2 ans environ. DSM 6.1 est sorti il y a un peu plus d'un an. DSM 6.2 est encore en beta. Pour le loader et il n'y a pas de date précises. Ca dépend des développeurs mais la version beta actuelle est plus que final a mon avis. Elle marche depuis plusieurs mois et a mon avis il n'y en aura pas d'autre poure DSM 6.1 à moins qu'une mise à jour de DSM viennent cassé le loader.

Pour faire une installation fraiche il suffit de remettre tous les disques, lancer avec le nouveau loader, et lorsque DSM propose de soit conserver la configuration ou tout reinstaller il faut choisir réinstaller. 

Share this post


Link to post
Share on other sites

Refaire une installe clean me convient tout a fait. Je ne souhaite garder ni la conf du syno, si les packages applicatifs

 

J'ai une question concernant ce qui est gardé ou non lors de la migration.

Je distingue les données de la façon suivante :

- Configuration OS du Syno

- Configuration application (Package)

- Données

 

Avec l'option "réinstaller" je perds quoi exactement ?

La conf Syno au minimum, au niveau de la conf des packages ca va donner quoi?

 

Merci du retour !

Share this post


Link to post
Share on other sites

Mon disque de test a crashé, il était vraiment en mauvais état. (Rien qu'a l'initialisation du Syno j'ai du spécifier de pas prendre en compte les bloques défectueux)

 

Au final j'ai rebranché mes anciens disques avec la clé USB que je venais de préparer, on ne remarque aucune différence avec une procédure de migration de Syno. 

 

Toutes les données sont là avec un conf reset du syno. Parfait !

 

Maintenant a voir sur la durée si c'est stable ...

Share this post


Link to post
Share on other sites
4 hours ago, deyko said:

Mon disque de test a crashé, il était vraiment en mauvais état. (Rien qu'a l'initialisation du Syno j'ai du spécifier de pas prendre en compte les bloques défectueux)

 

Au final j'ai rebranché mes anciens disques avec la clé USB que je venais de préparer, on ne remarque aucune différence avec une procédure de migration de Syno. 

 

Toutes les données sont là avec un conf reset du syno. Parfait !

 

Maintenant a voir sur la durée si c'est stable ...

 

Maintenant désactivez les mise à jour automatiques et à chaque fois que DSM vous notifie qu'il y a une mise à jour, votre premier réflexe doit être de venir sur le forum voir si cette mise jour ne casse pas l'installation. Ne faites jamais de mise à jour avant consultation sur une machine en productions.

Share this post


Link to post
Share on other sites

Salut à tous,

 

Je suis newbie sur ce site et sur Xpenology. Néanmoins je suis à l'aise avec l'informatique.

 

Mon projet : installer Xpenology sur un serveur HPE Proliant Gen10.

 

J'ai cru lire qu'il est impossible d'installer Xpenology sur une machine à base AMD. J'ai vu des avis partagés à gauche et à droite sur posts qui remontent à pas mal de temps déjà. Alors me disant que l'informatique évolue très rapidement, j'aimerais, avant de suivre ce super tuto, avoir la certitude que je peux installer Xpenology avec la version DSM 6.x sur mon système...

 

Merci par avance de votre aide ;)

Share this post


Link to post
Share on other sites

Hello,

 

Pour info je viens de tenter le 6.1.3 update 8 sur mon serveur de PREPROD, c'est KO.

 

Crash au boot :?

Share this post


Link to post
Share on other sites
54 minutes ago, ZaGaPonG said:

Hello,

 

Pour info je viens de tenter le 6.1.3 update 8 sur mon serveur de PREPROD, c'est KO.

 

Crash au boot :?

Autant pour moi, il s'agissait d'un changement de conf autre qui provoquait le crash.

 

Montée en PROD: 6.1.3 update 8 OK sur DS3615xs (Gen8)

Edited by ZaGaPonG

Share this post


Link to post
Share on other sites

Bonjour,

 

Comment faites-vous pour booter sur le loader depuis ESXI ??

Car pas de fichierVMDK sur le lien MEGA... Vous convertissez le .img ? 

 

Merci pour votre aide

Share this post


Link to post
Share on other sites
On 07/11/2017 at 9:44 AM, Jiel62 said:

Car pas de fichierVMDK sur le lien MEGA... Vous convertissez le .img ? 

 

Alors là j'ai un peu honte :? Je prône Vmware et je dois avouer que je ne sais plus comment j'ai réussi a avoir un vmdk en sortie...

image.thumb.png.4493bbd8616c128f7c43a2d08a26cef7.png

Share this post


Link to post
Share on other sites

Lol bizarre ça :P

 

Bon finalement j'ai trouvé un tuto sur le forum, le gars fait une conversion du fichier img en vmdk.

 

Fonctionne sur une VM de test vierge mais par contre j'ai peur de passer à l'acte sur mon NAS en prod... 

Et sinon avec la dernière maj en 6.1.4 y a pas de problème ? 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Jiel62 said:

Et sinon avec la dernière maj en 6.1.4 y a pas de problème ? 

yes. Chez moi et plusieurs personnes de la section anglaise n'ont rencontrées aucun souci.

Il n'est pas impossible que je sois passé par StarWind V2V Image Converter pour y parvenir effectivement

Share this post


Link to post
Share on other sites

Je confirme je suis passé aussi par ce logiciel pour la conversion du fichier img

 

Je viens de passer de la 6.0.2 à la 6.1.4 sur mon NAS de prod et tout est ok :11_blush:

 

Merci ;) 

Share this post


Link to post
Share on other sites

L'upgrade de la 6.1.3-15152-8 vers la 6.1.4-15217-1 ne marche pas avec le bootloader 1.02b pour informations

Share this post


Link to post
Share on other sites
10 hours ago, Tussana said:

L'upgrade de la 6.1.3-15152-8 vers la 6.1.4-15217-1 ne marche pas avec le bootloader 1.02b pour informations

As-tu bien redémarré ton NAS ?

Perso jamais eu de souci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now