Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.1.x (Jun's loader)

Recommended Posts

8 hours ago, djelusion said:

Thats something I was considering. The main question is can users using a 5.2 loader use the same mac info the 6.x loader? vid / pid is simple but the mac scheme im not sure if thats changed causing the newer loaders not to work properly?.

 

The MAC address has nothing to do with how the loader works. It's just there so that the information can be passed on to the kernel when booting. I recommend using the real MAC address of your NIC. As for the S/N I recommend you use a generated one as described in the tutorial. Synology changed the format of the S/N two years ago. 

 

Try the above process described by @IG-88. Since you are on DSM 5.2 and in order to make sure that the upgrade process will not be an issue, I would suggest to install DSM 5.2 on a spare drive with Trantor's old XPenoboot loader and then upgrade to DSM 6.1.3 following the above tutorial. That way you know for sure that the upgrade process works instead of doing a plain fresh install of DSM 6.1.3 which will only tell you one thing: DSM 6.1.3 work or not as a fresh install. It requires a bit more work but at least it will provide you peace of mind.

Share this post


Link to post
Share on other sites

Am I wrong or can step 4 be drastically speed up by burning the .img to the stick and editing the grub.cfg on the stick (showing up in Windows Explorer)? So no OSFMount  needed...

Share this post


Link to post
Share on other sites
1 hour ago, ACCakut said:

Am I wrong or can step 4 be drastically speed up by burning the .img to the stick and editing the grub.cfg on the stick (showing up in Windows Explorer)? So no OSFMount  needed...

 

yes, but you have to use a editor thats aware of unix text format, windows notepad ist not able to do that

if your hardware is workin with the drivers and firmware jun provides with the image, if you neet the extra.lzma to extend driver support, thats on the 2nd partition so you will have to use osfmount

Share this post


Link to post
Share on other sites
On 9/14/2017 at 5:04 AM, nleeies said:

I'm having trouble with both this loader as well as the 1.01 loader with an Atheros 8151 NIC. It seems as though the atl1c driver does not detect the hardware - the grub menu shows nothing with a net_ls_cards command, and the light is solid amber after booting the kernel. No new DHCP requests show up in my router's logs.

 

I have (likely incorrectly) attempted to compile the driver with the 15152 build as reference for the 1.02b loader, but ended up with the same result.

 

The NIC is confirmed working, as an Ubuntu live USB has no issue using atl1c.

 

Any advice?

Just an update - I have picked up a PCI-E NIC to get this thing up and running just to see if it even recognizes the AR8151. It seems the correct driver is used and the controller is recognized:

 

0000:03:00.0 Class 0200: Device 1969:1083 (rev c0)
        Subsystem: Device 1458:e000
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fbcc0000 (64-bit, non-prefetchable)
        I/O ports at df00 
        Capabilities: [40] Power Management version 3
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [58] Express Endpoint, MSI 00
        Capabilities: [6c] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [180] Device Serial Number ff-02-b3-f8-18-d6-c7-ff
        Kernel driver in use: atl1c


 

But the interface doesn't show up with an ifconfig -a, nor does it show up in DSM.

 

Any other diagnostics that I could run to find out why DSM just won't pick up the NIC?

Edited by Polanskiman
added proper code tags

Share this post


Link to post
Share on other sites

this driver is already part of the default 1.02b loader (jun) so try if the synology assistant finds your system when you boot 1.02b image (no need to install dsm 6.1.x just try to see if the "recent" version does work, if not i will put it on the list of drivers that will have to be compiled from external source)

Share this post


Link to post
Share on other sites
On 9/13/2017 at 3:13 PM, dotslash said:

Oh! I'm running on HP proliant gen8 and works perfectly!

 

Which model are you running on?

Because on my DL360 G7 i'm getting the following error, when I try to install/format

 

Quote

Failed to format the drives (35)

 

Edited by emkookmer
formating

Share this post


Link to post
Share on other sites
5 hours ago, emkookmer said:

 

Which model are you running on?

Because on my DL360 G7 i'm getting the following error, when I try to install/format

 

 

I've the same issue with a microserver Gen8 and a SAS Controler HPSA

I try the IG-88 extra.lzma whith the june 1.02B

The HPSA.KO is on the extra.lzma.

The disks are discover.

But the disks aren't recognize correctly.. the var/log/message say: Read Capacity failled for each disk.

I have tryed xpenology 5.2 and all work fine.

 

Could U help me to solve this issue ?

Thanks.

 

 

Share this post


Link to post
Share on other sites
23 hours ago, emkookmer said:

 

Which model are you running on?

Because on my DL360 G7 i'm getting the following error, when I try to install/format

 

 

Gen8 G1610T

Share this post


Link to post
Share on other sites

Hi - please note my current setup:

 

1. ESXi 6 on HP Gen8 microserver with 16GB memory

2. XPEnology ISO currently used: XPEnoboot_DS3615xs_5.2-5592.2.iso in a virtual machine

3. Current DSM Version: DSM 5.2-5644 Update 3

 

Could you please advise how I can update my DSM to the latest possible version? I have read this forum and cannot seem to find instructions specific to help me - but if the information is already provided somewhere, please accept my apology and point me in the right direction.

 

Thank you!

Share this post


Link to post
Share on other sites

Do i need to be on the latest 5.2 for this to work or can i get to DSM 6 from 5.2 -5592 update 3? 

 

I've followed the guide but when i get to the pat update i constantly get ' failed to upload the DSM installation file. Please check the network connection and try again. (54)' error. If anyone has any tips on how to get this fixed please let me know.

 

Alternatively if anyone has an img for 'XPEnoboot DS3615xs5.2-5644.5' that would be appreciated as i can't download that from here either error 522.

  • Like 1

Share this post


Link to post
Share on other sites

Should i change serial to one from new serial generator, or just use the one im currently on (from exel file) ?.

 

Also if switching to ds 916 what about serial ? stay on ds3615 ? the ds916 would be near perfect hardware match for me.

 

 

Share this post


Link to post
Share on other sites
42 minutes ago, imran said:

Hi - please note my current setup:

 

1. ESXi 6 on HP Gen8 microserver with 16GB memory

2. XPEnology ISO currently used: XPEnoboot_DS3615xs_5.2-5592.2.iso in a virtual machine

3. Current DSM Version: DSM 5.2-5644 Update 3

 

Could you please advise how I can update my DSM to the latest possible version? I have read this forum and cannot seem to find instructions specific to help me - but if the information is already provided somewhere, please accept my apology and point me in the right direction.

 

Thank you!

just look for topics cintaining HP Gen8 or use the search funcktion

i don't think you will find a more specific/detailed upgrade descrition then in this topic for your specific hardware, just read about what people say and what (specific) problems they had with that modell

 

 

 

it often used so you will find information and you also can PM a owner of such system for advice

Share this post


Link to post
Share on other sites
28 minutes ago, leigh258 said:

Do i need to be on the latest 5.2 for this to work or can i get to DSM 6 from 5.2 -5592 update 3? 

 

I've followed the guide but when i get to the pat update i constantly get ' failed to upload the DSM installation file. Please check the network connection and try again. (54)' error. If anyone has any tips on how to get this fixed please let me know.

 

Alternatively if anyone has an img for 'XPEnoboot DS3615xs5.2-5644.5' that would be appreciated as i can't download that from here either error 522.

what hardware? storage and notwork controller have to be supported be the bootloader you are using

did you try the additional extra.lzma?

Share this post


Link to post
Share on other sites
29 minutes ago, NightSmoker said:

Should i change serial to one from new serial generator, or just use the one im currently on (from exel file) ?.

 

Also if switching to ds 916 what about serial ? stay on ds3615 ? the ds916 would be near perfect hardware match for me.

 

 

serial is only importend for some funcrions like hardware transcoding (on 916+) and one or two wrote that they have used the sn of a real hardware 916+ to get it working - if you read the forum rules you will find that tossing aroud serials and generators is not allowed so discussion about that is limted (besides i dont care if synology is messing around to much there are other solutions then dsm like open media vault and they have much less problems with hardware support - witch makes about 70%-90 of the traffic here)

 

Share this post


Link to post
Share on other sites
10 minutes ago, IG-88 said:

what hardware? storage and notwork controller have to be supported be the bootloader you are using

did you try the additional extra.lzma?

Hi,

You've just reminded me that i changed MB's so maybe that is the reason, I currently run Gigabyte GA-78LMT-S2P Rev5 Motherboard. This has the  Atheros GbE LAN controller. I haven't used the extra.Izma as i overlooked the AMD chip. Will try that tonight to see if that works.

Share this post


Link to post
Share on other sites
2 hours ago, IG-88 said:

just look for topics cintaining HP Gen8 or use the search funcktion

i don't think you will find a more specific/detailed upgrade descrition then in this topic for your specific hardware, just read about what people say and what (specific) problems they had with that modell

 

it often used so you will find information and you also can PM a owner of such system for advice

 

Hi IG-88, thank you for your reply. Sorry for I didn't mean to draw attention on the hardware aspects. The key question is how to update the XPEnology DSM in an ESXi virtual environment. Since I am not using a physical USB drive to boot of the loader how I do deal with updating the VID / PID kind of configuration. If anyone has updated the ESXi VM XPEnology that information would be very helpful. Thank you.

Share this post


Link to post
Share on other sites
29 minutes ago, imran said:

Hi IG-88, thank you for your reply. Sorry for I didn't mean to draw attention on the hardware aspects. The key question is how to update the XPEnology DSM in an ESXi virtual environment. Since I am not using a physical USB drive to boot of the loader how I do deal with updating the VID / PID kind of configuration. If anyone has updated the ESXi VM XPEnology that information would be very helpful. Thank you.

 

with his 1.02a jun delivered not just the *.img file, he also had a vmdk file (text) that referenced to the img file, the later releases did not contain this, i' still using this vmdk "template" for virtual box vm's (with 1.02b)

same way is this (esxi is kind of common here)

there is also a converter for vmdk files but i cant remember the name or find the topic where its mentioned

Edited by IG-88

Share this post


Link to post
Share on other sites
26 minutes ago, IG-88 said:

 

hhere is also a converter for vmdk files but i cant remember the name or find the topic where its mentioned

 

i was refering to "StarWind V2V Image Converter"

Share this post


Link to post
Share on other sites
On 9/16/2017 at 2:04 AM, ACCakut said:

Am I wrong or can step 4 be drastically speed up by burning the .img to the stick and editing the grub.cfg on the stick (showing up in Windows Explorer)? So no OSFMount  needed...

 

On 9/16/2017 at 3:38 AM, IG-88 said:

 

yes, but you have to use a editor thats aware of unix text format, windows notepad ist not able to do that

if your hardware is workin with the drivers and firmware jun provides with the image, if you neet the extra.lzma to extend driver support, thats on the 2nd partition so you will have to use osfmount

 

Yes and no. You can do that with Windows 10. However, if my memory serves me well earlier versions of Windows will not allow the usb to mount in the file explorer thus the need to use OSFMount.

 

As for Linux or any other flavoured unix OS (ubuntu, xubuntu etc etc) it should mount without any problem.

Share this post


Link to post
Share on other sites
10 minutes ago, Polanskiman said:

 

 

Yes and no. You can do that with Windows 10. However, if my memory serves me well earlier versions of Windows will not allow the usb to mount in the file explorer thus the need to use OSFMount.

 

 

the first partion (grub.cfg) is always shown (any windows version with usb and fat support), the second partition  (extra.lzma) since winddows 10 creators update (1703 or 10.0.15063 aka Redstone2) and this seems mandatory now for all win10 consumer installtions (as it goes for microsoft and you let them do it by windows update)

 

Share this post


Link to post
Share on other sites
2 minutes ago, IG-88 said:

 

the first partion (grub.cfg) is always shown (any windows version with usb and fat support), the second partition  (extra.lzma) since winddows 10 creators update (1703 or 10.0.15063 aka Redstone2) and this seems mandatory now for all win10 consumer installtions (as it goes for microsoft and you let them do it by windows update)

 

 

Ok, good to know. I mostly work on MAC so rarely use Windows. Case closed.

Share this post


Link to post
Share on other sites

Hi

Does anyone have any info on how to Migrate/Upgrade from 6.0.x to 6.1.x 

which ever option i select on boot ie reinstall does not give me the migration screen in find.synology.com

the diskstation just boots as normal.

 

any ideas?

 

cheers

 

Share this post


Link to post
Share on other sites
13 minutes ago, andyrav said:

Hi

Does anyone have any info on how to Migrate/Upgrade from 6.0.x to 6.1.x 

which ever option i select on boot ie reinstall does not give me the migration screen in find.synology.com

the diskstation just boots as normal.

 

any ideas?

 

cheers

 

follow guide at start of this thread, just upgraded and worked fine.

Share this post


Link to post
Share on other sites
36 minutes ago, NightSmoker said:

follow guide at start of this thread, just upgraded and worked fine.

 

depends on what hardware is used

if a extra.lzma was used with 6.0.2 then the migration might fail because of missing divers

its good to know what kernel modules where loaded for network and storage, then you can check if this *.ko files are present in 6.1

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now