Tutorial: Install/Migrate DSM 5.2 to 6.1.x (Jun's loader)

Recommended Posts



I am currently trying to get xpenology working on a HP ex490 bare metal. Main difficulty is the headless setup, no eye on the booting process.

Tho it seems to be booting fine on the loader, but I can't seem to manage to catch the diskstation on the Syno assistant.


I am using the 3615xs loader 1.02b from Jun's Mega repo.


I have tried to plug the ex490 on my main network, I can see it request an IP in my DHCP server and I can ping it properly. It gives its hostame "diskstation".

I have tried to plug the ex490 on my laptop directly with a local DHCP server, same deal : request an IP, is pingable.seenonnetwork.thumb.PNG.487cab40047e00d92dfc16b91eef38e9.PNG


I have tested multiple speed on the port switch port, it works the same in 1000/100 full or half duplex (request an IP, can ping).

I have another official Syno on the network which is being discovered properly by the assistant.

I have tested my USB loader on a bridged VM, works fine, request and IP, is seen by the assistant, can install latest PAT and all...


I have tested with the custom extra.lmza, apparently it does not work properly as the ex490 never request an IP.

i have changed all VID/PID/Serial/MAC details.


Anyone ever managed to get one of those old ex490 rocking ?

I have thought about trying to setup a headless ubuntu or something, would it be of any use to grab some information usefull in the troubleshot ?


Thanks a lot for your inputs.



Edited by BonanzaCreek

Share this post

Link to post
Share on other sites

network chip is Realtek 8168, what extra.lzma did you try?

did you try the ip address in browser?


if you get it going, dont count on the esata port (sil3531), dsm 6.1 extra.lzma does not have a driver for this

Share this post

Link to post
Share on other sites

I have followed the instruction from this tutorial to this thread. and downloaded the one for 3615xs : "extra.lzma for ds3615 v4.7"


I have tried my USB with this lmza on the VM, works fine but on the ex490 it never request an IP so I suppose something goes sideway during the boot process.


I tried the IP in the browser with and without port info 5000/5001/9999 without success.


Also Telnet and SSH direct connection are terminated from the ex490 side.


Thanks for the tip on the esata, currently I do not use it.

Share this post

Link to post
Share on other sites

try a live linux from usb to proof that the chip is working with "normal" linux

in there see what this gives to you (drivers used)

lspci -k | grep 'Kernel driver'

at least its consistent that jun's and my extra.lzma do not work ;-)

try older bootloader for 6.0/5.2 to see if it does works with these (looks like accessing the web interface before actually installing the *.pat seem to be enough)


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now