• Announcements

    • Polanskiman

      DSM 6.2-23739   05/23/2018

      This is a MAJOR update of DSM. DO NOT UPDATE TO DSM 6.2 with Jun's loader 1.02b or earlier. Your box will be bricked.  You have been warned.   https://www.synology.com/en-global/releaseNote/DS3615xs
Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.1.x (Jun's loader)

Recommended Posts

On 12/23/2017 at 6:43 PM, SyncGuy said:

 

Alright... Thank you so much! I will mull over it for a few days and will decide if I should just go ahead with the change from DS3615xs to DS916+ for the DSM 6.1.4.....

*gulps*

 

Or just stick with DS3615xs for the upgrade.

 

Will report back my decision and if it goes smoothly....

 

SyncGuy:

 

Awaiting your decision and the outcome.  I am running the same board as you (ASRock N3150-ITX) and was considering the jump to v6.1.4 and a move to the DS916+ .pat, moving off of the DS3615xs .pat I have been on since the build.

 

Do tell-- what did you decide and what was your final outcome?

 

Thx!!!!

Edited by dial911

Share this post


Link to post
Share on other sites
14 minutes ago, dial911 said:

 

SyncGuy:

 

Awaiting your decision and the outcome.  I am running the same board as you (ASRock N3150-ITX) and was considering the jump to v6.1.4 and a move to the DS916+ .pat, moving off of the DS3615xs .pat I have been on since the build.

 

Do tell-- what did you decide and what was your final outcome?

 

Thx!!!!

 

Good day, mate!

 

Well... I'm sorry for not following up here but I've been surged with a number of tasks since then (New year, new KPI).

 

But here's the thing, it had just occurred to me that I have an active domain with which I can sub for a Gsuite business account for the unlimited storage limit. :D

 

From there, I'll back up my whole 40TB of data and do the update worry-free! As of now, I've yet to do so. My apologies...

Share this post


Link to post
Share on other sites

 

SyncGuy:

 

Will anxiously await the outcome of your attempt.  Thumbs up to being able to backup the 40TB on the GSuite account!!

 

Thx!!

Share this post


Link to post
Share on other sites

I can confirm this guide works for N40L (AMD Turion).

 

As others have said, it will go nowhere unless you have disabled C1E in the CPU configuration within BIOS. 

I had no idea what C1E was so had to do a google search before working out the setting would be within the CPU configuration.

 

Thanks Jun and Polanskiman

Share this post


Link to post
Share on other sites

I successfully upgraded from 6.0.2 directly to latest 6.1.5 PAT.  Baremetal Gigabyte GA-P35-DS3L.  Given the motherboard was old, I was thinking I had to use the MBR Genesys loader, but I was fine with Jun's.  Thanks for the tutorial, @Polanskiman

Share this post


Link to post
Share on other sites
On 1/15/2018 at 5:05 PM, SyncGuy said:

 

Good day, mate!

 

Well... I'm sorry for not following up here but I've been surged with a number of tasks since then (New year, new KPI).

 

But here's the thing, it had just occurred to me that I have an active domain with which I can sub for a Gsuite business account for the unlimited storage limit. :D

 

From there, I'll back up my whole 40TB of data and do the update worry-free! As of now, I've yet to do so. My apologies...

 

Any news on moving to the DS3615xs to DS916+ for the DSM 6.1.4?   It would be my preferred route, but I'd feel much more comfortable with doing it if you've already had success (especially since my trusty DS411slim is having issues right now....)

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Guys, 

Thanks everyone for their hard work on setting this up. I have had Xpenology running bare metal on my HP N54L for over 3 years now and have been on 5.2 for some time. Thought I would take the leap to 6.1 using the 1.02b loader. Added VID and PID using your instructions and used the existing MAC off the 5.2 install. Didn't have any trouble migrating it and had it all up and running. The only thing I changed was reset the IP to static. It nagged me for the update to 6.1.5 and after a bit of reading and successful updates I completed the update. After it rebooted I was unable to log into the NAS. Tried Synology Assistant (both web and installed version) but it couldn't be found. Plex, Sonarr and transmission were all running though and I could log into them! The only way I could get back in was to reinstall 6.1.5-15254 and migrate it again. 

I have read through these pages and the only thing I could find was about the MTU value being manually set to 9000 which mine is.....if I untick it and save it it comes back as ticked again.

 

Any help would be great!

 

Cheers,

Simon.

 

Share this post


Link to post
Share on other sites
3 hours ago, dial911 said:

 

Any news on moving to the DS3615xs to DS916+ for the DSM 6.1.4?   It would be my preferred route, but I'd feel much more comfortable with doing it if you've already had success (especially since my trusty DS411slim is having issues right now....)

 

Thanks!

 

Hi again!! Thank you for being patient with me but holy mother of goat... I am STILL backing up 40TB worth of data. 

 

I've learned that gSuite drive has an upload limit of 750MB/day. I'm currently left with another 6TB worth of data to upload..

 

Truly apologise but I can't do anything about that upload limit and it's irritating when I discovered that considering I've 1Gb/s up and down speed..

 

I will definitely update here again. :(

Share this post


Link to post
Share on other sites
3 hours ago, RXII said:

Hi Guys, 

Thanks everyone for their hard work on setting this up. I have had Xpenology running bare metal on my HP N54L for over 3 years now and have been on 5.2 for some time. Thought I would take the leap to 6.1 using the 1.02b loader. Added VID and PID using your instructions and used the existing MAC off the 5.2 install. Didn't have any trouble migrating it and had it all up and running. The only thing I changed was reset the IP to static. It nagged me for the update to 6.1.5 and after a bit of reading and successful updates I completed the update. After it rebooted I was unable to log into the NAS. Tried Synology Assistant (both web and installed version) but it couldn't be found. Plex, Sonarr and transmission were all running though and I could log into them! The only way I could get back in was to reinstall 6.1.5-15254 and migrate it again. 

I have read through these pages and the only thing I could find was about the MTU value being manually set to 9000 which mine is.....if I untick it and save it it comes back as ticked again.

 

Any help would be great!

 

Cheers,

Simon.

 

 

Try changing the MTU directly from the synoinfo.conf fille located at /etc.default see if that works. It should be located around the end of the file.

Share this post


Link to post
Share on other sites
5 hours ago, dial911 said:

 

Any news on moving to the DS3615xs to DS916+ for the DSM 6.1.4?   It would be my preferred route, but I'd feel much more comfortable with doing it if you've already had success (especially since my trusty DS411slim is having issues right now....)

 

Thanks!

 

1 hour ago, SyncGuy said:

 

Hi again!! Thank you for being patient with me but holy mother of goat... I am STILL backing up 40TB worth of data. 

 

I've learned that gSuite drive has an upload limit of 750MB/day. I'm currently left with another 6TB worth of data to upload..

 

Truly apologise but I can't do anything about that upload limit and it's irritating when I discovered that considering I've 1Gb/s up and down speed..

 

I will definitely update here again. :(

 

Please create a new topic on this as it is beyond the tutorial.

Share this post


Link to post
Share on other sites
8 minutes ago, Polanskiman said:

 

Try changing the MTU directly from the synoinfo.conf fille located at /etc.default see if that works. It should be located around the end of the file.

Do you think this is most likely the reason why? It was ticked and set to 9000 the whole time on my 5.2 install. Thanks for the reply.

Share this post


Link to post
Share on other sites
7 minutes ago, RXII said:

Do you think this is most likely the reason why? It was ticked and set to 9000 the whole time on my 5.2 install. Thanks for the reply.

 

Yes. Setting MTU to 9000 will most of the time generate the issue you are experiencing (no access to GUI and some other services not being available). Honestly I don't think you will see any difference speed wise setting MTU at the minimum (1500). Also for the untick / tick ussue, this seems a permission problem. Most certainly due to upgrading. Personnaly I always do a fresh install when going from one major version to another. This way you don't carry over problems from previous versions. Of course doing a fresh install requires installing all the packages again and reconfiguring DSM from scratch but it is worth the time.

Share this post


Link to post
Share on other sites
26 minutes ago, Polanskiman said:

 

Yes. Setting MTU to 9000 will most of the time generate the issue you are experiencing (no access to GUI and some other services not being available). Honestly I don't think you will see any difference speed wise setting MTU at the minimum (1500). Also for the untick / tick ussue, this seems a permission problem. Most certainly due to upgrading. Personnaly I always do a fresh install when going from one major version to another. This way you don't carry over problems from previous versions. Of course doing a fresh install requires installing all the packages again and reconfiguring DSM from scratch but it is worth the time.

 

Thanks Polanskiman, it has let me change the speed to 1500. I agree, you can't beat a fresh install.....I think I will go that route when I get time. Cheers

Share this post


Link to post
Share on other sites

@Polanskiman   First, thank you for the great write up!  In your post after successfully migrating/installing DSM you mention that we can update to UPDATE-2.  Am I correct in assuming that we get the PAT file from the link of critical updates that you provided and manually installing through DSM?  We can do this for all UPDATES that are successfully reported int he forums?  Thanks in advance!

Share this post


Link to post
Share on other sites
1 hour ago, gr33nzx6r said:

@Polanskiman   First, thank you for the great write up!  In your post after successfully migrating/installing DSM you mention that we can update to UPDATE-2.  Am I correct in assuming that we get the PAT file from the link of critical updates that you provided and manually installing through DSM?  We can do this for all UPDATES that are successfully reported int he forums?  Thanks in advance!

 

Yes or you can actually do this directly from the GUI and let DSM download the update for you. Just disable the auto-update for future updates.

You can update up to the latest critical update which is update 5.

Share this post


Link to post
Share on other sites
11 hours ago, Polanskiman said:

 

Yes or you can actually do this directly from the GUI and let DSM download the update for you. Just disable the auto-update for future updates.

You can update up to the latest critical update which is update 5.

 @Polanskiman  Thank you for the reply and thank you for all your dedication to this thread and helping us out!

Share this post


Link to post
Share on other sites

Not found topic about upgade system from 4.3 to 6.x, so ask a question here:

Current DSM version: DSM 4.3-3810 (model 3612xs) 

 

Is there a reliable way yet to upgrade to 6.1.1-15101-4 immediately? Or i should upgrade system to interim version 5.x?

 

The system prompts to upgrade to version 5.0-4528

Share this post


Link to post
Share on other sites
5 hours ago, sccp said:

Not found topic about upgade system from 4.3 to 6.x, so ask a question here:

Current DSM version: DSM 4.3-3810 (model 3612xs) 

 

Is there a reliable way yet to upgrade to 6.1.1-15101-4 immediately? Or i should upgrade system to interim version 5.x?

 

The system prompts to upgrade to version 5.0-4528

 

No. You need to do a step by step upgrade. DSM 4 > DSM 5 > DSM 6. This also requires you to use the appropriate loader for each upgrade which makes it even more time consuming. 

 

In all honesty though if I was you I would a do a fresh install of DSM 6 straight and then reconfigure DSM. It would take less time and you would start fresh. Doing upgrades usually carries config files from previous versions and I have seen countless questions about issues relating to this very reason. Your data being on a different partition it should remain safe.

 

Note: double posting is also no tolerated in the forum. It gives me and moderators unnecessary work. Please read the rules and guidelines.

Share this post


Link to post
Share on other sites

I must to perform the steps to install the system with the disks connected?
And then how to add them to the system without losing data? The menu item migration  may be chose when an update is installed.

How to be here that would not lose and do not back up the data.
Will be the dsm 6.x support the configuration from version 4.3?

 

Sorry for the duplicate of the message, I missed the window.

Share this post


Link to post
Share on other sites
26 minutes ago, sccp said:

I must to perform the steps to install the system with the disks connected?
And then how to add them to the system without losing data? The menu item migration  may be chose when an update is installed.

How to be here that would not lose and do not back up the data.
Will be the dsm 6.x support the configuration from version 4.3?

 

Sorry for the duplicate of the message, I missed the window.

 

Not sure I understanding everything, but yes your disks must be connected... I don't see how you can install if no disk are connected...

You should ALWAYS backup your data. That is perhaps the first thing you should do.

Data is usually located on a different partition than the system so when you install DSM only the system partition is modified.

No, DSM 6 will not support configuration of DSM 4. As I stated above I recommend a fresh install.

 

Before you do anything though I recommend you try installing DSM 6 on a spare drive to make sure that your hardware will work fine.

Share this post


Link to post
Share on other sites
10 hours ago, sccp said:

Current DSM version: DSM 4.3-3810 (model 3612xs) 

...

The system prompts to upgrade to version 5.0-4528

 

3 hours ago, Polanskiman said:

No, DSM 6 will not support configuration of DSM 4. As I stated above I recommend a fresh install.

 

it would be a little "unsecure" (in terms of success of getting the configuration) but if the offered update to 5.x is done the system (disks) would have 5.x with the wrong loader on usb but still already 5.x installed on disk so inserting 6.x loader and continuing with update 5.x -> 6.0 might be possible?, the config would be updated i guess but the gain would be not that big imho

also i'n not sure if that is going to work as it could be that the 1st start after installing 5.x is not performed without the 5.x loader so vital steps for converting the 4.0 to 5.x config might be missing and hitting that unfinished 5.0 config might result in a fresh install of 6.0 without migrating the config

 

i had 5.0 on my old system last year and opted for a fresh install, so you can imagine what my recommendation for you would be ...

Share this post


Link to post
Share on other sites
13 hours ago, sccp said:

I must to perform the steps to install the system with the disks connected?
And then how to add them to the system without losing data? The menu item migration  may be chose when an update is installed.

How to be here that would not lose and do not back up the data.
Will be the dsm 6.x support the configuration from version 4.3?

 

Sorry for the duplicate of the message, I missed the window.

imho a fresh install would be best, as recommended.

However, if you test your hardware with a spare HDD and 6.1 loader/DSM (having disconnected your raid hdd's), once that system is tested, delete any test volumes, power off, reconnect your raid drives to sata ports 2-n, on boot of DSM6, it should find your raid and the system partitions will be bad, repair them and you will have a full 6 setup. backup data first as recommended. 

Share this post


Link to post
Share on other sites
On 21.03.2018 at 11:58 PM, sccp said:

Not found topic about upgade system from 4.3 to 6.x, so ask a question here:

Current DSM version: DSM 4.3-3810 (model 3612xs) 

 

Is there a reliable way yet to upgrade to 6.1.1-15101-4 immediately? Or i should upgrade system to interim version 5.x?

 

The system prompts to upgrade to version 5.0-4528

 

Clean configuration no data loss

Now i'm going to go 6.1!

Share this post


Link to post
Share on other sites
1 hour ago, DeniZka said:

Clean configuration no data loss

Now i'm going to go 6.1!

Just remember to disable C1E support in the bios.

Share this post


Link to post
Share on other sites
3 hours ago, Dfds said:

Just remember to disable C1E support in the bios.

Success!

Thank yuu for advice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now