Nemo

Xpenology DSM 6.x on Virtualbox can't be found

Recommended Posts

Hello,

I tried to install DSM 6.x with bootloader ver. 1.02b on virtualbox. Everything went fine but only on one compuer. I have those problems:

 

1. I created a virtual xpenology on my laptop (Lenovo, network card Realtec), booted it,  it was found by synology assistant. But when I exported the virtual appliance (I wanted to use it on another computer) and imported it on another computer, the nework didn't work at all. I booted bootloader without problem, but could not find it by synology assistant. It seems to me, that there is a problem with networking. I compared virtualbox setting on my laptop with virtualbox setting on the computer - they were the same. I tried to create a virtual machine from scratch on the computer - networking didn't work (it was not found). I tried the same procedure on another two computers and it was the same result. I don't understand why it works on my laptop and don't work on another 3 computer with virtualbox. I did:

- every virtual box are the latest versions

- all computers are Windows 7 x64

- virtualbox extension pack is installed on all computers

- antivirus was uninstalled

- firewall disabled

- I tried bootloader 1.02a , 1.02b, 1.01 the same result

- intel virtualization technology in BIOS enabled

- MAC addres in virtualbox set according the MAC found by synology assistant on my laptop

- networking on virtualbox is set to "bridge"

- linux type in virtualbox settings is "Linux 2.6 / 3.x / 4.x 64bit" . I tried Ubuntu 64bit, Linux 2.4 64bit nothig worked

- I tried to change network card type in advanced network setting in virtualbox - the same result

- the same result was with DMS for DS916 and DS3617xs

 

2. If I start bootloader, the message "Booting the kernel" appears. I found in this forum that it is correct behaviour. But if I used bootloader for DSM 5.2 it showed all booting process and it was possible to log into command line directly form virtualbox console. Is there any way how to do the same with bootloader for DSM 6.x? I would like to log in via command line from virtualbox console and check network settings and if the eth devices are up or down.

 

Don't somebody know if someone is about releasing next (improved) version of xpenology bootloader or how to modify it that I could run command line after booting the kernel?

 

Share this post


Link to post
Share on other sites

1 - Are you sure you aren't using the same MAC address on both machines? If that's the case then no wonder, you are having a conflict on your network. Your router can only attribute one IP per MAC address.

 

2 - Entirely normal and discussed countless times. There is no video output with jun's loader and there wont be as far as I know.

Share this post


Link to post
Share on other sites

1. Yes, I use the same MAC on both machines. Because there was suggestion that in virtualbox must be set the same MAC as found in synology assistant.

But if I checked DHCP address lease list in my router, there was no MAC asociated with assigned IP address (IP was assigned but in MAC column were zeros)

I tried exported appliance in a different network and location (to avoid double MAC influence) and there was the same behaviour (not found).

 

Is there a way how to change default MAC of the bootloader so that I could use more xpenology in one network?

 

2. Is there a way how to connect to booted bootloader and check network settings when is is not found by synology assistant?

Share this post


Link to post
Share on other sites

Simply match the MAC address in your virtual box and on the grub.cfg file. Virtualbox lets you generate random MAC addresses.

 

Your problem might be a configuration issue of virtualbox on the second machine.

 

To check boot logs you need to create a serial port output to a dumpfile. Needs to be configured in virtualbox.

 

Share this post


Link to post
Share on other sites

I did as you suggested. I created a dump through serial port on virtualbox on each machine. It seems that on other machines is a problem connected to CPU. It seems like a kernel panic. But I have no idea how to solve it. The configuration of both virtualbox is identical. Any idea?

 

Here is a dump from working machine and below from not working machine:

Logs - Working machine  

 

[H[J[1;1H[?25l[m[H[J[1;1H[2;21HGNU GRUB  version 2.02~beta2-36ubuntu3.9

[m[4;2H+----------------------------------------------------------------------------+[5;2H|[5;79H|[6;2H|[6;79H|[7;2H|[7;79H|[8;2H|[8;79H|[9;2H|[9;79H|[10;2H|[10;79H|[11;2H|[11;79H|[12;2H|[12;79H|[13;2H|[13;79H|[14;2H|[14;79H|[15;2H|[15;79H|[16;2H|[16;79H|[17;2H+----------------------------------------------------------------------------+[m[18;2H[19;2H[m     Use the ^ and v keys to select which entry is highlighted.          
      Press enter to boot the selected OS, `e' to edit the commands       
      before booting or `c' for a command-line.                           [5;80H [7m[5;3H*DS916+ 6.1 Baremetal with Jun's Mod v1.02b                                 [m[5;78H[m[m[6;3H DS916+ 6.1 Baremetal with Jun's Mod v1.02b Reinstall                       [m[6;78H[m[m[7;3H DS916xs 6.1 VMWare/ESXI with Jun's Mod v1.02b                              [m[7;78H[m[m[8;3H                                                                            [m[8;78H[m[m[9;3H                                                                            [m[9;78H[m[m[10;3H                                                                            [m[10;78H[m[m[11;3H                                                                            [m[11;78H[m[m[12;3H                                                                            [m[12;78H[m[m[13;3H                                                                            [m[13;78H[m[m[14;3H                                                                            [m[14;78H[m[m[15;3H                                                                            [m[15;78H[m[m[16;3H                                                                            [m[16;78H[m[16;80H [5;78H[22;1H   The highlighted entry will be executed automatically in 1s.                 [5;78H[22;1H   The highlighted entry will be executed automatically in 0s.                 [5;78H[?25h[H[J[1;1H[H[J[1;1H[H[J[1;1H[H[J[1;1Hpatching file etc/passwd
patching file etc/rc
Hunk #1 succeeded at 170 (offset 7 lines).
patching file etc/synoinfo.conf
Hunk #2 succeeded at 273 (offset 3 lines).
Hunk #3 succeeded at 283 (offset 4 lines).
Hunk #4 succeeded at 299 (offset 4 lines).
patching file etc/synoinfo_8G.conf
Hunk #2 succeeded at 283 (offset 4 lines).
patching file linuxrc.syno
Hunk #1 succeeded at 39 (offset 2 lines).
Hunk #2 succeeded at 118 with fuzz 2 (offset 2 lines).
Hunk #3 succeeded at 451 (offset 67 lines).
patching file usr/sbin/init.post
START /linuxrc.syno
Insert basic USB modules...
:: Loading module usb-common ... [  OK  ]
:: Loading module usbcore ... [  OK  ]
:: Loading module ohci-hcd ... [  OK  ]
:: Loading module xhci-hcd ... [  OK  ]
:: Loading module usb-storage ... [  OK  ]
:: Loading module BusLogic ... [  OK  ]
:: Loading module vmw_pvscsi ... [  OK  ]
:: Loading module megaraid_mm ... [  OK  ]
:: Loading module megaraid_mbox ... [  OK  ]
:: Loading module megaraid ... [  OK  ]
:: Loading module megaraid_sas ... [  OK  ]
Insert net driver(Mindspeed only)...
Starting /usr/syno/bin/synocfgen...
/usr/syno/bin/synocfgen returns 0
[    3.205322] md: invalid raid superblock magic on sdb5
Partition Version=8
 /sbin/e2fsck exists, checking /dev/md0...
1.42.6-15047: recovering journal
1.42.6-15047: |==                                              |  3.7%   
1.42.6-15047: |====                                            /  7.4%   
1.42.6-15047: |==============================================  - 96.4%   
1.42.6-15047: |================================================| 100.0%   
                                                                               
       30757 inodes used (19.76%, out of 155648)
          44 non-contiguous files (0.1%)
           8 non-contiguous directories (0.0%)
             # of inodes with ind/dind/tind blocks: 0/0/0
             Extent depth histogram: 27966/13
      231614 blocks used (37.20%, out of 622544)
           0 bad blocks
           1 large file
       24476 regular files
        3203 directories
           2 character device files
           0 block device files
           0 fifos
        1229 links
        3067 symbolic links (2768 fast symbolic links)
           0 sockets
------------
       31977 files
/sbin/e2fsck returns 1
Mounting /dev/md0 /tmpRoot
------------upgrade
Begin upgrade procedure
No upgrade file exists
End upgrade procedure
============upgrade
Wait 2 seconds for synology manufactory device
Sat Sep  9 19:19:22 UTC 2017
/dev/md0 /tmpRoot ext4 rw,relatime,journal_checksum,data=ordered 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
sys /sys sysfs rw,relatime 0 0
none /dev devtmpfs rw,relatime,size=1023860k,nr_inodes=255965,mode=755 0 0
proc /proc proc rw,relatime 0 0
linuxrc.syno executed successfully.
Post init
[   12.575904] BTRFS: has skinny extents

DS916 login: [   57.331332] Power down.

 

Hide  

 

And here is from not working machine:

Logs - Non-working machine  

 

[H[J[1;1H[?25l[m[H[J[1;1H[2;21HGNU GRUB  version 2.02~beta2-36ubuntu3.9
[m[4;2H+----------------------------------------------------------------------------+[5;2H|[5;79H|[6;2H|[6;79H|[7;2H|[7;79H|[8;2H|[8;79H|[9;2H|[9;79H|[10;2H|[10;79H|[11;2H|[11;79H|[12;2H|[12;79H|[13;2H|[13;79H|[14;2H|[14;79H|[15;2H|[15;79H|[16;2H|[16;79H|[17;2H+----------------------------------------------------------------------------+[m[18;2H[19;2H[m     Use the ^ and v keys to select which entry is highlighted.          
      Press enter to boot the selected OS, `e' to edit the commands       
      before booting or `c' for a command-line.                           [5;80H [7m[5;3H*DS916+ 6.1 Baremetal with Jun's Mod v1.02b                                 [m[5;78H[m[m[6;3H DS916+ 6.1 Baremetal with Jun's Mod v1.02b Reinstall                       [m[6;78H[m[m[7;3H DS916xs 6.1 VMWare/ESXI with Jun's Mod v1.02b                              [m[7;78H[m[m[8;3H                                                                            [m[8;78H[m[m[9;3H                                                                            [m[9;78H[m[m[10;3H                                                                            [m[10;78H[m[m[11;3H                                                                            [m[11;78H[m[m[12;3H                                                                            [m[12;78H[m[m[13;3H                                                                            [m[13;78H[m[m[14;3H                                                                            [m[14;78H[m[m[15;3H                                                                            [m[15;78H[m[m[16;3H                                                                            [m[16;78H[m[16;80H [5;78H[22;1H   The highlighted entry will be executed automatically in 1s.                 [5;78H[22;1H   The highlighted entry will be executed automatically in 0s.                 [5;78H[?25h[H[J[1;1H[H[J[1;1H[H[J[1;1H[H[J[1;1H[    0.347485] invalid opcode: 0000 [#1] SMP
[    0.348924] Modules linked in:
[    0.349307] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 3.10.102 #15152
[    0.350584] Hardware name: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
[    0.352423] task: ffff88007c485800 ti: ffff88007c4a4000 task.ti: ffff88007c4a4000
[    0.353285] RIP: 0010:[<ffffffff814918be>]  [<ffffffff814918be>] sha_transform+0x2e/0x12e0
[    0.354256] RSP: 0000:ffff88007c4a7d60  EFLAGS: 00010092
[    0.354882] RAX: ffffffff819baa80 RBX: 0000000010325476 RCX: 00000000e8a4602c
[    0.355804] RDX: ffff88007c4a7db0 RSI: ffffffff819baa80 RDI: ffff88007c4a7d98
[    0.356731] RBP: 00000000c3d2e1f0 R08: 00000000efcdab89 R09: 0000000010325476
[    0.358906] R10: 0000000067452301 R11: 0000000098badcfe R12: 00000000f33d5697
[    0.359729] R13: ffff88007c4a7e66 R14: 0000000000000282 R15: 0000000000000004
[    0.360537] FS:  0000000000000000(0000) GS:ffff88007fd00000(0000) knlGS:0000000000000000
[    0.361951] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[    0.362619] CR2: 0000000000000000 CR3: 000000000180d000 CR4: 00000000000406e0
[    0.363350] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[    0.364111] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[    0.365416] Stack:
[    0.365644]  0000000000000010 ffffffff81842e80 ffffffff81842ea4 ffff88007c4a7e66
[    0.366449]  0000000000000282 0000000000000004 ffffffff812fc942 efcdab8967452301
[    0.367284]  1032547698badcfe 00000000c3d2e1f0 ffffffff81842fd0 0000000000000246
[    0.368153] Call Trace:
[    0.368415]  [<ffffffff812fc942>] ? extract_buf+0x62/0x140
[    0.368981]  [<ffffffff81057a55>] ? __wake_up+0x35/0x50
[    0.369526]  [<ffffffff812fc754>] ? account+0x104/0x290
[    0.370086]  [<ffffffff812fce8c>] ? extract_entropy+0x5c/0x170
[    0.370693]  [<ffffffff811612c7>] ? proc_register+0x67/0x140
[    0.371283]  [<ffffffff813eaf8b>] ? neigh_hash_alloc+0x7b/0xb0
[    0.372329]  [<ffffffff813eb046>] ? neigh_table_init+0x86/0x2b0
[    0.372942]  [<ffffffff818a13c5>] ? arp_init+0xc/0x47
[    0.373945]  [<ffffffff818a16d6>] ? inet_init+0x18e/0x27a
[    0.374510]  [<ffffffff818a1548>] ? ipv4_offload_init+0x63/0x63
[    0.375134]  [<ffffffff810003aa>] ? do_one_initcall+0xea/0x140
[    0.375736]  [<ffffffff81876dc8>] ? kernel_init_freeable+0x13a/0x1bb
[    0.376858]  [<ffffffff81492f70>] ? rest_init+0x70/0x70
[    0.377403]  [<ffffffff81492f75>] ? kernel_init+0x5/0x180
[    0.378512]  [<ffffffff814a4c08>] ? ret_from_fork+0x58/0x90
[    0.379096]  [<ffffffff81492f70>] ? rest_init+0x70/0x70
[    0.379641] Code: 8b 5f 08 44 8b 17 41 56 44 8b 47 04 44 89 d1 41 55 c1 c1 05 41 54 45 8d 23 55 8b 6f 10 41 81 c4 99 79 82 5a 53 8b 5f 0c 41 89 d9 <0f> 38 f0 06 45 31 d9 89 02 45 21 c1 41 c1 c8 02 41 31 d9 41 01
[    0.382676] RIP  [<ffffffff814918be>] sha_transform+0x2e/0x12e0
[    0.383327]  RSP <ffff88007c4a7d60>

 

Hide  

Share this post


Link to post
Share on other sites

Please use proper code tags when posting logs in the future.

 

Have a read at this https://xpenology.com/forum/topic/6253-dsm-6xx-loader/?do=findComment&comment=67297

 

I think your issue is that the cpu in the second machine is simply not compatible with DS916+ which is the model you are using for the loader.

 

I recommend you use 3615xs or 3617xs loaders for that machine instead.

Share this post


Link to post
Share on other sites

Sorry, I'm new here - what proper code tags do you mean? I just copy and paste logs content.

 

I have read the topic you mentioned. Here is a summary of my research:

 

Working machine (Intel Core i7 4702MQ @ 2.20GHz Haswell 22nm Technology):

DS916+   works - but cpu must be configured like 2 core. With one core it was unstable. It is strange that it works on Haswell family

DS3615xs  works

DS3617xs works

 

Not working machine I (Intel Core i5 2500 @ 3.30GHz Sandy Bridge 32nm Technology):

DS916+   doesn't work

DS3615xs  works

DS3617xs works

 

Not working machine II (Intel Core 2 Duo E6420 @ 2.13GHz Conroe 65nm Technology)

DS916+   doesn't work

DS3615xs  works

DS3617xs works

 

 

Share this post


Link to post
Share on other sites
10 hours ago, Nemo said:

Sorry, I'm new here - what proper code tags do you mean? I just copy and paste logs content.

 

Screen Shot 2017-09-12 at 2.26.40 PM.jpg

Share this post


Link to post
Share on other sites

I think, we can close this thread as solved. Thank you for help. How can I mark it as "solved"?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.