Sortie DSM 4.3


Recommended Posts

Je vous annoncent que trantor à mis à dispo une version de DSM 4.3 non officiel !

 

Si vous voulez faire des tests et nous faire votre retour ! :razz:

 

This is not an official synology product, it's only design for testing purpose not for production.

 

What's new ?

- AMD CPU support

- Add / update Network / SATA / SCSI / SAS / USB drivers

- USB OHCI support

- SSH access enabled by default

- DM-Mirror support for LVM2 physical relocation (include dm-log, dm-region-hash and dm-mirror modules. thanks totalnas)

 

Thank to all people who help the community to make possible to build 4.3 version (neXus, VeNoM, Vortex, guys from nas1.cn sorry if I forgot some of you)

Big thank for k3dt's work (synobios and his fix).

 

 

Version 1.0 is now available : http://xpenology.trantor.be/ (please click on ad to help me with this project)

 

 

Convert .img file to .vdi (virtualbox)

Edit serial number and MAC address for your XPEnology

 

 

:arrow: For unsupported hardware please post your driver request here

 

 

See changelog for full list of fix and supported hardware:

 

TODO LIST:

- Add missing drivers (previously included in other builds like pata, some network/sata/scsi)

- Add support for ASMedia ASM1062 devices

- Add USB to serial FTDI and Prolific chips

- Add virtualization options to standard build

- Make special build for ESXi (yes I know you want this ^^)

Link to post
Share on other sites

Oui, c'est vraiment une très bonne nouvelle !

Pour les virtualiseurs (virtualistes ?) comme moi, l'annonce d'un build ESX dans la foulée a de quoi embellir cette grise journée :geek:

 

Je vous tiendrai au courant de ma migration.

Link to post
Share on other sites

Bonjour,

 

Je me suis lancé hier dans le passage à la 4.3 avec mon HP N54L.

 

J'ai tenté de faire seulement la mise à jour du DSM avec le fichier PAT téléchargé, mais j'ai eu une erreur.

 

Il a donc falut :

1/ mettre à jour (ou plutot recréer) la clé USB de boot

2/ repasser par l'Assistant Synology pour charger le DSM 4.3 (je me suis connecté via l'interface web du NAS pour faire ca).

 

Pour moi pas de pertes de données, tout semble marcher, a part que j'ai réinstallé tout les paquets, reconfiguré les sauvegardes, le firewall, etc...

Je suis bien passé par la "restauration de la configuration" (menu DSM > Sauvegarder et restaurer > Onglet "Sauvegarde de Configuration" )qui m'a permis de restaurer les comptes Utilisateurs, groupes, entre autres choses.

 

Voila, à votre dispo pour en parler si besoin. :wink:

Edited by Guest
Link to post
Share on other sites

Hello. Merci pour ton retour.

Oui c'est bien le processus de migration à suivre, à ce que j'ai lu ici ou là.

 

Le plus embetant est de devoir réinstaller les paquets, je me demande aussi si les paramètres des applis sont perdus.

J'ai entre autres photo station, plex, phpmyadmin d'installés et ça me chagrine un peu de devoir les re-paramétrer :sad:

 

J'attends un peu que les choses se stabilisent avec la 4.3 et je m'y lancerai à mon tour.

Link to post
Share on other sites

Effectivement, je me suis un peu fait avoir avec la "Sauvegarde de Configuration". :???:

 

Pour la sauvegarde des "Applications", il faut faire une sauvegarde classique et non une "Sauvegarde de Configuration".

Cela permet apparement de sauver une base MySQL et Photostation (Quel base SQL?, Quels éléments de Photostation? à vérifier car je n'ai pas testé).

Pour Plex je n'ai pas encore regardé, mais j'ai effectivement peur d'avoir tout perdu. Je vous dirais une fois que j'aurais réinstallé le paquet.

Link to post
Share on other sites
Effectivement, je me suis un peu fait avoir avec la "Sauvegarde de Configuration". :???:

 

Pour la sauvegarde des "Applications", il faut faire une sauvegarde classique et non une "Sauvegarde de Configuration".

Cela permet apparement de sauver une base MySQL et Photostation (Quel base SQL?, Quels éléments de Photostation? à vérifier car je n'ai pas testé).

Pour Plex je n'ai pas encore regardé, mais j'ai effectivement peur d'avoir tout perdu. Je vous dirais une fois que j'aurais réinstallé le paquet.

 

 

Salut,

 

en ce qui me concerne, j'ai également fait l'upgrade, et je n'ai rien perdu...juste réinstallé le paquet Plex, et j'ai retrouvé ma configuration à l'identique...

 

Encore un grand merci à Trantor...

Link to post
Share on other sites

Je crois que je vais encore patienter car ayant déjà testé DSM 4.3 je ne vois pas trop la différence et mon N54L marche comme il doit actuellement en 4.2.

 

Ceux qui ont migré constatent une différence?

 

QUand je suis passé de 4.2 à 3 sur mon DS212J j'avais dû recréer les disques pour passer au EXT4, j'ai du mal à croire que ça ne soit pas nécessaire avec Xpenology.

Link to post
Share on other sites
Je crois que je vais encore patienter car ayant déjà testé DSM 4.3 je ne vois pas trop la différence et mon N54L marche comme il doit actuellement en 4.2.

 

Ceux qui ont migré constatent une différence?

 

QUand je suis passé de 4.2 à 3 sur mon DS212J j'avais dû recréer les disques pour passer au EXT4, j'ai du mal à croire que ça ne soit pas nécessaire avec Xpenology.

 

Peut être mes disques étaient-ils déjà en EXT4...je n'en sais rien, mais toujours est-il que je n'ai eu strictement aucune perte de données, ça je te le confirme... :wink:

 

Là, ça fait presque 24 heures que j'ai fait l'upgrade, et tout fonctionne merveilleusement bien...

Link to post
Share on other sites

Bonsoir,

J'aurai une petite question au sujet du type de formatage proposé justement par la 4.2 et 4.3, c'est visiblement en ext4, hors j'ai placé 4 disques dans mon N54L qui proviennent de mon vieux CS407 qui fonctionnait sous DMS 3.2 maxi, il sont de mémoire formaté en ext2 ou peut être 3 ?

Est ce que je peux les laisser comme ils sont ou serait-il préférable de les passer en ext4 ? meilleurs performance ?

Merci :wink:

Link to post
Share on other sites

Hello,

 

Update faite via MAIS.... J'ai perdu toute ma conf >< Je n'ai pas pensé à faire une sauvegarde avant, je me suis dit mise à jour,.... pas nécessaire..... Mais bon, finalement ça m'arrange car j'ai découvert Syno avec XPEnology et à force de trifouiller la bête, j'ai plein de petit bug, repartir à zéro est un mal pour un bien finalemnt

 

Donc attention tout de même....

 

Par contre, ça m'a effacé mes paramètres mais pas entièrement, je trouve encore des résidus de mon ancienne conf, comment faire un "reset total" sur XPEnology (sans perdre mes données bien sur ><) afin de tout recommencer comme si le système était neuf ?

Link to post
Share on other sites

Bonjour,

 

J'ai un message d'erreur après l'installation :

 

GRUB Loading stage1.5.

 

GRUB loading, please wait ...

Error 22

_

 

Comment puis-je régler le problème ?

J'ai fait l'installation sur virtual box en suivant le tuto.

Link to post
Share on other sites

bien de la chance :wink:

 

Moi j'ai perdu toute ma conf (enfin presque...) mais bon, je voulais repartir à zéro donc un mal pour un bien ^^

 

Ce qui m'embête le plus maintenant c'est que j'ai des résidus de mon ancienne conf et impossible de remonter une version usine vierge, je n'y arrive pas...

Link to post
Share on other sites
bien de la chance :wink:

 

Moi j'ai perdu toute ma conf (enfin presque...) mais bon, je voulais repartir à zéro donc un mal pour un bien ^^

 

Ce qui m'embête le plus maintenant c'est que j'ai des résidus de mon ancienne conf et impossible de remonter une version usine vierge, je n'y arrive pas...

 

 

Tu as essayé l'option "restaurer par défaut" ?

Link to post
Share on other sites

Mise à jour de l'amorce avec des pilotes supplémentaires :

viewtopic.php?f=2&t=1361&p=8699#p8699

(+correction du message en boucle concernant le buzzer).

 

à noter que le bug du volume planté à chaque démarrage a été reconnu mais pas encore résolu. Le contournement consiste pour l'instant à réparer le volume (quoique ça a l'air de bien fonctionner si l'on ignore cet avertissement).

 

Je me demande si une simple conversion du fichier de img à vmdk permet de mettre à jour ma VM pour tester :-|

Link to post
Share on other sites
non, car pour le moment, personne m'a certifié que ça n'allait pas effacer mes données...

 

C'est juste le mot "Formater" qui me fait flipper un peu ^^ :grin:

 

 

Je te confirme, ça efface les données....sauvegarde obligatoire sur des HDD réseau ou externes.... :roll:

Link to post
Share on other sites

Bonsoir tout le monde,

 

Je suis nouveau ici, donc soyez indulgents.

 

J aimerais savoir comment corriger le bugg buzzer avec le correctif mentionné plus haut.

 

Ca dit copier le fichier synobios.ko dans modules, ca j ai compri mais comment faire la copie, ca je ne sais pas faire avec le type de fichier.

 

Est ce que quelqu un peut m aider svp. Merci d avance.

 

Farid

Link to post
Share on other sites

Tu met le fichier synobios.ko dans un partage de l'xpenology depuis un pc sous windows (par exemple share).

Tu te connecte en SSH avec putty, puis tu tape :

mv /volume1/share/synobios.ko /lib/modules (ou share est le nom de ton partage).

 

Sinon le plus simple tu attends la v1.1 qui inclura directement le fix :wink:

Link to post
Share on other sites

Salut à tous,

 

J'ai testé dsm 4.3 sur une asus z87-deluxe, ca tourne bien, les 2 ports réseaux sont utilisables!

 

Par contre, le volume créer en raid 1 matériel n'est pas reconnu par xpe.

 

La carte réseau wifi intégrée n'est pas installée (je m'y attendais)

 

Voilà pour un ptit retour...

Link to post
Share on other sites