Balrog

Enabling serial port in ESXi for a VM

Recommended Posts

A little help for everyone who struggles a little bit with enabling the serial console in ESXi. This manual works 1:1:

https://www.juniper.net/documentation/en_US/vmx15.1f4/topics/task/configuration/vmx-vm-connecting-vmware.html

 

in short:

 

# at ESXi:
open Firewall for serial Console

 

# at VM:
add Serial Port 1
- Use Network
- Connect at Power
- Direction: Server
- Port URI: telnet://:8601

 

In PuTTY the connection will be made as:

Type: Telnet

Hostname: IP-of-your-ESXi-Host

Port: The-port-you-entered-in-the-config-of-the-VM (e.g. 8601)

 

With this you have at every time contact to the Xpenology-VM-Console even a driver wont be load with a upgrade (like in Loader 1.02a). :-)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I know this was required before, but what's the benefit of adding the serial port?

Just debugging information and being able to do low-level stuff if SSH is down/disabled?

Share this post


Link to post
Share on other sites

As I wrote: You are able with this to access a direct console at every time. Like an insurance if things go bad. Even without loaded nic-drivers in the VM or disabled SSH.
In the past this was the access via iLO for me as DSM was installed bare-metal on a HP Microserver Gen8.

Share this post


Link to post
Share on other sites
As I wrote: You are able with this to access a direct console at every time. Like an insurance if things go bad. Even without loaded nic-drivers in the VM or disabled SSH.
In the past this was the access via iLO for me as DSM was installed bare-metal on a HP Microserver Gen8.
Is this still possible on esxi 6.5 free edition for you?
For me a license issue is shown in the vmware.log of the virtual machine :(

Is there maybe another way?

Gesendet von meinem ONE A2003 mit Tapatalk

Share this post


Link to post
Share on other sites

It is possible that the serial port function is only available with a licensed esxi-host but I am not sure about this.

Sent from my SM-T810 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now