patapain

Centre de paquets : Valider les conditions d'utilisations

Recommended Posts

Bonjour la communauté,

Aujourd'hui en allant dans le centre de paquets il m'affiche un message m'indiquant d' "accepter les conditions d'utilisations". Je les ai parcouru en diagonal (je vous conseil d'en faire autant) et j'ai bien peur qu'il nous bloquent l'accès aux paquets si on accepte.

Vous me direz : qu'a cela ne tienne il suffit de ne pas valider, sauf qu'on ne peut plus accéder  au centre de paquets si on ne valide pas. Comme j'ai un paquet que je veux relancer car il est visiblement bloqué (est-ce Synology qui l'aurait bloqué, la est la question ?) je suis dans l'impasse. Dilemme : Je valide au risque de voir tous les paquets bloqué ??? ou pas ...

Est-ce que quelqu'un a rencontré cette situation ? et est-ce qu'il a validé ?

Merci par avance.

Pat

 

Share this post


Link to post
Share on other sites

Alors perso chapeau-bas pour avoir lu les CGU!

Mais chez moi ce message n'apparait pas (ou plus). N'aurais-tu pas créer un nouveau compte récemment avec lequel tu te serais connecté, ou alors réinitialisé des paramètres ?

Dans tous les cas, je doute qu'il y ait un lien avec Synology puisque par définition on peut ajouter des sources extérieures à Synology.

Edited by nicoueron

Share this post


Link to post
Share on other sites

Merci pour ta reponse "nicoueron". pour les CGUI je ne les ai parcuru qu'en diagonale.

Par contre j'ai un compte chez Synology et j'avais essayé de créer un ID quickconnect avec mon SN mais je n'ai pas réussi, ca ne marche plus. J'ai, chez eux, un N° de serie qui ne correspond a aucun Syno (j'en ai 2, un vrai : DJ107+ et un XPEnology). Penses-tu que je doives changer mon SN et n'aurais-je pas de pb.

Sinon j'ai dans le "panneau de config / sécurité / certificat" un certificat de Synology. Quelqu'un l'a-t-til ?

Tu dis "n'apparait pas (plus)" as-tu eu ce message et as-tu validé ?

 

Merci pour tes réponses.

Pat

certificat syno.jpg

Share this post


Link to post
Share on other sites

Salut

 

Quote

Penses-tu que je doives changer mon SN et n'aurais-je pas de pb

Perso, il me semble que depuis la version 5 de DSM, le quickconnect ne marche pas vraiment. Je n'ai jamais réussi à le faire marcher sur mon XPEnology. De toute façon je n'ai jamais compris vraiment l'intérêt, il y a d'autres moyens pour se connecter à un syno à distance. Moi par exemple qui dispose d'une IP fixe, j'ai pu très facilement l'associer à mon nom de domaine. A défaut d'avoir une IP fixe, il suffit de créer un dynDNS. J'arrive même à utiliser toutes les applications mobiles tels que DS File ou DS Cam c'est pour dire.

 

Quote

Sinon j'ai dans le "panneau de config / sécurité / certificat" un certificat de Synology. Quelqu'un l'a-t-til ?

Moi je ne l'ai plus, je l'ai remplacé par un certificat émis par Let's Encrypt. Il permet d'exposer de façon sécurisé via HTTPS les applications Synology. C'est donc le certificat qui est présenté au navigateur lorsque tu te connectes à ton syno si tu as activé le protocole HTTPS.

 

Quote

Tu dis "n'apparait pas (plus)" as-tu eu ce message et as-tu validé ?

On a ce message la première fois qu'on arrive sur le centre de paquets. Une fois validé il ne doit plus être présenté.

Share this post


Link to post
Share on other sites

Ce message est affiché à chaque fois que Synology décide de faire une mise à jour du centre de paquets. Il suffit de l'accepter comme indiqué par @nicoueron

Share this post


Link to post
Share on other sites

Merci a vous deux,

J'étais un peu inquiet car personne n'en avait parlé et que dans le CGU il parle de :

 

8.1. Dans le but de fournir et de faire fonctionner le Centre de Paquets de Synology, nous pouvons accéder ou dévoiler vos coordonnées de contact afin de : (a) respecter la loi ou répondre à une requête légale ou une procédure légale ; (b) protéger les droits de propriété ou la propriété de Synology ou de nos clients et développeurs de paquets, notamment pour faire appliquer nos contrats ou règlements régissant votre usage du Centre de Paquets de Synology ; (c) estimer de bonne foi que cette consultation ou divulgation s'impose afin de protéger la sécurité personnelle des employés ou clients de Synology, des développeurs de paquets, ou (d) pour vous contacter concernant des problèmes relatifs aux paquets que vous avez téléchargés.

8.2. Veuillez noter que Synology se réserve le droit de bloquer ou d'empêcher autrement la transmission de tout type de communication vers ou depuis le Centre de Paquets de Synology dans un effort pour protéger le Centre de Paquets de Synology, protéger nos clients, les développeurs de paquets et le propriétaire de droit concerné, ou pour vous empêcher de violer les termes de ce contrat ; notez également que la technologie ou d'autres moyens que nous employons peuvent empêcher, interrompre ou arrêter votre utilisation du Centre de Paquets de Synology.

 

ce qui n'est pas très engageant vous en conviendrez.

Pour le Quickconnect, sur les conseils de @Polanskiman je ne l'utilise plus. Comme toi @nicoueron j'ai une adresse IP fixe chez Free et un nom de domaine, c'est donc effectivement simple d'accéder a son syno a distance.

 

Par contre @nicoueron  j'ai voulu mettre un certificat Let's Encrypt sur Certbot mais il demande le "software" ainsi que le "system" qu'on utilise pour créer le certificat. Peux-tu me dire ce que tu as mis pour ces deux paramètres ?

Merci par avance

Pat

Share this post


Link to post
Share on other sites

Tu te compliques la vie! 

Tu peux le faire directement depuis DSM sans passer par Certbot.

Panneau de configuration>Sécurité>Certificat :

Ajouter> Ajouter un nouveau certificat > Procurez-vous un certificat auprès de let's encrypt

Et là tu renseignes ton nom de domaine, l'adresse mail et si besoin des noms alternatifs si tu veux utiliser un seul certificat pour plusieurs sous-domaine.

 

Chez moi j'ai créé une autre VM sur Ubuntu 16.04 qui dispose des outils let's encrypt ainsi qu'un script python qui se connecte à OVH (mon fournisseur de nom de domaine) et qui me génère un certificat pour une vingtaine de sous-domaine selon un challenge particulier permettant ainsi d'assurer que c'est bien moi le propriétaire du domaine. Sur la VM j'ai également une tache cron qui permet d'automatiser le renouvellement du certificat, car celui-ci expire tous les 3 mois. Mais je me suis peut-être un petit trop compliqué la vie, là où Synology permet de faire 90% du boulot avec une interface pratique!

Edited by nicoueron

Share this post


Link to post
Share on other sites
57 minutes ago, nicoueron said:

Tu te compliques la vie! 

Tu peux le faire directement depuis DSM sans passer par Certbot.

Panneau de configuration>Sécurité>Certificat :

Ajouter> Ajouter un nouveau certificat > Procurez-vous un certificat auprès de let's encrypt

Et là tu renseignes ton nom de domaine, l'adresse mail et si besoin des noms alternatifs si tu veux utiliser un seul certificat pour plusieurs sous-domaine.

 

Chez moi j'ai créé une autre VM sur Ubuntu 16.04 qui dispose des outils let's encrypt ainsi qu'un script python qui se connecte à OVH (mon fournisseur de nom de domaine) et qui me génère un certificat pour une vingtaine de sous-domaine selon un challenge particulier permettant ainsi d'assurer que c'est bien moi le propriétaire du domaine. Sur la VM j'ai également une tache cron qui permet d'automatiser le renouvellement du certificat, car celui-ci expire tous les 3 mois. Mais je me suis peut-être un petit trop compliqué la vie, là où Synology permet de faire 90% du boulot avec une interface pratique!

 

Je tiens juste à rajouter que le renouvellement automatique du certificat Let's Encrypt via une tâche cron c'est bien tant que le port 80 est ouvert dans DSM et que sur le routeur le port est redirigé vers la machine. Je dis cela car la plupart du temps les gens n'ouvrent/redirigent pas le port 80 en permanence et donc une tâche cron ne marcherait pas dans ce cas. Je suis hors sujet donc je vais m'arrêter là.

Share this post


Link to post
Share on other sites

hello

Info :

idem pour moi, misse a jour de deux paquets. Conditions validées sans problème

DSM 6.1.3-15152 Update 3 . loader Jun 1.02b

 

Edited by sliders

Share this post


Link to post
Share on other sites

Rebonjour

J'ai essayé de créer une certificat comme tu me l'as indiqué "nicoueron" mais il m'indique que le nom de domaine n'est pas valide, alors qu'il existe bien (je suis chez DDN), il est simple puisque c'est mon nom.net. Sais-tu d'ou cela peut venir ?

J'aimerai bien le créer sur Certbot, connais-tu les parametres pour le créer ( le "software" ainsi que le "system")

Je ne savais pas que ces certificat expirait au bout de 3 mois c'est un peu court, ne peut-on mettre une durée plus importante ?

Maintenant je t'avoue que créer un script Python je ne sais pas faire. Je suis intéressé, peux-tu me dire comment faire !

 

Merci par avance

Pat

certif.jpg

Share this post


Link to post
Share on other sites

Je vais regarder mon Routeur et je te tiens au courant.

sinon, on  ne peut-on mettre une durée plus importante ?

Share this post


Link to post
Share on other sites

Le concept de Let's encrypt est justement que ce soit gratuit, la contre partie est que chaque certificat est limité à 3mois.

Share this post


Link to post
Share on other sites

Pour revenir à ton pb, regarde du coté des logs pour savoir quel est le message d'erreur lors du challenge let's encrypt avec DSM.

Share this post


Link to post
Share on other sites
On 8/28/2017 at 7:50 PM, patapain said:

Je vais regarder mon Routeur et je te tiens au courant.

sinon, on  ne peut-on mettre une durée plus importante ?

 

23 hours ago, nicoueron said:

Le concept de Let's encrypt est justement que ce soit gratuit, la contre partie est que chaque certificat est limité à 3mois.

 

A prior cela n'est même pas un problème car DSM est configuré pour automatiquement renouveler le certificat 30 jours avant son expiration sous condition que le port 80 soit bien redirigé et ouvert bien entendu.

 

A lire: https://forum.synology.com/enu/viewtopic.php?t=119699

Share this post


Link to post
Share on other sites
23 hours ago, nicoueron said:

Pour revenir à ton pb, regarde du coté des logs pour savoir quel est le message d'erreur lors du challenge let's encrypt avec DSM.

 

Les logs se trouvant ici:

/var/log/messages

 

Share this post


Link to post
Share on other sites

Rebonjour,

J'ai du laisser mon syno quelques temps car j'étais pas mal surbooké, desolé de ne revenir que maintenant.

Polanskiman comment je fais pour aller dans

/var/log/messages

c'est dans la console ?

Mais je n'y connais pas grand chose, alors si tu pouvais m'expliquer ou m'indiquer ou je peux trouver des explications, ça serait sympa

Merci par avance

Share this post


Link to post
Share on other sites
10 hours ago, patapain said:

Rebonjour,

J'ai du laisser mon syno quelques temps car j'étais pas mal surbooké, desolé de ne revenir que maintenant.

Polanskiman comment je fais pour aller dans


/var/log/messages

c'est dans la console ?

Mais je n'y connais pas grand chose, alors si tu pouvais m'expliquer ou m'indiquer ou je peux trouver des explications, ça serait sympa

Merci par avance

 

Via SSH. Un fois dans la console SSH tapez ceci:

vi /var/log/messages

Vous verrez les logs. Naviguez avec les flèches du haut/bas ou avec la molette/roulette de votre souris. 

 

Pour sortir de vi il faut taper: 

:q!

 

Share this post


Link to post
Share on other sites

bonjour,

Avec Putty je me suis connecté avec le compte "admin" et j'ai lancé "vi" et ouvert le fichier messages dans "/var/log" il m'indique "permission denied" et ne m'affiche rien. par contre le fichier fait plus de 1Mo.

Dois-je me connecter en "root". mais je ne connais pas le mot de passe et j'ai lu que ce compte était désactivé sous DSM 6.

Merci a tous pour le temps que vous y consacrez.Putty.jpg.1e8cd87a836d6a006fe0e29b37a216f1.jpg

Edited by patapain

Share this post


Link to post
Share on other sites

pour le root tu tapes
sudo -i
comme mot de passe c'est le même que celui que tu utilises pour admin


Envoyé de mon SM-G901F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

rebonjour a tous,

Bon ben ca a été laborieux (pas évident quand on n'y connait rien) mais j'ai enfin réussi et c'est grâce a vous tous, une super communauté qui s'entraide (enfin moi j'ai pas pu aidé beaucoup, mais qui sait un jour...)

Alors le fichier "messages" m'indiquait que la connexion était impossible car le port 80 n'était pas ouvert. et que le nom de domaine était incomplet : il manquait le "www" devant (enfin lorsque je l'ai créé je n'avais pas mis le "www" juste "mon nom.net", il l'avait rajouté tout seul).

voici donc le résultat :

59cfed14cdc66_Letsencrypt.jpg.226597f152762fb7bc0de918ca9a5e8f.jpg

Je me pose maintenant une question :

- Avoir ouvert le port 80 sur mon routeur n'aurait-il pas ouvert une porte aux pirates ? et quelle serait la solution sinon ?

J'en vois une : dans mon routeur ouvrir le port 80 mais uniquement pour une adresse, celle d'encrypt, le pb je ne la connais pas et il est possible qu'ils en utilisent plusieurs.

Cordialement

 

 

Share this post


Link to post
Share on other sites

[mention=4292]patapain[/mention] Si vous n'utilisez pas le port 80 alors il vaut mieux annulez la redirection du port 80 sur votre routeur lorsque vous avez fini de mettre en place le certificat. Le certificat doit être renouvelé tous les 3 mois donc il faudra rediriger le port 80 tous les 3 mois. Normalement Let's Encrypt envoi des messages de relance quelques semaines avant le renouvellement du certificat et DSM tente de renouveler le certificat plusieurs semaines à l'avance aussi. Regardez la configuration de votre routeur, il es possible que celui ci est une option de redirection de port sur demande ce qui permet de ne pas rediriger le port en permanence mais seulement lorsqu'une machine (en l'occurence votre NAS) en fait la demande.

 

A lire: https://forum.synology.com/enu/viewtopic.php?t=119699

 

Autre chose, mais pas des moindres, nous dévions complètement du sujet initial donc tout ceci est du hors sujet. Si vous avez d'autres questions au sujet de Let's encrypt merci d'ouvrir un nouveau fil de discussion. La réponse à la question du premier post a été donnée. Je cloture donc ce fil de discussion, chose que j'aurais dû faire il y a fort longtemps.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.