mb51running

TerraMaster F2-220

Recommended Posts

Posted (edited)
On 12/29/2019 at 7:18 PM, richv31 said:

OK, this is what I did to get the terramaster nas running on 6.2.2. This is for a fresh install only. It may work for an upgrade but I have not tried it. Create a usb drive with 1.04b (setup your VID/PID, serial, mac, etc). Then download the extra.lzma that real3x created (that excludes the updated graphics driver modules that Jun included in 1.04b) and replace the one in the second partition on the usb drive with it. DO NOT delete the extra2.lzma from the USB drive as others have suggested. If you do, the system will not boot for install. Plug the usb, boot the system with a clean HDD (e.g. no synology partitions exist) and install the 6.2.2 update 4 pat file. I have this running on Terramaster F2-220, F4-220 and a qnap-453be. I recall reading somewhere in the tutorials that the J1800/J1900 cpus do not work with the updated i915 drivers )in 1.04b) for 918 installs.

Finally, if you attempt to use the vanilla 1.04b on these machines, they will boot up fine for install, but once the install is completed they will disappear from the network. seemingly the issue is with the updated graphics driver that causes issues in loading the realtek network driver.

I am waiting to try IG-88s new drivers but for the moment the above is working for me.

 

I have a TerraMaster F5-220 and a true synology I was able to load DSM 6.1.XXXXXX I have read you post several times. I am trying to load DSM 6.2.2 . only because there is a package I want to use and it requires 6.2.X or higher. You reference  extra.lzma that real3x created (that excludes the updated graphics driver modules that Jun included in 1.04b) I can't For the life of me find the files you mentioned. I'm not lazy but the forum is a little like what happens in never speak of Usenet LOL. There must be some limitation that prevents hyperlinks to be used in the forums. As I mentioned I truly tried to find the files and follow your information. Would you be kind enough to help me out?

 

My error every time I tried to down load any of the files the process failed I was only getting the HTML file for the page. when I used a download manager I was able to download the Extra2.Lzma files. please forgive my brain fart.

Edited by Nunyafb Izness

Share this post


Link to post
Share on other sites
27 minutes ago, Nunyafb Izness said:

 

I have a TerraMaster F5-220 and a true synology I was able to load DSM 6.6.XXXXXX I have read you post several times. I am trying to load DSM 6.2.2 . only because there is a package I want to use and it requires 6.2.X or higher. You reference  extra.lzma that real3x created (that excludes the updated graphics driver modules that Jun included in 1.04b) I can't For the life of me find the files you mentioned. I'm not lazy but the forum is a little like what happens in never speak of Usenet LOL. There must be some limitation that prevents hyperlinks to be used in the forums. As I mentioned I truly tried to find the files and follow your information. Would you be kind enough to help me out?

Try this one https://mega.nz/file/lgBSxIYC#lRzwpgfmd6H6NM4H1Y9TE8vMOyUz8RdEHSLkvlFwFuA

On my TS451 works perfectly fine. Even with hw transcoding.

I found it on a Chinese forum.

Share this post


Link to post
Share on other sites

the real3x files have now been replaced with IG-88s work. For 6.2.2 use 0.8_syno files (extra/extra2) from this thread:

For 6.2.3 use 0.10 or 0.11 from this:

 

Share this post


Link to post
Share on other sites
On 8/23/2017 at 1:10 PM, elviso33 said:

Anyone know if Xpenology will work in the 4 bay one as well?

 

tia

elviso

I a word yes it works with F4-220 and F5-220 other models I do not know.

Share this post


Link to post
Share on other sites

Has anyone tried the latest 6.2.3-25426 with our F4-220?  As per some other threads support for the Realtek r8168 chip should be included so it may just work out of the box.

 

 

Share this post


Link to post
Share on other sites
50 minutes ago, kociubin said:

Has anyone tried the latest 6.2.3-25426 with our F4-220?  As per some other threads support for the Realtek r8168 chip should be included so it may just work out of the box.

 

 

In a word YES I have been working on what i did and exactly how so even NOOBS such as myself can do it. If you want I can pm you my rough notes and you can send me questions while I finish cleaning up my notes. This includes installing the fancontrol.

Share this post


Link to post
Share on other sites
5 minutes ago, Nunyafb Izness said:

In a word YES I have been working on what i did and exactly how so even NOOBS such as myself can do it. If you want I can pm you my rough notes and you can send me questions while I finish cleaning up my notes. This includes installing the fancontrol.

 

I will attempt it today.  It would be great if you could post your notes here for everyone to see. 

Share this post


Link to post
Share on other sites
8 hours ago, Nunyafb Izness said:

In a word YES I have been working on what i did and exactly how so even NOOBS such as myself can do it. If you want I can pm you my rough notes and you can send me questions while I finish cleaning up my notes. This includes installing the fancontrol.

8 hours ago, kociubin said:

 

I will attempt it today.  It would be great if you could post your notes here for everyone to see. 

Yes!! Post notes! And a noob info on how to upgrade/update the firmware without losing all my data ^^. If it has hardware support for Plex to this will be awesome :)

Share this post


Link to post
Share on other sites
13 minutes ago, Benoit258 said:

Yes!! Post notes! And a noob info on how to upgrade/update the firmware without losing all my data ^^. If it has hardware support for Plex to this will be awesome :)

I'm Sorry I am NOT a Linux guy I use it maybe 1-2 times a year usually dealing with Xpenology upgrades. I'm over 60 Y/O and frankly don't have time to really learn it (Linux guy's are free to flame me but when you get over 60 tell me you want to learn a whole new programing language) I end up looking up commands every time I try a new project. 

I can not guarantee you won't lose you date I did my work as a clean install. I don't use Plex I use Emby and I don't care about transcoding Sorry. I'm working on info right now and will try to post as soon as I can.

Share this post


Link to post
Share on other sites

I decided to just pull the trigger and apply the upgrade to 6.2.3.  I was able to upgrade directly from  "DSM 6.2.1-23824 Update 6" to:  6.2.3-25426.   I didn't have to do any additional tweaks. I simply upgraded from the UI and 10 minutes later my NAS was back up and running 6.2.3.

 

Everything appears to work OK so far.  I noticed that I lost hardware transcoding (i.e. no /dev/dri device) but I don't care. 

 

 

Share this post


Link to post
Share on other sites
55 minutes ago, kociubin said:

I decided to just pull the trigger and apply the upgrade to 6.2.3.  I was able to upgrade directly from  "DSM 6.2.1-23824 Update 6" to:  6.2.3-25426.   I didn't have to do any additional tweaks. I simply upgraded from the UI and 10 minutes later my NAS was back up and running 6.2.3.

 

Everything appears to work OK so far.  I noticed that I lost hardware transcoding (i.e. no /dev/dri device) but I don't care. 

 

 

 

I was able to get transcoding to work.  I used v0.13.3 extras from this thread:  "Driver extension jun 1.03b/1.04b for DSM6.2.3 for 918+ / 3615xs / 3617xs"

 

Everything works now including hardware transcoding inside plex. 

Share this post


Link to post
Share on other sites

Hello i want to post my successful CLEAN installation of DSM 6.2.2-24922 Update 6 on the F2-220.

The things i have used:
-Jun's Loader v1.03b DS3615xs (LINK)
-Driver extension jun 1.03b/1.04b for DSM6.2.2 for 3615xs (LINK)
-Bios settings set to "Legacy"
-VGA cable to select USB Stick from Boot options

Steps:
-First edit the GRUB file with VID,PID,MAC etc
-Second, mount the second partition and replace the extra.lzma file from Driver extension mod
-Third, extract the zImage and the rd.gz from the DSM_DS3615xs_24922.pat file and place them on the second partition again
 

Screenshot_2020-07-06 Diskstation - Synology DiskStation.png


Edit:

I have tested the DSM 6.2.3-25426 Version and booted up nicely

I have followed the same steps but i have used the following:
-Same loader
-Driver extension jun 1.03b/1.04b for DSM6.2.3 (LINK)
-The zImage and the rd.gz from the DSM_DS3615xs_25426.pat file



 

Screenshot_2020-07-06 DiskStation - Synology DiskStation(2).png

Edited by delavegagr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.