MikeM

booten von DS3615xs 6.1 Jun's Mod V1.02b.iso nicht möglich

Recommended Posts

Ich habe mir die Datei:

 

    DS3615xs 6.1 Jun's Mod V1.02b.iso

 

heruntergeladen und wollte eine virtuelle Maschine mit DSM 6.1.3 erstellen. Jedoch kann die Maschine nicht vom ISO-Image booten, da angeblich kein Bootmedium eingelegt ist. Beim Versuch das Image zu mounten, erhielt ich sowohl unter Window10 als unter MacOS die Meldung, das das Image beschädigt sei.

 

Unter Linux konnte ich das Image öffenen und fand darin folgende Dateien:

   extra.lzma

   info.txt

   rd.gz

   zImage

 

Mit XPEnoboot_DS3615xs_5.2-5644.4.iso konnte ich problemlos VM's unter VM-Ware, VirtualBox und Hyper-V erstellen. Da ich aber auf meine DS214+ bereit DSM 6.1.3 zu laufen habe, würde ich das System zu Testzwecken auch in einer VM erstellen.

 

Mike

Share this post


Link to post
Share on other sites

Und wie bekomme ich dann ein bootfähiges Image für Hyper-V?

 

Mein Englisch ist leider lausig und habe dazu noch nichts gefunden.

Share this post


Link to post
Share on other sites
3 minutes ago, MikeM said:

Und wie bekomme ich dann ein bootfähiges Image für Hyper-V?

 

Mein Englisch ist leider lausig und habe dazu noch nichts gefunden.

 

Die Bootloader img in StarWind V2V Image Converter laden und dann das Format auswählen.

 

 

 

59942bff4dc45_StarwindV2V.jpg.d8686acade9ed240817e30fe3b99cd5a.jpg

Starwind V2V.jpg

Edited by logy

Share this post


Link to post
Share on other sites

Hat soweit geklappt, aber bei Booting the Kernel bleibt die Maschine stehen. (getestet mit Hyper-V und VirtualBox 5.22)

Share this post


Link to post
Share on other sites

Ich habe die VM jetzt mit dem Synology Assistant im Netz gefunden. Leider klappt die Installation der Firmware über den Assistenten anscheinend nicht ohne eine Internetverbindung. der Zugriff über den Webbrowser ist leider auch nicht möglich. Da sich der Host in einem abgeschlossenen Netzwerk befindet, kann ich keine Internetverbindung herstellen.

 

Hat jemand eine Idee, wie ich diese Hürde umgehen kann?

Share this post


Link to post
Share on other sites

Das hatte ich natürlich gemacht, aber die Installation bricht ab und es gibt eine Fehlermeldung. Zur Fehleranalyse will das Programm auf die NAS über Port 23 mit Telnet zugreifen. Ich soll den Router prüfen und den Port freischalten.

 

Nur da ist kein Router. Da die virtuelle NAS nicht im Netzwerk auftauchen darf, läuft alles über das interne Netz der VM. Das heißt, nur der Host und die VM's können darauf zugreifen.

 

 

Share this post


Link to post
Share on other sites
On 16.8.2017 at 1:24 PM, MikeM said:

Und wie bekomme ich dann ein bootfähiges Image für Hyper-V?

 

Mein Englisch ist leider lausig und habe dazu noch nichts gefunden.

Ein gutes Englisch nutzt da leider auch nix, weil der Kernel der 6er Version kein Hyper-V unterstützt. Ein Patch wurde leider bisher noch nicht eingearbeitet.
 

Share this post


Link to post
Share on other sites

hallo,

 

eines der "probleme" ist das der bedarf nicht so hoch ist, die leute die einen echten hypervisor brauchen nehmen esxi (auch wenn sie lieber hyper-v hätten) und die das nur für test vm's brauchen nehmen unter windows virtual box

 

da der support für hyper-v direkt in den kernel compiliert werden muss (ladbare module reichen nicht) ist das nicht so einfach, außer jun pruduziert zur zeit keiner einen kernel (der dann auch die schutzmechanismen von synology umgehen muss), je weiter man sich vom original synology kernel entfernt desto höher die wahrscheinlichkeit das man das dsm das sysnology ausliefert (eine appliance) nicht mehr richtig läuft

wenn es mit esx nicht liefe dann würde sich evtl. eher was tun aber da esx einfach mit ein paar zusätzlichen treibern läuft gehts den weg des geringsten widerstandes und ich denke die wahrscheinlichkeit das sich das ändert ist gering

am ende wollen die leute dms in einer hypervisor umgebung nutzen uns sich nicht wochen lang damit beschäftigen wie man das doch hinkriegt, solche "überzeugungstäter" mit viel zeit un knowhow gibts nicht viele, man kann seine zeit und energie auch anderweitig investieren

so lange vmware den esx quasi verschenkt wird sich da nichts ändern und selbst wenn, da dsm bereits kvm support eingebaut hat (synology nutzt das selbst für virtual dsm) würde es evtl. schnell in diese richtung schwenken

 

ist auch irgenwie ein wiederspruch in sich, ein microsoft/hyper--v enthusiast der sich so in linux rein kniet (neuen kernel mit schutz umghenung und alllem) um dann eine linux system (dsm, das dann einen "emulator" für windows netzwerke und AD "emulator" enthält) zum laufen zu bewegen ...

wer betriebssystem/hypervisor eher als mittel zu zweck sieht wird sich nicht an hyper-v klammern und das nehemn was ohne probleme geht und wenn man mal sieht was einen kleine extra hardware für baremetal so kostet und wie viele stunden man für den hyper-v support investieren muss - ich meine das wird nicht passieren, wäre extremer zufall wenn sich jemand (außer jun) dafür findet

 

PS: man kann open media vault unter hyper-v laufen lassen, auch das kann den einen oder anderen potentiell kandidaten von dsm fernhalten, ist halt keine appliance wie dsm und dadurch leichter anpassbar

 

Share this post


Link to post
Share on other sites

Leider muß auf meinem Rechner Hyper-V laufen. Damit scheiden sowohl VM-Ware (Workstation ist ein etwas zickig und will nicht neben dem Hyper-V laufen) und VirtualBox (hier laufen neben dem Hyper-V nur 32-Bit Maschinen) aus.

 

Das Problem scheint jedoch hauptsächlich in der fehlenden Internetverbindung zu liegen. Ich habe auf einen anderen Rechner eine DSM-6-1 in VM-Ware erst installieren können, nachdem ich eine Internetverbindung hergestellt habe.

 

Dummerweise kann ich diese Maschine nicht nach Hyper-V migrieren. Hyper-V bietet hierfür keine Importmöglichkeit an. Der VM-Ware Converter kann zwar so ziemlich alles importieren, bietet aber leider keine Exportmöglichkeit, was natürlich nachvollziehbar ist.

 

Share this post


Link to post
Share on other sites

Hallo @MikeM,

 

ich stehe gerade vor dem selben Problem wie du.

Ich habe zwar nicht das Problem der Netzwerktrennung und fehlenden Internetverbindung (also meine VM darf normal im Netzwerk hängen), die VM wird aber weder übern Browser, noch über den Synology Assistant gefunden.

Was hast du getan, damit du deine VM überhaupt finden konntest?

 

Danke und Gruß

Share this post


Link to post
Share on other sites

hallo,

 

das mit dem netzwerk in der hyper-v vm ist imho so das die ms eigene virtuelle karte den hyper-v support im kernel braucht (der nicht drin ist, module reichen da wohl nicht) und die fail save karte DEC 21140 ist nicht in DSM selbst und nicht in Jun's loader enthalten - letzteres könnte man zwar ändern (habe ich vor, wird vermutlich in meinem nächsten extr.lzma drin sein) aber bringen wird nicht viel da die karte nur 100Mbit unterstützt und max. 4 davon möglich sind, also selbst wenn man es schafft die zu bündeln wäre die performance nur zum rumspielen ausreichend, wirklich effektiv nutzen ginge so imho nicht

bei vmware und virtual box gibts das problem nicht da bei ersterem die virtuelle vmxnet karte ein einfacher treiber ist der als modul nachgeladen werden kann und zum anderen gibts als fail save eine intel e1000 gigabit karte die von dsm bzw. jun's loader unterstützt wird

Share this post


Link to post
Share on other sites

Hallo zusammen, ich stehe vor dem Problem, dass ich von 5.0-4493 nicht auf DSM 6.1.x updaten kann. Ich bekomme meinen USB Stick nicht zu booten, habe alles ergänzt VID, PID, S/N, MAC und die Kiste bootet nicht vom Stick :-( Monitor bleibt schwarz. Wahrscheinlich mache ich einen simplen Fehler ... ich komme aber nicht drauf.

Leider habe ich im BIOS auch kein C1E deaktivieren können, vielleicht hängt es damit zusammen. Bin für jede Idee dankbar!

Beste Grüße, Benjamin

Share this post


Link to post
Share on other sites

@dm7zq

schon mal die begriffe thread hijacking oder crossposting gehört?

 

mach bitte einen eigenen thread auf und beschreib deine hardware genauer

board, prozessor, storage controller und nic wären wihtig

und genauer bei

1 hour ago, dm7zq said:

Monitor bleibt schwarz.

 

es kommt ja sicher noch eine meldung des BIOS, wenn er wirklich schwarz bliebe hättest du ganz andere probleme als wenn der stick nicht bootet

in der theorie kommt erst  der grub und danach bootet der kernel aber der meldet nur das er startet, der rest wird auf der console an com1 ausgegeben (was den meisten nichts nützt)

 

 

 

Edited by IG-88

Share this post


Link to post
Share on other sites

Hallo IG-88,

 

danke für Deine Hinweise. Ich sammele die Infos und werde separat posten.

 

Grüße, Benjamin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now