Recommended Posts

5 минут назад, Vladimir_ar сказал:

пытался ставить вначале не docker. Блин не получается:

  error (Показать содержимое)

sudo docker exec -u www-data nextcloud php /var/www/html/occ maintenance:mode --on
Console has to be executed with the user that owns the file config/config.php
Current user: www-data
Owner of config.php:
Try adding 'sudo -u  ' to the beginning of the command (without the single quotes)
If running with 'docker exec' try adding the option '-u ' to the docker command (without the single quotes)


 

так может в этом и проблема, может вам сначала зачистить все хвосты от предыдущей установки owncloud, подозреваю что там какой-то конфликт произошел, но этот вариант можно рассматривать как последнюю инстанцию, если не получится исправить.

  • Thanks 1
Link to post
Share on other sites
15 minutes ago, xMiroRRside said:

вам надо выйти из оболочки bash nextcloud

подскажите пожалуйста как?

Spoiler

Console has to be executed with the user that owns the file config/config.php
Current user: www-data
Owner of config.php:
Try adding 'sudo -u  ' to the beginning of the command (without the single quotes)
If running with 'docker exec' try adding the option '-u ' to the docker command (without the single quotes)

 

Edited by Vladimir_ar
Link to post
Share on other sites
13 minutes ago, xMiroRRside said:

делаем из под root


sudo -i

вводим пароль

и видим root@Xpenology:~$ 

пробовал, всё без изменений, я походу с правами напортачил, но никак не могу изменить владельца файла

Screenshot_2.jpg

Link to post
Share on other sites
1 минуту назад, Vladimir_ar сказал:

пробовал, всё без изменений, я походу с правами напортачил, но никак не могу изменить владельца файла

Вот оно чего, 

cd /docker/nextcloud/www/html/config
chown -R 33:33 config.php
chmod -R 640 config.php

 

  • Thanks 1
Link to post
Share on other sites
24 minutes ago, xMiroRRside said:

Вот оно чего, 


cd /docker/nextcloud/www/html/config
chown -R 33:33 config.php
chmod -R 640 config.php

 

благодарю, права исправить получилось и все ваши рекомендованные команды тоже выполнил, но к сожалению без изменений всё:

Spoiler

 

ErrorindexTypeError: Argument 3 passed to OC\AppFramework\Middleware\MiddlewareDispatcher::beforeOutput() must be of the type string, bool given, called in /var/www/html/lib/private/AppFramework/Http/Dispatcher.php on line 124

/var/www/html/lib/private/AppFramework/Http/Dispatcher.php - line 124:

OC\AppFramework\Middleware\MiddlewareDispatcher->beforeOutput(OCA\Onlyoffi ... {}, "download", false)

/var/www/html/lib/private/AppFramework/App.php - line 137:

OC\AppFramework\Http\Dispatcher->dispatch(OCA\Onlyoffi ... {}, "download")

/var/www/html/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:

OC\AppFramework\App::main("OCA\\Onlyof ... r", "download", OC\AppFramew ... {}, { _route: "o ... "})

<<closure>>

OC\AppFramework\Routing\RouteActionHandler->__invoke({ _route: "o ... "})

/var/www/html/lib/private/Route/Router.php - line 297:

call_user_func(OC\AppFramew ... {}, { _route: "o ... "})

/var/www/html/lib/base.php - line 1007:

OC\Route\Router->match("/apps/onlyoffice/download")

/var/www/html/index.php - line 37:

OC::handleRequest()

 

ErrorPHPfopen(/var/www/html/data/admin/files/Documents/Nextcloud flyer.pdf): failed to open stream: No such file or directory at /var/www/html/lib/private/Files/Storage/Local.php#351

Fatal    webdav    Sabre\DAV\Exception\ServiceUnavailable: Could not open file
/var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 90:

OCA\DAV\Connector\Sabre\File->get()

/var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php - line 89:

Sabre\DAV\CorePlugin->httpGet(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})

/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 474:

Sabre\DAV\Server->emit("method:GET", [ Sabre\HTTP ... }])

/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 251:

Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})

/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php - line 319:

Sabre\DAV\Server->start()

/var/www/html/apps/dav/appinfo/v1/webdav.php - line 82:

Sabre\DAV\Server->exec()

/var/www/html/remote.php - line 167:

require_once("/var/www/ht ... p")

 

 

Link to post
Share on other sites
1 минуту назад, Vladimir_ar сказал:

благодарю, права исправить получилось и все ваши рекомендованные команды тоже выполнил, но к сожалению без изменений всё:

Удалите все хвосты предыдущей установки, и поставьте заново, все должно заработать, это пожалуй лучший вариант.

  • Thanks 1
Link to post
Share on other sites

 Да в том, то и дело, что не было предыдущих установок, была попытка настройки  nextcloud как веб сервера, но не завелось, потом увидел ваш пост и решил попробовать в docker и тут засада.

Link to post
Share on other sites
1 час назад, xMiroRRside сказал:

19938 -rw-r--r-- 1 www-data www-data   4096 Jul  9 19:25 owncloud.db

это как там появилось?

Думаю что, есть еще что лишнее, чего там быть не должно, поэтому рекомендую вам удалить все и поставить с чистого листа 

Edited by xMiroRRside
добавил
  • Thanks 1
Link to post
Share on other sites

Короче удалил docker контейнер и снова попытался запустить через web station - блин всё работает, открывает из локалки и внешки, но как-то не очень быстро, мне показалось из docker как-то гораздо пошустрее всё бегало. А docker контейнер у меня 100% конфликтовал с web station, тут походу или один вариант или другой. 

Edited by Vladimir_ar
Link to post
Share on other sites
1 час назад, Vladimir_ar сказал:

А docker контейнер у меня 100% конфликтовал с web station, тут походу или один вариант или другой. 

О чем вам и говорил, что где то есть какой-то конфликт, поэтому вам и рекомендовал удалить все предыдущие установки и поставить все с нуля.

1 час назад, Vladimir_ar сказал:

из docker как-то гораздо пошустрее всё бегало

Да, через Docker работает шустрей, а если еще поставить Redis для кеширования, будет еще быстрей.

  • Thanks 1
Link to post
Share on other sites
11 minutes ago, xMiroRRside said:

О чем вам и говорил, что где то есть какой-то конфликт, поэтому вам и рекомендовал удалить все предыдущие установки и поставить все с нуля.

Да, через Docker работает шустрей, а если еще поставить Redis для кеширования, будет еще быстрей.

Огромная благодарность за помощь и приобретённый опыт. (не разобрался пока как тут плюс участнику ставить)

Link to post
Share on other sites
6 минут назад, Vladimir_ar сказал:

(не разобрался пока как тут плюс участнику ставить)

На сердечко, там выбираете кубок.

Не за что, чем смог помог🍻

  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...
В 14.07.2020 в 14:41, xMiroRRside сказал:

Да, через Docker работает шустрей, а если еще поставить Redis для кеширования, будет еще быстрей.

Интересно, почему так происходит, теоретически должно быть наоборот, наверное в хостовом апаче или пхп что-то закручено?

У меня нексткоуд на хосте, в принципе для семейных нужд скорости хватает, но по сравнению с owncloud на работе на нормальном линухе, торможения чувствуются.

Вспомнил еще, после установки, при встроенной проверке некстклоуд ругается на отсутствие пхпшного imagemagick помоему. Нашел где-то мурзилку по его нетривиальной установке, установил, но никакого эффекта не заметил, наверное используется модулями, которыми я не пользуюсь.

И еще у меня не работает обновление версии через веб-интерфейс, вероятно с какими то пхп-параметрами непорядок, хотя вроде всё крутил по науке. Через командную строку обновляется нормально.

Edited by KIO1968
Link to post
Share on other sites
  • 1 month later...

Прошу помощи. Поломался Некстклауд в Докере.

Вроде бы ничего такого не трогал, но раз поломался, то значит всё-таки наверное трогал. 
Возможно это как-то связано с тем, что накануне, ради интереса, пробовал запустить VPN сервер и  DHCP сервер на Synology. Может быть в процессе где-то что-то не то нажал. 

Починить без переустановки не получилось, решил переустановить с нуля, удалив контейнеры и образы Некстклауда и Марии.
Сначала попробовал по той инструкции, по которой Некстклауд работал до поломки. 
Потом попробовал так
Потом снёс всё вместе с Докером и переустановил снова - не помогло.
Потом попробовал установить Некстклауд с Марией без Докера - безрезультатно.

 

Самое интересное, что во всех случаях результат переустановки выглядит одинаково. 

 

NEXTTT.jpg.9de4fca64cec3df65fc9067ae9f0eb1d.jpg

 

Внимание, вопрос. Куда копать?

Link to post
Share on other sites
15 минут назад, Valiko сказал:

Прошу помощи. Поломался Некстклауд в Докере.

Вроде бы ничего такого не трогал, но раз поломался, то значит всё-таки наверное трогал. 
Возможно это как-то связано с тем, что накануне, ради интереса, пробовал запустить VPN сервер и  DHCP сервер на Synology. Может быть в процессе где-то что-то не то нажал. 

Починить без переустановки не получилось, решил переустановить с нуля, удалив контейнеры и образы Некстклауда и Марии.
Сначала попробовал по той инструкции, по которой Некстклауд работал до поломки. 
Потом попробовал так
Потом снёс всё вместе с Докером и переустановил снова - не помогло.
Потом попробовал установить Некстклауд с Марией без Докера - безрезультатно.

 

Самое интересное, что во всех случаях результат переустановки выглядит одинаково. 

 

NEXTTT.jpg.9de4fca64cec3df65fc9067ae9f0eb1d.jpg

 

Внимание, вопрос. Куда копать?

Ошибка при попытке создать пользователя с правами администратора: не удалось подключиться к базе данных: возникла исключительная ситуация в драйвере: SQLSTATE [HYO00] [2002]

Смотрите внимательно, возможно где-то напутали с базой данных, проверьте пользователя, пароль, и правильно ли вы указали IP-address:порт базы данных.

Link to post
Share on other sites
2 часа назад, xMiroRRside сказал:

Смотрите внимательно, возможно где-то напутали с базой данных, проверьте пользователя, пароль, и правильно ли вы указали IP-address:порт базы данных

 

 

Проверял не один раз. Заходил в Марию через терминал: база есть, имя правильное, юзер и его пароль тоже.🥴

Странно, что ошибка одна и та же и в Докере и без Докера.

 

Link to post
Share on other sites

Если настраиваете на хосте, указывайте адрес субд как 127.0.0.1 (или может даже 127.0.0.1:3307 уже не помню точно по прошествии времени) а не localhost, и в настройках пхп проверьте что касается марии/мускула, чтоб порт стоял 3307 а не 3306. В самой хрени брандмауэр не включен ли, может он тоже что-то блокирует?

 

  • Thanks 1
Link to post
Share on other sites

Нашёл.

Оказывается была включена вот эта пимпочка. 

 

 

Скрытый текст

next.thumb.jpg.064505900bee53f7148ac87572d2047f.jpg

 

 

 

Но это ещё не всё. Не понос, так золотуха. Теперь выяснилось, что подключение по SSH не работает. По Telnet соединяется, а по SHH - Connection refused.

 

Попутно замечено, что не включается служба SFTP. Ставлю галку, нажимаю применить, система пишет settings applied, но галка снимается. 

 

Скрытый текст

settings.thumb.jpg.e979374f1e9799bc6422a0a397859753.jpg

 

Link to post
Share on other sites

Проверьте, включена ли галка ssh в панель управления / терминал и снмп, sftp работает поверх ssh...

Так же поройтесь в районе безопасность / учетная запись на предмет блокировки айпишников, пропишите вашу локальную подсеть в список разрешенных.

Брандмауэр точно выключен?

  • Thanks 1
Link to post
Share on other sites
1 час назад, KIO1968 сказал:

Проверьте, включена ли галка ssh в панель управления / терминал и снмп, sftp работает поверх ssh...

Так же поройтесь в районе безопасность / учетная запись на предмет блокировки айпишников, пропишите вашу локальную подсеть в список разрешенных.

Брандмауэр точно выключен?

 

Брандмауэр точно выключен.

А вот галка в панели управления глючит. В "панель управления / терминал и снмп" галку можно снять и поставить, а в "панель управления / информационный центр /  служба" галку можно только снять. Если поставить и попытаться сохранить, то галка сбросится на горизонтальную черту.

 

 

Скрытый текст

ssh.thumb.jpg.b22012cdaa18ada808d977118019f789.jpg

 

 

И ещё такя штука происходит, когда переключаюсь в telnet на root. Вроде бы раньше такого не было.

 

sudo: /var/db/sudo/lectured is owned by uid 1023, should be 0

Edited by Valiko
Link to post
Share on other sites

А почему у вас два порта на SSH значатся, 22 и 223?

 

1 час назад, Valiko сказал:

И ещё такя штука происходит, когда переключаюсь в telnet на root. Вроде бы раньше такого не было.

 

sudo: /var/db/sudo/lectured is owned by uid 1023, should be 0

А сменить владельца этого каталога (chown или по крестьянски через мс) на root даёт, не пробовали? У себя посмотрел, владелец каталога root:root, права 700.

У меня картинки DSM по другому выглядят, наверное у Вас версия старенькая.

Вполне возможно, что когда то вы с правами в файловой системе намудрили, не проще переставить систему с нуля, если знаний в линухе недостаточно?

Заодно тогда может и версию DSM посвежее поставите, если конечно с железом оно совместимо.

 

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.