Recommended Posts

Yesterday my house's breakers tripped, and my NAS(Xpenology DSM 6.1.3-Update 1) shut down.

After that, I get the error below with practically everything (Control panel - show user details, Download station, Package center, .........)

So now I'm left with a bare-bone NAS only with SMB.

 

Any reasons why? Any help will be well appreciated.

 

Pack.PNG

**Translation : "Task Failed" **

 

**Trying to click on 'Reset Everything' on the Control Panel doesn't do anything :( **

Edited by Lazy775

Share this post


Link to post
Share on other sites

How can I reinstall it? Tried formatting a drive and reinstalling OS, but boots from the corrupted install.

 

2 out of 4 HDDs are reinstalled(1 volume)

other 2(volumes) are intact, since I don't want to lose data

Share this post


Link to post
Share on other sites

What kind of hardware you have? Remove (take the HDD out) with only the bootloader USB stick inserted.

 

power on, and let it boot to the boot loader.

 

Find it on the synology assistant, and when it opens the web page, it will ask to insert HDD insert and then do a install.This Should NOT delete your data, however this can possibly clear your configurations (some settings in DSM like network , etc etc) no file should be erased.

 

Share this post


Link to post
Share on other sites

I have tried that, but it couldnt detect HDD when it booted :(

Also, trying to boot with the formatted disk and plugging in the drives(with bad OS) doesnt work.

And, putting all of my drives while booting makes it boot to the bad OS.

Share this post


Link to post
Share on other sites

**Note**

HDD1 : 2TB, with bad OS

HDD2 : 2TB, with bad OS(seperate volume)

HDD3 : 500GB, formatted and has clean OS

HDD4 : same as above, but only 250G

 

HDD3 and 4 are JBOD Volumes.

 

**Things I've tried**

Boot with no drives - Not recognizing hot swap(added while on) HDDs

Format some drives and mount others from that - Same as above, even HDD2 attached over USB are not recognized.

Click on system reset from Control Panel - no response

Attach all drives after formatting HDD3 and 4 and install them with clean OS - boots into BAD OS as long as there are at least 1 drive.

Share this post


Link to post
Share on other sites

Possible solutions : 

 

1. Reinstall OS(I dont know how)

2. Format everything and start from scratch

 

I want to stay away from number 2(or destructive solutions in total).

Can anyone tell me how to reinstall DSM?

 

Note : used DS3617xs image

 

**Going to sleep now, tired fighting my NAS**

Edited by Lazy775

Share this post


Link to post
Share on other sites

try

1) disconnect all drives

2) connect a 'new' (unpartitioned) drive on sata channel 1

3) install dsm to same version as before with an admin account/password same as before, shutdown

4) reconnect 'other' drives to sata 2-4 and repair system partitions

5) repeat 4) for remaining drives then finally reconnect the 4 disks you need. 

Share this post


Link to post
Share on other sites

Solved!

 

Reinstalled by the following : 

 

1) Change /etc.defaults/VERSION (sudo /etc.defaults/VERSION) into something older (ex : DSM 6.1.2 - 15132)

 

2) Reboot

 

3) Synology assistant should say 'Migration Available'. Install the latest OS.

 

4) Yay! It's done now!

 

Thanks @Polanskiman for the reinstall tips :smile:

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.