Jump to content
XPEnology Community

Open VPN setup Plus bugs


razer1x2
 Share

Recommended Posts

Hi,

 

My first post here and I have read what I can and still confused and cant seem to find what im looking for.. plus the search doesn't seem to want to find anything - Terms too generic/common?

 

Im new to installing Xpenology and have got a successful install but a few bugs are present.

 

Hardware wise, specs for install are:

 

HP N54L Microserver std config with 250gb hdd / 2gb ram..

3x2tb hdd's

Onboard NIC

 

Network specs:

Virgin Media Superhub Business 50mb

Netgear 200mb Homeplugs connected to router and server

 

Clients:

Macbook Pro ML

Iphone's

Windows Hardwired desktop 2ft from server connected to same homeplug as is 4way switch model..

 

The problems im having are:

HDD's dont seem to want to spin down.

Nor do I have WOL working. Says cannot make changes to WOL setup.. Problem with Mac address from digging?

Also cant connect via openvpn to the server from outside the network.

 

 

Everything works fine except for the spindown of the hdd's and the VPN tunnel. I can get to the authentication stage at which point it asks for the Username and password - Which are the User's ones ( have tried all of my users accounts and even made new one to try still no luck.

 

I have ports forwarded right on the SH - Port 1194 on both the SH and also in the Firewall, and router config for DSM. I have a dynamic IP so use the DDNS service free with a synology domain. I have used this external WAN ip for the connection in the config file for OpenVPN and do get as far as authentication so thats all fine.

 

Now im stuck and not sure what to try. Oh im connecting using tunnelblick for mac as the VPN tunnel platform. I tried PPTP but couldn't get it to connect at all??

 

NOW HELP! :grin:

 

Please!

 

Cheers,

Ryan

Link to comment
Share on other sites

Glad im not the only one with issues!

 

Im about to try the 4.3 build to see if makes any difference aswell as try to get the WOL to work..

If I cant get VPN to work then looking at going hardware based with VPN switch or router... Will have to see...

Link to comment
Share on other sites

Not wanting to teach anyone to suck eggs as it were, but are you sure you have the correct ports open and forwarded?

 

These are the ones that Synology list:

 

Type                    Port Number	Protocol
Cloud Station           6690            TCP
VPN Server (OpenVPN)    1194            UDP
VPN Server (PPTP)       1723            TCP
VPN Server (L2TP/IPSec) 500, 1701, 4500 UDP

 

ref: What network ports are used by Synology services?

Link to comment
Share on other sites

Ports all open right...

 

Been through about 20 combinations of ports and forwarding to no avail.. Ports are right as it will get as far as the authentication stage at which point I use my login which has admin rights and gets refused. Try default admin ( the one setup with) same problem so gathered its not a port problem..

 

I could understand the port problem being the case if it wouldn't connect at all but it does??

 

Thanks for the help anyhow.. WIll also try when I update to 4.3 tomorrow and see if it makes any difference.. Still looking at going hardware anyway as means can vpn into network and wol..

Link to comment
Share on other sites

Got VPN working now...

 

A little bit of tinkering and it now works on 4.3 build...

 

Now to try and get WOL working so I can boot the machine remotely..

 

Am planning on moving VPN server from xpenology to Raspberry PI if I can get WOL to work... We shall see.. Any demo's/ instructions for WOL would be grateful! Lol..

 

Raz

Link to comment
Share on other sites

 Share

×
×
  • Create New...