Kizilkum

Установка Xpenology на ESXI

Recommended Posts

В 24.07.2017 в 11:28, Kizilkum сказал:

если у вас нет возможности пробросить целиком контроллер, можно подключить целиком физические диски, не пробрасывая весь контроллер

называется это pRDM, как это делается подробно расписано здесь.

17.JPG.df9e6117646c609cbaf03edd09505221.JPG

 

Правильно я понимаю что диск 1 на 50 МБ на SATA котроллере 0 размещен? 

Не понятно почему Диск 2 размещен на контроллере SCSI 0:1, а не 0:0 - это значение пропущено или на нем размещен DSM?

Контроллер устанавливаете SCSI LSI Logic Parallel в режиме none, virtual или physical?

По этому скрину видно что запустили диски 4 ТБ. 

Edited by lliax

Share this post


Link to post
Share on other sites

В общем не смог победить проброс дисков в физическом режиме. Пробросил встроенный дисковый контроллер. Благо у меня их 2 встроенных на мат. плате. 

Share this post


Link to post
Share on other sites

Добрый день.

 

Решил поставить XPEnology на ESXi, есть микросервер НРЕ 8-го поколения. ESXi на microSD, версия 6.7.

датастор и виртуалка на отдельном SSD диске, в слоте для подключения DVD-ROM. 

в качестве инструкции использовал видео из темы , файлы брал отсюда

виртуалка поднимается, хранилище находится, устанавливается, все хорошо.

далее использовал RDM для маппирования дисков, причем не важно с каким ключом -z или -r. 

хранилище диски видит, говорит, что не инициализированные. провожу инициализацию, делаю raid 1 на 2 диска, делаю на них один пул на весь объем.

хранилка работает, данные на нее пишутся, читаются. скорость порядка 113 МБ/сек. 

 

проблема вот в чем, если погасить сервер и вытащить один диск из рейда, хотел проверить как отработает XPEnology потерю одного диска, то виртуальная машина более не включается, жалуется на потерянный диск.

как мне кажется такого быть не должно, ведь сама виртуалка живет на другом диске.

 

может кто-то сталкивался с таким, и подскажет, в какую сторону копать.

Share this post


Link to post
Share on other sites
6 часов назад, Rojer сказал:

raid 1 на 2 диска, делаю на них один пул на весь объем

Проверьте, возможно вы рейд 0 создали, а не 1. Давно на голом железе пробовал из зеркала второй винт вытаскивать, все заводилось на 1 винте.

Share this post


Link to post
Share on other sites
8 hours ago, Olegin said:

Проверьте, возможно вы рейд 0 создали, а не 1. Давно на голом железе пробовал из зеркала второй винт вытаскивать, все заводилось на 1 винте.

Увы, рейд 1. даже если ставлю диски как independent persistent все тоже самое.

попробую провести эксперимент на bear metal 

Share this post


Link to post
Share on other sites
8 hours ago, Olegin said:

Проверьте, возможно вы рейд 0 создали, а не 1. Давно на голом железе пробовал из зеркала второй винт вытаскивать, все заводилось на 1 винте.

Тут видимо не совсем такая ситуация. На железе, BIOS продолжает загрузку при отсутствуюшем диске. Для VM это фатальная ошибка.

Share this post


Link to post
Share on other sites
22 minutes ago, XPEH said:

Тут видимо не совсем такая ситуация. На железе, BIOS продолжает загрузку при отсутствуюшем диске. Для VM это фатальная ошибка.

Есть идеи что делать? Проверил sata, 1:, пробовал диски ставить в independance, результат один, при отключении диска врртулка не стартует

Share this post


Link to post
Share on other sites

Доброго времени суток.
Установка прошла успешно.
Но проблема возникла что, не работает Центр пакетов. (Подскажите как исправить)

Создавал нового пользователя с правами администратора. Проблема не решилась


 

Снимок экрана 2020-01-26 в 15.48.33.png

Edited by Graid

Share this post


Link to post
Share on other sites
3 часа назад, Graid сказал:

Доброго времени суток.
Установка прошла успешно.
Но проблема возникла что, не работает Центр пакетов. (Подскажите как исправить)

Создавал нового пользователя с правами администратора. Проблема не решилась


 

Снимок экрана 2020-01-26 в 15.48.33.png

Проверьте пинг Гугла, мне кажется у хрени нет доступа в интернет.

Share this post


Link to post
Share on other sites
Проверьте пинг Гугла, мне кажется у хрени нет доступа в интернет.

Я начал подозревать что проблема с провайдером. Так как если подключить напрямую через роутер все нормально работает.


Отправлено с моего iPhone используя Tapatalk

Share this post


Link to post
Share on other sites

ДНС может быть не прописан.

Только, что решил залипший центр после обновления, соданием юзера.

Edited by exotsk

Share this post


Link to post
Share on other sites

Ребята, у меня есть 8 виртуальных машин с xpenology c 1 gb ram и 20 gb жесткий диск. Они у меня типа пустышки, не спрашивайте для чего. Вопрос, какие минимальные жетские диски и ram можно дать этой виртуалке чтобы хрень запустилось?

Share this post


Link to post
Share on other sites

День добрый!

Скиньте на fex.net. эти заветные три/два файла, плиз!

третий день мучаюсь - все заканчивается с ошибкой 35 (немогу отформатировать диск)

Перепробовал все! и виртуальный диск и проброс физического и разные контроллеры и маки с серийниками.

Упирается в немогу отформатировать диск :(

Share this post


Link to post
Share on other sites
8 минут назад, AlexChu сказал:

Это видел, буду пробовать. А для 3615?

Тынц.

  • Like 1

Share this post


Link to post
Share on other sites
4 минуты назад, Olegin сказал:
13 минуты назад, Olegin сказал:

@AlexChu Тынц для 918

Спасибо буду копать....Может оффтоп но какая разница между 918 и 3615?

Share this post


Link to post
Share on other sites

Если проц позволяет, то на 918 можно попробовать запустить железный транскодинг путем проброса GPU... В остальном теже яйца только в профиль.

Share this post


Link to post
Share on other sites
3 минуты назад, Olegin сказал:

Если проц позволяет, то на 918 можно попробовать запустить железный транскодинг путем проброса GPU... В остальном теже яйца только в профиль.

Спасибо!

Share this post


Link to post
Share on other sites

Перепробовал все варианты, запустился какойто левый туториал с англоязычного сайта, но совсем не то что хотелось.

Может кто подскажет: как включить логирование через ком-порт на ESXi+Xpenology.

Видел где-то на форуме....

Share this post


Link to post
Share on other sites

Не могу отформатить диск и все! жесть какаято!

лог загрузки прилагаю, может кто подскажет куда копать!

print.jpg

serial.out

Share this post


Link to post
Share on other sites
Posted (edited)

Подскажите минимальный размер hdd сколько нужен чтобы установить xpenology на виртуалке, 5-10 gb хватит?

20 как оказалось многовато

Edited by utya

Share this post


Link to post
Share on other sites
8 часов назад, utya сказал:

Подскажите минимальный размер hdd сколько нужен чтобы установить xpenology на виртуалке, 5-10 gb хватит?

20 как оказалось многовато

Полагаю что 4 Гб будет достаточно. На сколько помню 2 Гб уходит в разметке на разделе под систему. 2 Гб можно оставить под данные.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.