Kizilkum

Установка Xpenology на ESXI

Recommended Posts

10 часов назад, Kizilkum сказал:

2 диска не подключены как pRDM

доброго времени. а есть какая-то проверка корректного подключения накопителя как pRDM? а то у меня все накопители подключены одинаково, в ESXi видятся одинаково, все без разметки, а свинология видит только один накопитель помимо того, на котором datastore1, её файлы и ESXi находятся. И ставится на свой выбор на один из имеющихся. В крайний раз поставилась на тот HDD, который криво подключается к этой ВМ Xpenology, поскольку при правке постоянно горит красная рамка вокруг его размера и мешает сделать save:

5a0c01e6d7f28_synol3hdddetails.thumb.PNG.89d732ba51ba7b07dbc5ce04bd1a8745.PNG

в ESXi при показе этой ВМ всё выглядит как будто так и надо:

5a0bff244f7d4_synol3hddattached.PNG.595f1a711d7c79e7264ce3990b63a259.PNG

Есть ли какой-то способ всё это настраивать?

Могу ещё насыпать скринов, как это выглядит.

synol .vmdk files.PNG

Edited by RadioDOT
убрал лишнее

Share this post


Link to post
Share on other sites

а как можно восстановить Справку DSM? куда-то пропала, пустое окно показывает.

Share this post


Link to post
Share on other sites

Сегодня накатывал DS916p на ESXi 6.5. Создал новую виртуалку, в сторадж виртуалки залил synoboot-flat.vmdk (переименованный synoboot.img) и synoboot.vmdk , прицепил загрузчик к виртуалке. Подцепил пару  RDM-дисков (мапил по-привычке с параметром -r).

Загружаемся (find.synology.com не нашел этот инстанс), запускаю установку, pat-файл скачивается, но система не устанавливается ни автоматом, ни вручную.

Примапил iso c загрузчиком, загрузился с него. Как ни странно, DSM установилась. После установки отцепил iso-шник, оставив загрузчиком synoboot.vmdk

Система загрузилась и работает. Единственное, что ругается сейчас, что "невозможно выполнить запуск DSM, поскольку возникла проблема"

Что это за глюк? Вроде все работает, пакеты устанавливаются...

 

PS Еще вопросец по ESXi на Braswell-ах (в теме есть люди с такой платформой). У меня сейчас 6.5.0 (Build 4564106). Она не имеет поддержки видеоадаптера в N3150 и грузится "вслепую". В новых билдах этот косяк устранен?

Edited by sergk174

Share this post


Link to post
Share on other sites
В 31.03.2018 в 23:35, sergk174 сказал:

У меня сейчас 6.5.0 (Build 4564106). Она не имеет поддержки видеоадаптера в N3150 и грузится "вслепую". В новых билдах этот косяк устранен?

Не понял, что за вопрос?

У меня все работает, и грузится не в слепую, как понять в слепую??

Скрин сделай и сбрось как у тебя, или на телефон сфоткай.... скины не мои, но у меня тоже самое!

ESXi_Complete.gif ESXi_Boot.gif

 

esx management.png

это уже мой

 

 

456.jpeg

 

678.jpeg

Edited by tajson

Share this post


Link to post
Share on other sites
В 31.03.2018 в 23:35, sergk174 сказал:

У меня сейчас 6.5.0 (Build 4564106). Она не имеет поддержки видеоадаптера в N3150 и грузится "вслепую".

Обновись, все делается штатно...

Share this post


Link to post
Share on other sites
7 hours ago, tajson said:

Не понял, что за вопрос?

У меня все работает, и грузится не в слепую, как понять в слепую??

У меня 6.5 (Build 4564106). На N3150 в процессе загрузки изображение на экране перестает обновляться, хотя в целом все работает.

Для установки на флешку использовался обходной маневр с виртуальной машиной. Видимо, в новом релизе все исправили. Надо обновиться.

Share this post


Link to post
Share on other sites

Всем привет =)

Можно подсказать. EXSi 6.7.0. Ставлю по мануалу в начале этой темы, все проходит нормально до перезагрузки, после перезагрузки уже DiskStation не виден не в проге Synology Assistant ни в браузере. Те я не дохожу до скрина, где задается учетка рута и далее. Что может быть?

Share this post


Link to post
Share on other sites

В консоли должно быть видно где остановка. Скорее всего на загрузке.

Share this post


Link to post
Share on other sites
1 час назад, XPEH сказал:

В консоли должно быть видно где остановка. Скорее всего на загрузке.

а как это победить?)

Share this post


Link to post
Share on other sites

В зависимости от проблемы очевидно. По запросу " Помогите не работает, в чем проблема?" угадывать невозможно. Приведите больше деталей и шаг за шагом проблема и пути решения могут определиться.

Share this post


Link to post
Share on other sites
10 часов назад, Alex_White сказал:

а как это победить?)

 

Настройте com порт виртуалки на передачу информации в файл и смотрите в файле после запуска vm, где затык.  
5b10e7ba558f2_2018-06-0109-28-19.png.a1a6706a31587f212a0869f9cfd14dfe.png
Hide  

Share this post


Link to post
Share on other sites
В 01.06.2018 в 10:30, Olegin сказал:

 

Настройте com порт виртуалки на передачу информации в файл и смотрите в файле после запуска vm, где затык.

Прикрепил лог, особо в нем ничего не понял) Я менял кол-во процессоров, менял типы скайзи контроллеров, а также типы сетевых адаптеров - результат одинаков, машина в сети не появляется

Тут настройки с которыми удалось поставить XPenology, но до перезагрузки  

image.thumb.png.f50383f969ab3b106bcb04e07eb5c520.png

Hide  

 

serial (1).out

Share this post


Link to post
Share on other sites

Прошу прощения за свою невнимательность =)

Все оказалось гораздо проще

Нужно было использовать нужную версию DSM (из папки 15047), а я до этого пытался поставить DSM из папки 15254 

image.thumb.png.3fc5d5c08b4f1627c60d49552c76dcaa.png

Hide  

Share this post


Link to post
Share on other sites

обновил ESXi до 6.7 

ранее скачивал обновления, в этот раз для бесплатной версии скачать не получилось, пишут единственный вариант через консоль

https://www.vladan.fr/upgrade-esxi-6-x-to-6-7-via-cli-two-methods/

После обновления ВМ с DSM не запускалась, в логах: 

  • Power on failure messages: Module 'HV' power on failed.
  • The virtual machine cannot be powered on because virtual nested paging is not compatible with PCI passthru. To power on the VM either disable VHV or remove the passthru device(s).  If you wish to try this experimentally you can add vhv.allowPassthru=TRUE to your virtual machines config settings.

Ошибка связанна с проброшенным в ВМ контроллером LSI 9211. Другая ВМ с win 10 заработала без проблем.

Пробовал как написано добавлять параметр, в настройки ВМ, но при сохранении настроек появлялась другая ошибка. Попытка загуглить и поправить привела к третьей ошибке, которая вообще не гуглиться.

Проверял драйвера про которые пишут могут криво обновиться при переходе на 6.7 , команда из статьи выдает все Ok. В списке пакетов везде 6.7

Проверил редактирование настроек ВМ, вообще без никаких изменений, не сохраняет выдает одну из ошибок.

 

Подключился через WinSCP, нашел файл настроек ВМ и вписал руками в конец файла: 

vhv.allowPassthru = "TRUE"

Все заработало.

6.7 работает немного быстрее, один тест ранее максимум показывал 49.5 на esxi 6.5, после обновления 52.65

  • Like 1

Share this post


Link to post
Share on other sites

Залейте плиз рабочий комплект для 6.5, некак не могу побороть установку. Запускается, нажимаю инсталл, ребут и все, ни сканером не find ничего не находит.

Share this post


Link to post
Share on other sites
20 минут назад, LLC сказал:

Залейте плиз рабочий комплект для 6.5

Это что за зверь?

21 минуту назад, LLC сказал:

Запускается, нажимаю инсталл, ребут и все, ни сканером не find ничего не находит

Надеюсь в загрузчике при старте "VMWare/ESXI VERSION" выбирали?

Share this post


Link to post
Share on other sites

ova или три файлика для готовой виртуалки

И при первом старте и после перезагрузки выбираю VMWare/ESXI VERSION.

 

Share this post


Link to post
Share on other sites

Для какой версии нужен? Насколько помню в 3615 все есть, попробуйте для начала ее запустить ничего не меняя.

Share this post


Link to post
Share on other sites

А гдеж ее взять, если по ссылкам выше только synoboot.img ?

Share this post


Link to post
Share on other sites

В альфа версиях гдето валялось, зайдите по ссылке в топике про 6.2, там старые папки тоже доступны.

Share this post


Link to post
Share on other sites

Скопировал файлы, подключил ВМ. Ошибка сетевого адаптера, ничего в конфиге не редактируется, как из 19 сообщения этого топика.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.