Recommended Posts

HI! I have my xpenology up and running, but I'm trying to configure my ddns and I'm not able to do that. 

 

If I enter the NAS by the ip address ex: 98.13.78.14:5004 (I've change the main port) it goes perfectly. But it I try it by the domain of the ddns I couldn't. 

 

Why is happening this? Do you have any idea? Thanks in advance.

Link to post
Share on other sites
  • 2 weeks later...
On 10/26/2018 at 12:04 AM, adriaurora said:

HI! I have my xpenology up and running, but I'm trying to configure my ddns and I'm not able to do that. 

 

If I enter the NAS by the ip address ex: 98.13.78.14:5004 (I've change the main port) it goes perfectly. But it I try it by the domain of the ddns I couldn't. 

 

Why is happening this? Do you have any idea? Thanks in advance.

 

Have you tried removing the www. in front front of the domain name?

Try like this: http://yourname.ext - Don't use www.

Link to post
Share on other sites
  • 5 weeks later...

I'm not exactly sure what I'm doing wrong.  I setup my DDNS according to the tutorial using duckdns, it shows normal.  I port forwarded and using canyouseeme.org and it shows that it can see the port.  Yet, when I try to test the connection, I can't access my NAS.  Can anyone offer suggestions?  I'm a complete noob and have been searching google trying to find the answer, maybe someone here can offer a helping hand, thank you!

Link to post
Share on other sites
  • 4 weeks later...
  • 1 year later...
  • 4 months later...

Well thanks a lot guys for all the manuals and efforts, keep on the good work .

i did install and followed all the steps of Polanskiman till i tried to get access from my phone to the server >>> and when i put my user name and password i get inside the server without any problem but once i choose for fotos or videos don't get in but the app store get open for me to download DS photo >>>> ok i did but when i open the app cant login here im stuck

 

what do i do wrong ? can still we  use the synology apps with xpenology?

 

Thanks alot 

Link to post
Share on other sites
  • 3 months later...

Too bad  Duckdns  does not work anymore.    I have a Zyxel t50 router   only services to use are:   DydNS.com,  zoneedit.com   no-ip.com   dtdns.com and Freedns.afraid.org   but too bad the organisations that will exist yet, do give you another extention  (i.e.  no-ip.com  > you got  no-ip.org   so the only option is to use  user defined and that never works.

 

Schermafbeelding 2020-08-29 om 14.46.12.jpg

Link to post
Share on other sites
  • 1 month later...

Hola a todos, tengo un Synology ds216 y el acceso a él a través del puerto 80 funciona perfecto para mí, configurar Synology DDNS, en cambio tengo un 8-core más rápido con dsm 6.1.7 y no puedo conectarme a él, en una configuración de DDNS con No ip, en este equipo tengo cámaras y otras funciones y funcionan correctamente desde el exterior, pero no sé qué puede pasar con la estación web del puerto 80 internamente funciona externamente en este 8 núcleos no.

Link to post
Share on other sites
  • 3 months later...

Hi everyone, I just can't connect DDNS to DSM; I followed all the procedure indicated by Polanskiman which then seems to me to be the normal procedure for connecting to a DDNS service, especially if you have accounts with service providers already in the list, I've already done it several times with other synlogy 1813 and 1010 and the thing went well without many problems. I don't understand where the problem could be, I thought it was precisely because there are other synologies that run within the same LAN but from what I read it shouldn't be for this, so I don't know how to do it, can someone help me ??? thanks

Link to post
Share on other sites

 

Hi Flyride, we have already heard on other occasions, thanks for the reply, however I tried various providers that I am already registered with, no.ip.com, freedns, two.dns.de, and then I also wanted to register in dnsexit , duckdns, they all give me the same (generic) error I tried to follow Polanskiman's directions but nothing; I read that you use a little docker program, I also tried with those, many do not install one but I could not get it to work and view it on the browser. I am testing the various DSMs (the one I am talking about is a 5.2 baremetal, but the same problems I have also found in DSM 6.0.2 and 6.2.3 in virtual) because I have to get a new nas if expenology works correctly I do a nas from me (who are very much better than the original synology) otherwise I have to opt for a 1821+, nice machine but I repeat with the same money making you a nas you get a much, much better one. thanks

Link to post
Share on other sites

I'm sorry you are having so much trouble. Needless to say many people are successfully using DDNS, both the Synology client and others.  Keep at it and you will find a solution.  Some of the free options are problematic however.

 

For what it's worth, I am using this docker: https://hub.docker.com/r/80x86/ddns-updater

 

This is specifically because it has support for CloudFlare as my DDNS provider, as I use cloudflare to host my domains (I DDNS my home systems to one of my domains). But it supports a number of free and paid services.

 

image.thumb.png.937a7466436ed34bc9a2f341e0e28500.png

Link to post
Share on other sites

 

Hi Flyride yes I tried and tried again last night but nothing, I also tried with the docker program that you indicated to me but I can't configure it, this morning I tried to create a virtual machine by also changing the serial number provided by the application tool 142 in the grub file (I didn't do this before and thought it might be that the default serial number was blocked) but it doesn't work that way either. I have to work on it but if you assure me that it should work I'll have to find where the error is. Thanks in the meantim

Link to post
Share on other sites

i went through Polanskiman excellent tutorial and everything worked first time, thank you for that

 

after logging out i couldnt log in again, i was trying for ages with http://[yourdomain].duckdns.org:5000 or 5001

and https://[yourdomain].duckdns.org:5000 or 5001, ive opend my ports from 5000 to 5001, as in the tutorial

 

i uninstalled and reinstalled DS file from my mobile but that didnt do anything

 

i eventually tried [yourdomain].duckdns.org  with no http:// or https:// and no port number at the end

it signs in straight away, if i go back and sign in as https://[yourdomain].duckdns.org:5000 or 5001 it wont sign in

 

 

Link to post
Share on other sites

 

Hi Able, thanks for the answer, just last night after days of attempts they managed to work the DDNS through the docker 80x86 container (as indicated by flyride) and its registration with cloudflare, I had already tried with the indications from Polanskiman, at first sight not it doesn't seem very difficult the description is simple but it doesn't work for me; I just tried with the variations that you indicated to me but nothing, there is probably a small detail that escapes me (it also happened with 80x86 that I had to work on it for a week just because I didn't know cloudflare and I didn't know that from different tokens. ....), however you give access via DDNS I solved it at least in part it is clear that I would like to do it from DNS without using docker (which I think is better) but by the time I will work on it let's see if I can solve it . Thanks

Link to post
Share on other sites
  • 10 months later...

I think i've set things up correctly, i can ping my DuckDNS hostname successfully, and i can use it for DSM access, however i get rejected with port 1194. Should i be seeing something at this address, because the guide suggested attempting it to verify its succeeded. Same story when i tried with NoIP. I've watched a few YouTube tutorials and they all do something a little different.
I suspect that i need OpenVPN connect in order to perhaps see that port, but the guide doesnt clarify anything about other devices, and despite following YT videos where they've imported the modified .ovpn file, its being rejected on my Surface tablet, and my main PC is just flat out refusing to install it which apparently they havent a scoobydoo why that is and its been that way for 6yrs+ 

In the Connect profile, i have:
hostname.duckdns.org
UN = my google login addr

PW... i can only assume this is the huge 'token' on the Duck account page?

Yet that fails. So im a little confused and ive been looking high & low for the past 4hrs trying to figure it out.
Im pretty sure the DSM, Port Forwarding, Syn-Firewall side of things is correct (I hadnt added firewall until doing forwarding, and i can see port 5000 fine, as can an overseas mate). Im just a little lost as to whether i should be seeing something on port 1194 (i see nothing there via LAN or DDNS & port), and/or whether this Connect is the reason as it wasnt mentioned, but i see people doing it in videos... just racing through it without explaining what they're doing.

I dont like asking for help if its perfectly reasonable that can figure it out for myself, but all the guides seems to have some form of hole thats not giving me a full picture of what im experiencing.

Link to post
Share on other sites

Hi everyone great tutorial. Everything is work fine. 

here is my NAS MasterStudio

I have very important question.
How to login with DS file or DS photo? I cant login with masterstudio.ddns.net, i want to use wiht mobile data or another wifi network. Now only work with direct ip with home network.

Edited by GeriHDHUN
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.