XPEnology on hp MicroServer Gen10


Recommended Posts

well, likely not any time soon. AMD Opteron X3216  features Zen core, and itself is an APU with Radeon VEGA.   Not only the current version of boot loader doesn't support AMD CPU yet,  there is likely no support of the graphics portion of the APU as well. 

Link to post
Share on other sites
On 6/27/2017 at 1:45 PM, hpk said:

Thanks ... so I'll go for a Gen8 with Xeon processor and ILO port ...

 

Actually going with Gen8 might be better two fold reason - you can upgrade the CPU plus the lack of ILO on the new Gen10 and not to mention its cheaper now (gen8)

Link to post
Share on other sites
  • 1 month later...
  • 5 weeks later...
  • 1 month later...
On 9/14/2017 at 11:04 PM, hpk said:

yes, works like a charm ... 

 

Hi, could you give me more details about your config? I am planning to buy one of these servers and I would like to install DSM baremetal. If is not possible, I will try with ESXi.

 

Where do you store the VMs in ESXI? Do you have a SSD in the 5th SATA port? Is it possible to install ESXi on a USB stick using the interal connector?

Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...

Hi Michael,

 

Yes, I am using the HPE Gen10 microserver. The steps I did before installing DSM were:

1. Boot the server, entered bios and copied the MAC addresses of the 2 network cards.

2. Found the PID and VID of the usb

3. Mounted the img file from 1.02b and updated the MACs

4. With WIn32DiskImages I wrote the loader on a USB and put it in the internal slot.

5. Started the server and installed DSM. The pat file was 6.1.4 and after everything was done I installed the latest update at that time, update 2.

  • Like 1
Link to post
Share on other sites
  • 1 month later...
On 12/18/2017 at 12:48 AM, neobluenet said:

Hi Michael,

 

Yes, I am using the HPE Gen10 microserver. The steps I did before installing DSM were:

1. Boot the server, entered bios and copied the MAC addresses of the 2 network cards.

2. Found the PID and VID of the usb

3. Mounted the img file from 1.02b and updated the MACs

4. With WIn32DiskImages I wrote the loader on a USB and put it in the internal slot.

5. Started the server and installed DSM. The pat file was 6.1.4 and after everything was done I installed the latest update at that time, update 2.

Hi Neobluenet,

 

I am looking at purchasing the Gen10 as an alternative for building on XPEnology box from scratch. I'm not new to Synology, but new to using XPEnology.  I know this thread is a few months old, but can you elaborate on your steps above, e.g., the need to find the PID and VID as well as updating the MACs?  If this is documented somewhere else, please let me know and I will review.

 

Thanks in advance for the post and follow-up

Link to post
Share on other sites
On 2/5/2018 at 6:37 AM, IT_Informant said:

Hi Neobluenet,

 

I am looking at purchasing the Gen10 as an alternative for building on XPEnology box from scratch. I'm not new to Synology, but new to using XPEnology.  I know this thread is a few months old, but can you elaborate on your steps above, e.g., the need to find the PID and VID as well as updating the MACs?  If this is documented somewhere else, please let me know and I will review.

 

Thanks in advance for the post and follow-up

 

It is documented in the FAQs section of this forum which point to the proper tutorials.

Link to post
Share on other sites
  • 2 weeks later...
  • 7 months later...
  • 3 weeks later...
  • 1 month later...
  • 4 weeks later...

Gen 10 x3421 - 8Gb, AMD SVM in BIOS is on.

installed  bootloader 1.04  918+ 6.2.1 Updated 2, work fine but VMM do not work.

installed  bootloader 1.02b  3615xs on 6.1.7 and 6.2 (6.2.1 fails),  work fine but VMM do not work.

2 NIC connected fine. VirSwitch is on. 

 

1. Error starting VM:  Failed to power on the virtual machine  on the host due to insufficient RAM on the host

2. find / -name kvm* gives that No kvm-amd.ko in the system.

3. Errors Is logs:

Failed to open /dev/net/tun

Failed to create tap device

Failed to start NI

 

Can someone HELP to fix kernel for AMD support please?

 

 in /var/log/messages:

2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: MemSize: ccc/reservation.cpp:900 Start to op(3), fd16a28d-a5f7-446f-b14a-ab188407a85e: [{}] -> [{"vram_size":1426063360}]
2018-12-28T11:52:29+03:00 FS synoccc_guestd[18266]: ccc/reservation.cpp:137 locked /dev/virtualization/libvirt/qemu/syno.qemu_back_mem.fd16a28d-a5f7-446f-b14a-ab188407a85e size: 1426063360
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: CpuCore: ccc/reservation.cpp:900 Start to op(3), fd16a28d-a5f7-446f-b14a-ab188407a85e: [{}] -> [{"cpu_pin_num":0,"cpu_weight":256,"vcpu_num":1}]
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: CpuCore: ccc/reservation.cpp:1181 CPU cores utilization, total: 2 * 4, sum of vcpu used: 1, sum of cpu pin reserved: 0, want vcpu: 1, want cpu reserv
ed: 0
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: ccc/vnic.cpp:581 Failed to open /dev/net/tun
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: ccc/vnic.cpp:1190 Failed to create tap device
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: ccc/guest.cpp:70 Failed to start NIC [230572df-a2c3-4e51-a251-89ea0adea490]
2018-12-28T11:52:29+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: ccc/guest.cpp:2078 Failed to start nic
2018-12-28T11:52:30+03:00 FS synoccc_guestd[18266]: ccc/reservation.cpp:105 un-locked /dev/virtualization/libvirt/qemu/syno.qemu_back_mem.fd16a28d-a5f7-446f-b14a-ab188407a85e
2018-12-28T11:52:30+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: CpuCore: ccc/reservation.cpp:1181 CPU cores utilization, total: 2 * 4, sum of vcpu used: 0, sum of cpu pin reserved: 0, want vcpu: -1, want cpu reser
ved: 0
2018-12-28T11:52:30+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: ccc/guest.cpp:2573 Failed to prepare for guest [fd16a28d-a5f7-446f-b14a-ab188407a85e]
2018-12-28T11:52:33+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: Guest/guest.cpp:4955 Failed creating guest [fd16a28d-a5f7-446f-b14a-ab188407a85e] reason [-4]
2018-12-28T11:52:33+03:00 FS synoscgi_SYNO.Virtualization.Guest.Action_1_pwr_ctl[7623]: guest_action.cpp:207 Bad response [{"error":{"code":903},"httpd_restart":false,"success":false}]/ request [{"api":"SYNO.CCC.Guest","guest_id":"fd16a2
8d-a5f7-446f-b14a-ab188407a85e","method":"poweron","version":1}]

r

Edited by Polanskiman
Use code tags please!
Link to post
Share on other sites
  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.