Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.0.2 (Jun's loader)

Recommended Posts

I followed the turorial, but synology assistant can't find my N54L

 

Someone in the same situation with same hardware ??

Do I need soem especific drivers in the USB ??

 

I just mod my VID/VID as said in the tuto on grub.cfg

Share this post


Link to post
Share on other sites

I got my N54L running now. Needed to set boot menu Timeout to 5 sec, in order to see and select AMD boot option. Without selecting AMD boot, machine does not show up on network at all.

 

Did not use any Sata port setting. Runs fine now!

Edited by Guest

Share this post


Link to post
Share on other sites

This is when you set the SataPortMap= not correct!

In my case this was the problem.

 

I followed the turorial, but synology assistant can't find my N54L

 

Someone in the same situation with same hardware ??

Do I need soem especific drivers in the USB ??

 

I just mod my VID/VID as said in the tuto on grub.cfg

Share this post


Link to post
Share on other sites
I followed the turorial, but synology assistant can't find my N54L

 

Someone in the same situation with same hardware ??

Do I need soem especific drivers in the USB ??

 

I just mod my VID/VID as said in the tuto on grub.cfg

 

The N54L is an AMD based machine if I not wrong.

 

When you reach the boot menu you need to be very quick and use your keyboard to select the appropriate boot install selection (AMD).

 

You can also change the timining in the grub.cfg file by changing the timeout=1 to something like timeout=3 so to give you some time at the boot menu.

 

Other people have been able to install DSM 6.0 on that machine so I don't see why you couldn't.

 

Although not strictly necessary I recommend you change your mac to match your NIC's real mac address or at least to the MAC address you used to use before with dsm 5.2

 

Check your router as well to make sure your dhcp server attributed an IP to your machine. If an IP was attributed then the problem might come from your network. If it didn't then it's coming from the machine itself or the grub.cfg configuration.

 

As a last resort you could also reset your bios to default.

Edited by Guest

Share this post


Link to post
Share on other sites
This is when you set the SataPortMap= not correct!

In my case this was the problem.

 

I followed the turorial, but synology assistant can't find my N54L

 

Someone in the same situation with same hardware ??

Do I need soem especific drivers in the USB ??

 

I just mod my VID/VID as said in the tuto on grub.cfg

 

Not sure this is the case. He can't see the machine on the network. So this is a network/mac related issue in principle. If you are using Jun's latest loader there is no need to use sataportmap= but it might be necessary if you get an error during the installation that says something along the lines: "hard drive and sata ports disabled"

Share this post


Link to post
Share on other sites

Hello, I have a HP Proliant G8 and i'm trying update from DSM 5.2 to 6.0.

 

I can see the advise:

 

'early consol in decompress_kernel

Decompressing Linux.. Parsing ELF… done.

Booting the kernel.'

 

but i cannot find my NAS by any way. The note 1 of the tutorial says:

 

'Note 1: If after following the tutorial you can’t find your NAS through http://find.synology.com ou Synology Assistant it is highly possible that the drivers of your NIC are not included in the ramdisk of the loader. In doubt, just ask.'

 

But

1.- which are 'the drivers of my NIC'?

2.- how can i include the drivers in the ramdisk of the loader?

 

Thanks

Share this post


Link to post
Share on other sites

On my n54l I cannot boot. I set the time delay to 5 but all I get is a monitor off after the BIOS lines. No choices, no nothing. I think I've done it all, except I cannot find any serial port in the BIOS. Also, I see there is an EFI partition in the USB boot drive. Maybe this machine can only boot from MBR flash USB drives?. ANy ideas?.

Share this post


Link to post
Share on other sites

I cant boot my HP Gen8, do I have to change anything else in bios?

 

it's on AHCI, but the pendrive does not boot.

entered vip, pid, sn, mac in jun's 1.0.1 loader while mounted the img with OSFMount (because I cant access / or see the partitions on the pendrive after writing the img file with Win32DiskImager)

 

The old (5.2) bootloader worked like a charm before with this setup.

Share this post


Link to post
Share on other sites
Hello, I have a HP Proliant G8 and i'm trying update from DSM 5.2 to 6.0.

 

I can see the advise:

 

'early consol in decompress_kernel

Decompressing Linux.. Parsing ELF… done.

Booting the kernel.'

 

but i cannot find my NAS by any way. The note 1 of the tutorial says:

 

'Note 1: If after following the tutorial you can’t find your NAS through http://find.synology.com ou Synology Assistant it is highly possible that the drivers of your NIC are not included in the ramdisk of the loader. In doubt, just ask.'

 

But

1.- which are 'the drivers of my NIC'?

2.- how can i include the drivers in the ramdisk of the loader?

 

Thanks

 

Since you have the HP Gen8 you shouldn't need any other drivers as some other people have been able to make the upgrade to DSM 6.0 with that machine. Have a look at the main thread.

 

Are you using the latest loader v1.01? There could actually be other reasons why you can't see the NAS on the network. The tutorial was made some weeks ago and things have evolved fast since then.

 

Strictly speaking you can't just include drivers to the ramdisk. You need to compile the source code first to produce the modules. That's something best left to those who know what they are doing namely, Jun, Trantor, Arcao and some others here who have the skills and time. It's technically involved.

 

Don't want to push you away though if you feel like trying there are some guidelines in the main thread and google on how to.

Share this post


Link to post
Share on other sites
mattail said:
I have an asrock E3C236D2I MB with 2 NICs - Intel i210 + Intel i219.

Are these supported?

 

The I219 in principle yes >>> https://xpenology.com/forum/topic/6253-dsm-6xx-loader/?do=findComment&comment=55612 and https://xpenology.com/forum/topic/6253-dsm-6xx-loader/?do=findComment&comment=55720

 

All those drivers listed in the posts were added to Jun's loader v.1.0 and V1.01

Share this post


Link to post
Share on other sites
On my n54l I cannot boot. I set the time delay to 5 but all I get is a monitor off after the BIOS lines. No choices, no nothing. I think I've done it all, except I cannot find any serial port in the BIOS. Also, I see there is an EFI partition in the USB boot drive. Maybe this machine can only boot from MBR flash USB drives?. ANy ideas?.

 

As far as I know the N54L is a BIOS machine not UEFI. Nonetheless, the loader is a hydrid loader made for UEFI and Bios MOBOs. Are you using the latest loader v.1.01? Try to burn the loader on the USB again and/or change USB key. I have seen some reports where people had dysfunctional USB keys and nothing was showing up.

 

Make sure your bios is configured to AHCI.

 

A BIOS reset sometimes helps.

 

To re-assure you though other people have been able to install DSM 6.0 on a HP N54L so I don't see why you wouldn't be able to do the same.

Edited by Guest

Share this post


Link to post
Share on other sites
I cant boot my HP Gen8, do I have to change anything else in bios?

 

it's on AHCI, but the pendrive does not boot.

entered vip, pid, sn, mac in jun's 1.0.1 loader while mounted the img with OSFMount (because I cant access / or see the partitions on the pendrive after writing the img file with Win32DiskImager)

 

The old (5.2) bootloader worked like a charm before with this setup.

 

When you mount your USB key with OSFMount make sure you un-tick the "Read-only Drive" box, else any changes will not be saved to the grub file once you dismount the key.

 

The Loader's image made by Setsunakawa and Arcao were made using an MBR partition table. That's the reason why you were able to edit it directly with your file explorer without the need of a third party software. In Win 10 you can access the pen drive without any 3rd party software.

Share this post


Link to post
Share on other sites
I cant boot my HP Gen8, do I have to change anything else in bios?

 

it's on AHCI, but the pendrive does not boot.

entered vip, pid, sn, mac in jun's 1.0.1 loader while mounted the img with OSFMount (because I cant access / or see the partitions on the pendrive after writing the img file with Win32DiskImager)

 

The old (5.2) bootloader worked like a charm before with this setup.

 

When you mount your USB key with OSFMount make sure you un-tick the "Read-only Drive" box, else any changes will not be saved to the grub file once you dismount the key.

 

The Loader's image made by Setsunakawa and Arcao were made using an MBR partition table. That's the reason why you were able to edit it directly with your file explorer without the need of a third party software. In Win 10 you can access the pen drive without any 3rd party software.

 

I tried with 2 different usb keys but it can't boot from them (the grub doest even show up).

Tried to copy with Win32DiskImager and with rufus too.. after the dd finished I cant access my pendrive, not in my Win10 or with my mac. (I see the pendrive under disk utility without any partition)

Share this post


Link to post
Share on other sites

I'm a huge stupid :shock::shock:

 

After succesuflly update my N54L to 6.0 and have all in place (I created a new USB key and reserved my old one) , I just wanted to know what would happen if I boot again with the old USB with old boot (The new one if extremely spartan and they do not show progress or anything)

 

The booting process showed some missing files and several "updating files bla bla bla ...."

 

Now I can't access to mi N54L

 

Synology assistan find it, but cant open web or anything.

 

Of course I switched again the old USB key with the new one with new loader (created in the update process), but it seems something has changed in my hard disks, and i cant login to xpenology (SSH o WEB, no matter what).

 

Then I tried to change option in boot to Force Install o Reinstall, but the only option that shows my N54L in synology assistant is the AMD option at the boot

 

HELP !!! :cry::cry::cry:

Share this post


Link to post
Share on other sites
I cant boot my HP Gen8, do I have to change anything else in bios?

 

it's on AHCI, but the pendrive does not boot.

entered vip, pid, sn, mac in jun's 1.0.1 loader while mounted the img with OSFMount (because I cant access / or see the partitions on the pendrive after writing the img file with Win32DiskImager)

 

The old (5.2) bootloader worked like a charm before with this setup.

 

When you mount your USB key with OSFMount make sure you un-tick the "Read-only Drive" box, else any changes will not be saved to the grub file once you dismount the key.

 

The Loader's image made by Setsunakawa and Arcao were made using an MBR partition table. That's the reason why you were able to edit it directly with your file explorer without the need of a third party software. In Win 10 you can access the pen drive without any 3rd party software.

 

I tried with 2 different usb keys but it can't boot from them (the grub doest even show up).

Tried to copy with Win32DiskImager and with rufus too.. after the dd finished I cant access my pendrive, not in my Win10 or with my mac. (I see the pendrive under disk utility without any partition)

 

You wont be able to see it on Mac OS either. You need to issue the following commands:

 

diskutil list

this should bring the list of disks available. In my case it's:

/dev/disk0 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *640.1 GB   disk0
  1:                        EFI EFI                     209.7 MB   disk0s1
  2:                  Apple_HFS El Cap_TESTING_ENVIR... 214.1 GB   disk0s2
  3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
  4:                  Apple_HFS El Capitan              424.5 GB   disk0s4
  5:                 Apple_Boot Recovery HD             650.0 MB   disk0s5
/dev/disk1 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *640.1 GB   disk1
  1:                        EFI EFI                     209.7 MB   disk1s1
  2:                  Apple_HFS Mac 1                   639.8 GB   disk1s2
/dev/disk2 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *2.0 TB     disk2
  1:                        EFI EFI                     209.7 MB   disk2s1
  2:                  Apple_HFS Backup_OSX              1000.0 GB  disk2s2
  3:                  Apple_HFS Backup_DATA             999.9 GB   disk2s3
/dev/disk3 (external, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:      GUID_partition_scheme                        *4.0 GB     disk3
  1:                        EFI NO NAME                 31.5 MB    disk3s1
  2:           Linux Filesystem                         15.7 MB    disk3s2
  3:        Bios Boot Partition                         4.2 MB     disk3s3

 

find the EFI disk of the USB key. Mine is disk3s1 as you can see above. Then issue:

mkdir /Volumes/efi

followed by

sudo mount -t msdos /dev/disk3s1 /Volumes/efi

 

Note I have used disk3s1 in my last command. Your disk ID might not be the same so pay attention to what you are doing.

Share this post


Link to post
Share on other sites

Thanks, i can access the efi partition this way.

So it looks like this part is okay: the grub.cfg has all the neccessary update

 

I have changed to SataPortMap=4 , i have 4 disk in my Gen8, is this okay?

The Gen8 wont boot from this pendrive :sad: where can i change to boot from UEFI?

Share this post


Link to post
Share on other sites
Thanks, i can access the efi partition this way.

So it looks like this part is okay: the grub.cfg has all the neccessary update

 

I have changed to SataPortMap=4 , i have 4 disk in my Gen8, is this okay?

The Gen8 wont boot from this pendrive :sad: where can i change to boot from UEFI?

 

Make sure you are able to boot from a usb key. You need to check in the bios that this feature is enabled.

 

Yes sataportmap=4 should be fine if you have 4 drives.

 

A bios reset somtimes help.

Share this post


Link to post
Share on other sites
On my n54l I cannot boot. I set the time delay to 5 but all I get is a monitor off after the BIOS lines. No choices, no nothing. I think I've done it all, except I cannot find any serial port in the BIOS. Also, I see there is an EFI partition in the USB boot drive. Maybe this machine can only boot from MBR flash USB drives?. ANy ideas?.

 

As far as I know the N54L is a BIOS machine not UEFI. Nonetheless, the loader is a hydrid loader made for UEFI and Bios MOBOs. Are you using the latest loader v.1.01? Try to burn the loader on the USB again and/or change USB key. I have seen some reports where people had dysfunctional USB keys and nothing was showing up.

 

Make sure your bios is configured to AHCI.

 

A BIOS reset sometimes helps.

 

To re-assure you though other people have been able to install DSM 6.0 on a HP N54L so I don't see why you wouldn't be able to do the same.

 

Tried three different flash drives, and did a BIOS reset. No way. Black screen. My n54l is running 5.2 with no problems.

Share this post


Link to post
Share on other sites

I still cant boot the i tested already with my HP Microserver Gen8 (doesnt have uefi, just legacy)

Any idea?

Share this post


Link to post
Share on other sites

Fully remove 'sataportmap=xx' comment? See what it does?

 

Also make sure in BIOS setting for USB drive is on HDD-emulation, not AUTO etc.

Edited by Guest

Share this post


Link to post
Share on other sites
I still cant boot the i tested already with my HP Microserver Gen8 (doesnt have uefi, just legacy)

Any idea?

 

It was a pendrive faults, i dont know why, totaly working pendrives just dont boot in microserver, the 4th just started booting, ..

Share this post


Link to post
Share on other sites
On my n54l I cannot boot. I set the time delay to 5 but all I get is a monitor off after the BIOS lines. No choices, no nothing. I think I've done it all, except I cannot find any serial port in the BIOS. Also, I see there is an EFI partition in the USB boot drive. Maybe this machine can only boot from MBR flash USB drives?. ANy ideas?.

 

As far as I know the N54L is a BIOS machine not UEFI. Nonetheless, the loader is a hydrid loader made for UEFI and Bios MOBOs. Are you using the latest loader v.1.01? Try to burn the loader on the USB again and/or change USB key. I have seen some reports where people had dysfunctional USB keys and nothing was showing up.

 

Make sure your bios is configured to AHCI.

 

A BIOS reset sometimes helps.

 

To re-assure you though other people have been able to install DSM 6.0 on a HP N54L so I don't see why you wouldn't be able to do the same.

 

Tried three different flash drives, and did a BIOS reset. No way. Black screen. My n54l is running 5.2 with no problems.

 

Modified vid/pid?

 

What burning software are you using?

 

Is your monitor plugged directly to the serial port and not some other port?

 

It might be coming from a config issue in your bios. Make sure your serial is activate in bios. Also make sure usb key is set to be bootable from bios.

Share this post


Link to post
Share on other sites

I used the win32imager. Works well with the usb drive in version 5.2. My monitor is plugged to the VGA port. The n54l has no serial port, and I cannot find nothing about a serial port in my BIOS. When booting 5.2 I can see all the linux lines coming out to the screen, so the VGA port works when booting. I am booting now from usb because the n54l is being used with v.5.2, so the USB drive it is the booting disk. What do you mean by "Make sure your serial is activate in bios"?.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.