Polanskiman

Tutorial: Install/Migrate DSM 5.2 to 6.0.2 (Jun's loader)

Recommended Posts

And i got all 16 drives back, But slot 1-4 is still empty so drive numbering starts at 5 and end at 20.

Question is, what is it that tells DSM what number a drives has. What port is taking up those 4 slots.

 

what ever it is it shoud be found in /var/log/messages, dsm has to start a driver and recognise ports for storage

 

I think i found what i was looking for but unsure, Can you confirm?

It starts at "port-5:0" so i guess thats why DSM starts with "Disk 5" instead of 1?

Question now is how i can modify the configuration to start at port 1 and if it's even possible.

 

Edit: Btw, I forgott but last night i had problems with one drive dropping out completley after i rebooted the machine.

Pulled it and inserted it again, no go in DSM. Looked in dmesg and i could see the drive apear.

i Found out it was DSM that moved the drive from number 20 to 21 so i had to change the synoinfo valus again to include that drive, and BAM! the drive was back and i had to rebuild the raid.

So now it shows Drive 6 to 21.....

 

Should i edit the sataportmap maybe? In that case, What would be a good value to start with?

 

/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:0/end_device-5:0/target5:0:0/5:0:0:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:1/end_device-5:1/target5:0:1/5:0:1:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:2/end_device-5:2/target5:0:2/5:0:2:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:3/end_device-5:3/target5:0:3/5:0:3:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:4/end_device-5:4/target5:0:4/5:0:4:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:5/end_device-5:5/target5:0:5/5:0:5:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:6/end_device-5:6/target5:0:6/5:0:6:0
/devices/pci0000:00/0000:00:03.0/0000:02:00.0/host5/port-5:7/end_device-5:7/target5:0:7/5:0:7:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:0/end_device-6:0/target6:0:0/6:0:0:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:1/end_device-6:1/target6:0:1/6:0:1:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:2/end_device-6:2/target6:0:2/6:0:2:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:3/end_device-6:3/target6:0:3/6:0:3:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:4/end_device-6:4/target6:0:4/6:0:4:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:5/end_device-6:5/target6:0:5/6:0:5:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:6/end_device-6:6/target6:0:6/6:0:6:0
/devices/pci0000:00/0000:00:07.0/0000:03:00.0/host6/port-6:7/end_device-6:7/target6:0:7/6:0:7:0

 

Any sugestions on this yet?

Share this post


Link to post
Share on other sites

Polanskiman thank you for trying to help! Ok, so...

my cpu is Intel Pentium E8500

my mobo is MSI P6NGM

i have 2x2gb kingston ddr2 667mhz

1x 500gb wd blue

1x 120gb kingston hyperx ssd

gpu is nVidia gt210 but I don't need it, its just there to see the screen, but I will take it out when I finish this setup.

 

Waiting for your instructions :smile:

 

EDIT: I also booted up windows 10 install just to format both drives in the "nas" so there are no problems with upgradeing etc...

Share this post


Link to post
Share on other sites
Polanskiman thank you for trying to help! Ok, so...

my cpu is Intel Pentium E8500

my mobo is MSI P6NGM

i have 2x2gb kingston ddr2 667mhz

1x 500gb wd blue

1x 120gb kingston hyperx ssd

gpu is nVidia gt210 but I don't need it, its just there to see the screen, but I will take it out when I finish this setup.

 

Waiting for your instructions :smile:

 

EDIT: I also booted up windows 10 install just to format both drives in the "nas" so there are no problems with upgradeing etc...

 

Your MSI P6NGM has a Realtek PHY 8201CL that needs the 8139too.ko module and it is not included in the loader.

Assuming you are using the loader v1.01, can you please replace the extra.lzma ramdisk in the loader with this one and try installing again?

https://mega.nz/#!HRJQGbhA!moPPC7fRCn-4 ... E8SaazHDg8

Please revert whether it works or not.

Share this post


Link to post
Share on other sites

THANK YOU POLANSKIMAN!!!!

 

Ofcourse I will try it right away, I'm on vaication this week so ill be working on this the whole day, and its 11AM allready :razz:

 

Should I do a clean install/boot or should I first install and boot 5.2 and then try to boot as you sugest?

Share this post


Link to post
Share on other sites
THANK YOU POLANSKIMAN!!!!

 

Ofcourse I will try it right away, I'm on vaication this week so ill be working on this the whole day, and its 11AM allready :razz:

 

Should I do a clean install/boot or should I first install and boot 5.2 and then try to boot as you sugest?

 

If you have no data or previous system to migrate there is no reason to install 5.2. Just install straight 6.0.2 with the loader v1.01

Share this post


Link to post
Share on other sites

IT WORKS!!!

 

Thank you a milion times Polanskiman!!!!!! THANK YOU!!!!

 

I am verry happy now, please PM me your paypal I would like to donate a couple of bucks to you, I don't have much but you deserve it!

Share this post


Link to post
Share on other sites
IT WORKS!!!

 

Thank you a milion times Polanskiman!!!!!! THANK YOU!!!!

 

I am verry happy now, please PM me your paypal I would like to donate a couple of bucks to you, I don't have much but you deserve it!

 

Happy it does. No worries about the money. I do it to help and my repayment is that you are satisfied. Enjoy.

Note: please disable the automatic update of DSM and DO NOT update to 6.1 or 6.1.1. You can do all the minor updates up to Update 11 but don't go any further.

Share this post


Link to post
Share on other sites

Hi guys, so I did a quick search and it looks like (from previous posts) the Broadcom NetXtreme® 5709 Dual Port Gigabit Ethernet driver is supposed to be in the loader but I'm not able to get it to work on a bare metal Dell R510 using V1.02A2 of the loader.

 

I stuck in another NIC (another older Broadcom) and it detected it in assistant just fine but the internal Broadcoms aren't recognized (so I'm pretty sure it's something with internal adapter compatibility).

 

If anyone has any advice or can confirm that the 5709 is actually included that would be a big help.

 

Thanks!!

Share this post


Link to post
Share on other sites

thank you

 

i'm getting this message dsm cannot start up normally :sad: every things looks fine since i'm using DSM 6.0.2-8451 but after 3 days of up time i'm now getting that message

Share this post


Link to post
Share on other sites
should i update via each updates or all the fixers are in update 8 fine to use ?

 

Each update is incremental, meaning it contains the fixes of previous updates. The latest is update 11 which is safe to apply.

Share this post


Link to post
Share on other sites

Hi All - Change Log 2 says that the Broadcom NetXtremeII BCM5706/BCM5708/5709/5716 is included, any idea why it does not recognize the NICs?

I have this on a bare metal Dell box with the 5709 Dual adapter, but I can only get it to recognize an add-in old school NIC.

 

Thx

Share this post


Link to post
Share on other sites

Hi i have the same issue, with a t3 driver needed.

 

I've a Tigon3, but the 1.01 doesn't include the t3 driver. How to include it? Thanks!!

 

eth0: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 

 

Polanskiman thank you for trying to help! Ok, so...

my cpu is Intel Pentium E8500

my mobo is MSI P6NGM

i have 2x2gb kingston ddr2 667mhz

1x 500gb wd blue

1x 120gb kingston hyperx ssd

gpu is nVidia gt210 but I don't need it, its just there to see the screen, but I will take it out when I finish this setup.

 

Waiting for your instructions :smile:

 

EDIT: I also booted up windows 10 install just to format both drives in the "nas" so there are no problems with upgradeing etc...

 

Your MSI P6NGM has a Realtek PHY 8201CL that needs the 8139too.ko module and it is not included in the loader.

Assuming you are using the loader v1.01, can you please replace the extra.lzma ramdisk in the loader with this one and try installing again?

https://mega.nz/#!HRJQGbhA!moPPC7fRCn-4 ... E8SaazHDg8

Please revert whether it works or not.

Share this post


Link to post
Share on other sites
so update 6.0.3-8754 is now out can we update or not?

 

I haven't tested it yet but I think it will not be possible. Those who have tried so far ended up having a bricked box.

Share this post


Link to post
Share on other sites

For those who have tried and failed with update 12 (6.0.3-8754), did you try reimaging your usb?

 

I only updated from 5.2 to 6.0 update 11, 2 days ago and I thought my device was bricked until I remembered to reimage and I was happy again.

 

banhuk

Share this post


Link to post
Share on other sites

Hello,

 

What do you mean by "reimage" ? Change the PID/VID/Mac ?

 

Just bricked mine by not beeing cautious enough (last backup last night), can't even see the machine on the network.

 

Any idea ?

 

eJules

Share this post


Link to post
Share on other sites
pauldiaz said:
so update 6.0.3-8754 is now out can we update or not?

No. Read below.

banhuk said:
For those who have tried and failed with update 12 (6.0.3-8754), did you try reimaging your usb?

 

I only updated from 5.2 to 6.0 update 11, 2 days ago and I thought my device was bricked until I remembered to reimage and I was happy again.

 

banhuk

6.0.3-8754 is not update 12 and is definitely not a minor update. Re-imaging the USB key will have no effect whatsoever on the outcome.

eJules said:
Hello,

 

What do you mean by "reimage" ? Change the PID/VID/Mac ?

 

Just bricked mine by not beeing cautious enough (last backup last night), can't even see the machine on the network.

 

Any idea ?

 

eJules

DSM 6.0.3-8754 WILL NOT work with loader v1.01 as this is not some trivial minor update. Although the kernel is the same version (3.10.77) as 6.0.2, the kernel was recompiled by Synology and there has been enough changes in the code for the loader not to work as is. Looking at the logs I can see that some modules are failing to load which is a clear sign that the kernel includes some changes.

 

DO NOT UPDATE TO DSM 6.0.3-8754 or you will have a bricked box in a recoverable loop state from which you won't be able to come out. The only way as far I can tell is to either wipe the system partition and then reinstall 6.0.2 or access the system partition through a Live Ubuntu USB key and modify the version file to then be able to reinstall 6.0.2. You can try this with no warranties: https://xpenology.com/forum/topic/7004-tutorial-how-to-access-dsms-data-system-partitions/

Also, search the forum extensively before attempting anything.

Share this post


Link to post
Share on other sites
CITmAn said:
Hi guys, so I did a quick search and it looks like (from previous posts) the Broadcom NetXtreme® 5709 Dual Port Gigabit Ethernet driver is supposed to be in the loader but I'm not able to get it to work on a bare metal Dell R510 using V1.02A2 of the loader.

 

I stuck in another NIC (another older Broadcom) and it detected it in assistant just fine but the internal Broadcoms aren't recognized (so I'm pretty sure it's something with internal adapter compatibility).

 

If anyone has any advice or can confirm that the 5709 is actually included that would be a big help.

 

Thanks!!

Hello and welcome to the forum

Not sure if you noticed but this is a tutorial for DSM 5.2 to 6.0 loader v1.01, not v1.02a2.

What you are asking is beyond this tutorial. In the future please use the search function prior posting.

 

Now to answer your question, the reason I believe it's not working is because there is a missing firmware in v1.02a/v1.02a2 for that NIC. I compiled the firmware for 3615xs but not for 3617xs (you can read here >>> https://xpenology.com/forum/topic/6253-dsm-6xx-loader/?do=findComment&comment=68662). Using v1.02a (3615xs) for you could be a temporary solution although you wont get the full capacity of your machine with that loader. You would need v.102a2 (3617xs). I might compile the firmware for that loader later.

 

CITmAn said:
Hi All - Change Log 2 says that the Broadcom NetXtremeII BCM5706/BCM5708/5709/5716 is included, any idea why it does not recognize the NICs?

I have this on a bare metal Dell box with the 5709 Dual adapter, but I can only get it to recognize an add-in old school NIC.

 

Thx

You are quoting the log for v1.01. It does not directly apply to v.1.02a2 although the module is included in v.1.02a2. What is missing is the firmware. Read above.

Share this post


Link to post
Share on other sites
Hi i have the same issue, with a t3 driver needed.

 

I've a Tigon3, but the 1.01 doesn't include the t3 driver. How to include it? Thanks!!

 

eth0: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 

 

tg3 module is included. What issue do you have?

Share this post


Link to post
Share on other sites

Thank you so much for your reply and for the information. I'm really just getting the hang of this so I do appreciate your patience.

I will keep an eye out for 3617xs firmware in the future. Also thanks for all you do. :grin:

Share this post


Link to post
Share on other sites

I try tu update 5.2 to 6.0. When i start uploading pat file i have error 16 (not enough system space to make update). On dev/root i have only 63mb free space and I think this is the problem. I delete logs but still to low free space. I have a Plex, maybe is the problem? I dont wont make clean install, what should I delete?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.