Pinocchio

RAID 6 - Plus d'accès aux données

Recommended Posts

Bonjour à tous,

Si je viens vers vous aujourd'hui, c'est pour demander votre aide.
Je vais essayer d'être le plus clair possible dans mon explication.

 

Par souci de compatibilité, le driver de ma carte PCI 2 x 4 ports SATA ne fonctionne que sur Windows, j’utilise donc un WS2012 R2 avec Hyper-V, installé sur deux SSD en RAID 1 (via BIOS CM Asus).
Il n'y a donc pas support S.M.A.R.T. pour les HDD.  J’ai 8 HDD branchés sur la carte PCI, ainsi que 2 HDD et 2 SSD sur la carte mère.

Le « NAS » a fonctionné pendant environ 8 mois, avec l’utilisation d’un RAID 6 de 10 HDD sous DSM 5.2-5644 Update 5.

Un jour, un disque a disparu du système. Après plusieurs redémarrage il est revenu mais avec un problème : file system error. J’ai donc formaté le HDD pour le réinsérer dans le RAID. Sauf que, quand j’ai enlevé le HDD, l’erreur s’est répercutée sur tous les HDD du RAID.
Sans surprise, à la fin de la reconstruction, tous les HDD ont gardé cette erreur.
Via l’interface DSM, j’ai essayé de cliquer sur « réparé », plusieurs tentatives en vain..

Après quelques recherches et conscient de la limite de mes connaissances en Linux, j’avais accès à mes données et ai donc décidé d’ignorer cette erreur (qu’ai-je fait…).


L’erreur s’est bien sûr empirée 2 mois plus tard, le volume annonçant un espace libre de 90% (qui est supposé être de 15%), mais toutes mes données étaient toujours accessibles et utilisables.
Par pur réflex, j’ai éteins la VM. Elle n’a plus démarré ensuite (bluescreen du WS pendant le démarrage de la VM) :
http://i.imgur.com/KWH5K7g.png


J’ai réussi à démarrer la VM en déconnectant les HDD un par un pour identifier le fautif.
Au démarrage, un contrôle de parité s’est lancé. Quand il a fini, j’ai essayé de cliquer sur « réparer ». A ma grande surprise, tous les disques (-1 qui est déconnecté) se sont instantanément "réparés" et leur statut est passé à « normal » (aucun redémarrage nécessaire contrairement à ce que j’ai pu voir sur internet).
Lueur d’espoir, j’ai reconnecté le dernier disque et la VM a démarré sans erreur. Cependant, ce dernier disque n’était plus membre du RAID et impossible de l’ajouter sans dire à Syno qu’il s’agit d’un disque de remplacement, ce que j’ai fait.
Tous les disques ont maintenant un statut « normal », le groupe de disque également (il m’annonce cependant qu’il est rempli à 100%, donc 0 octet de libre). Le volume est toujours en panne avec une capacité de 0 octet.
Dans le panneau de configuration, tous les dossiers partagés ont disparus (ne sont pas listés).

Screenshot de l'onglet "Groupe de disques" : http://i.imgur.com/tiw6a7F.png

Screenshot de l'onglet "Volume" : http://i.imgur.com/Zd8vtdT.png


Voici l’état actuel de mon NAS, j’ai fouillé assez longuement sur les divers forums, et une liste de commandes revient assez souvent pour l’analyse des HDD et du RAID :

Résultat de fdisk -l

https://justpaste.it/17xm5


Résultat de cat /proc/mdstat

https://justpaste.it/17xmb

 

Résultat de mdadm --detail /dev/md2

https://justpaste.it/17xmc

 

Résultat de lvm vgscan

https://justpaste.it/17xmd


Résultat de lvm vgdisplay

https://justpaste.it/17xmf

 

Résultat de cat /var/log/synolog/synosys.log

https://justpaste.it/17xmg

 

Résultat de cat /var/log/dmesg (limité au démarrage d'aujourd'hui)

https://justpaste.it/17xmi

 

Quand mon volume a annoncé 90% d’espace libre et que j’avais toujours accès à mes données, j’ai cherché une solution cloud pour réaliser une sauvegarde, et également repartir sur un RAID propre.

J’ai trouvé la solution illimité d’Amazon très intéressante, manque de chance le lendemain Amazon l’arrête….
Si l’un d’entre vous est souscrit à la solution d’Amazon illimité, je serais très intéressé (utilisation d’une semaine maximum pour l’upload de mes données, le formatage de mon RAID pour repartir à neuf, et le download des données). Il me semble qu’il y a une gestion des comptes, je n’aurai donc pas accès à vos données. Et je suis prêt à participer financièrement.

J’ai vu d’autres solutions abordables comme Hubic, CrashPlan et BlackBaze, mais beaucoup de retours négatifs sur la corruption de données ou un upload très discutable.
Je suis ouvert à toute suggestion à ce sujet (compatibilité de odrive ou équivalent souhaitée).

 

J’ai estimé que les débuts du « NAS » pouvaient avoir une importance, voilà pourquoi je suis rentré assez dans les détails tout en restant assez clair.
C’est la première fois que je demande de l’aide sur les forums internet, car je suis conscient que je n’ai pas les connaissances nécessaires pour résoudre ce problème et que l’enjeu est grand.
Je sais que mes données sont toujours là, et j’implore un expert de m’aider à les sauver.


Bien à vous.

Share this post


Link to post
Share on other sites

-> l’enjeu est grand. ...

 

Personnellement je me procurerais quelques disques pour faire les sauvegardes : 2 * 8TB ce sera environ 500 euros

 

Ce sera surement le plus simple et rapide

 

Je ne vois aucune autre solution d 'autant que transférer par Internet 16 TB cela va prendre "un certain temps"

Edited by F5BJR

Share this post


Link to post
Share on other sites

Tout d'abord merci de votre réponse et de votre intérêt.

Une petite correction, le stockage est de 21 TB et non 12 TB. Se procurer des disques pour atteindre cette capacité me parait plutôt onéreux.
Mais cela n'a que peu d'importance, car pour le moment les données ne sont plus accessibles.. : "Dans le panneau de configuration, tous les dossiers partagés ont disparus (ne sont pas listés)."

Tout ce qui est affiché est erroné :
- l'espace utilisé sur le screenshot du groupe de disque : il affiche que les 100% de la capacité sont utilisés, réellement environ 80% le sont.
- Toutes les informations concernant la capacité du volume (cf. screenshot de l'onglet Volume).

Enfin, la taille des données à upload est secondaire, en effet un ami possède une fibre 800/800 (d'où l'importance de la qualité de l'upload de l’hébergeur choisi).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now