thinksitdo

Change MAC address AFTER DSM 6 install?

Recommended Posts

16 hours ago, OldSmurf said:

@Polanskiman I believe it's 1.02b. I haven't gotten around to updating it yet. I have the very same GNU GRUB version 2.02 beta as in your screen dump. And I agree that the commands should work. But as you can see from my screen dump ... they don't :(

 

That version of the loader does not have a bug in this regard. Did you modify the grub file in any way or some of the files in the loader?

 

Share this post


Link to post
Share on other sites

You can download the loader again and try again if you want to figure out the mystery. Let me know if you get the same error.

FYI the result of the command you type in the that command line is stored in a file called 'grubenv' which is located at the same level than the grub.cfg file. You can open that file in read only mode with a text editor to see what is in it. 

Edited by Polanskiman
added extra info.

Share this post


Link to post
Share on other sites

@Polanskiman Thanks for your input.
My primary ESXi server is currently crashed so I am running on my (very weak) backup server. New parts will arrive next week so I will continue work on this once everything is up and running.
I’ll get back to you at that time



Sent from my iPhone using Tapatalk

Edited by OldSmurf

Share this post


Link to post
Share on other sites

@Polanskiman I finally managed to get it to work :) I got my new Dell R510 up and running and used this opportunity to upgrade to ESXi 6.7. This enabled me to use this guide: https://advanxer.com/blog/2018/12/install-xpenology-dsm-6-2-1-on-esxi-6-7-ready-made-ova-file/ It worked very nicely and now I am able to edit SN and MAC address. So I made a couple of new Xpenologies and this time they remain on the same SN and MAC after a power cycle. And editing with the "c" during boot works as well.

Thanks for your help along and support during these somewhat challenging weeks :)

  • Like 1

Share this post


Link to post
Share on other sites
On 5/17/2019 at 10:16 AM, Olegin said:

 

 

On 5/17/2019 at 10:16 AM, Olegin said:

Admin@your_DS:~$ sudo -i
Password:
root@your_DS:~# mkdir -p /tmp/synoboot_part0
root@your_DS:~# cd /dev
root@your_DS:/dev# mount -t vfat synoboot1 /tmp/synoboot_part0
root@your_DS:/dev# ls /tmp/synoboot_part0
bzImage  EFI  grub  info.txt
...
root@your_DS:/dev# cd /
root@your_DS:/# umount /tmp/synoboot_part0
root@your_DS:/# rm -r /tmp/synoboot_part0

 

@Olegin How do i edit the grub file since i have tried vi and it stated it wants to create a new file.

 

Share this post


Link to post
Share on other sites
On 5/17/2019 at 3:16 AM, Olegin said:

@OldSmurf

You can mount loader partition in telnet/ssh session and then edit grub.cfg

On 5/24/2019 at 3:14 PM, OldSmurf said:

@Olegin

Thank you so much for your reply. I am a noob in Linux so it took me way too long to figure things out. But when I figured out that the line with the three dots indicated when I should edit the grub.cfg things started to work (mind you - the VIM editor and me are not good friends)

So I have now successfully changed the MAC address .. and this time the XPe keeps it after a reboot :)

 

Thanks again :)

 

I wanted to thank you for this information. I'm using a Terramaster NAS F5-220 and the boot USB is inside and requires taking the whole thing apart. I had issues editing the grub.cfg file but as it turned out I was overthinking it and I cd/ to the tmp folder when I tried to cd /grub i got a message that the file /folder did not exist. I started over repaeted exactly what you provided then ran nano all worked as expected. Did I mention I use Linux maybe twice a year....:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.