Jun's Alpha Loader for DSM 6.1


Recommended Posts

Thanks for your comments Polanskiman. Will bear them in mind.

I felt preferable to use DS3617xs rather than DS3615xs because the DS3617xs (with Xeon D1527 cpu) is somewhat closer to my config (Xeon E3-1241v3) than the DS3615xs which has an i3 processor.

Admittedly, my system was running stable and reliably as DS3615xs under 5.2-5644 & 5.2-5967 for over 12 months. As my system is currently configured to emulate DS3617xs, I'll just leave it as is and see how it continues for the time being. I'll hang off the switch over until a full (non alpha/beta) DS3617xs DSM 6.1 release is available. If other issues arise, then maybe I'll be forced to revert to DS3615xs v1.01 config.

 

That makes sense. Just don't put anything too valuable or without a backup with the current v1.02a2. That's all.

 

Hi Polanskiman, just to update you that my Supermicro X10SL7-F based system with Xeon E3-1241v3 has continued running reliably on Jun's loader v1.02a2Alpha on DSM 6.1.1-15101 since our last discussion some days back. System was last rebooted 4+ days ago. In meantime I have been building Photostation 6.7.1-3419 albums on it and doing intensive copy and backup operations.

Only issue I have noticed with Photostation is that it's screwing with .mov files. Earlier versions of that product had no problems displaying .mov, .mkv, .avi files. But it seems other people with genuine Synology boxes (like my DS1513+) have also been complaining of this issue.

BTW: I updated my DS1513+ to 6.1.1-15101 update 1 today. My Xpenology (emulating DS3617xs) has not detected the availability of this update yet and tells me I've installed all important updates.

Any idea on when a beta (or non alpha) build of the DSM 6.1.1 loader might become available for the DS3617xs?

Thanks

 

Addendum: System detected the 6.1.1-15101 update 1 a couple of hours ago. Update went OK - no problems. System still apears stable and reliable. Just updated Plex to PlexMediaServer-1.5.5.3634-995f1dead-x86_64 and that too appears to be working reliably. Very happy with the whole system.

Link to post
Share on other sites
Hi Polanskiman, just to update you that my Supermicro X10SL7-F based system with Xeon E3-1241v3 has continued running reliably on Jun's loader v1.02a2Alpha on DSM 6.1.1-15101 since our last discussion some days back. System was last rebooted 4+ days ago. In meantime I have been building Photostation 6.7.1-3419 albums on it and doing intensive copy and backup operations.

Only issue I have noticed with Photostation is that it's screwing with .mov files. Earlier versions of that product had no problems displaying .mov, .mkv, .avi files. But it seems other people with genuine Synology boxes (like my DS1513+) have also been complaining of this issue.

BTW: I updated my DS1513+ to 6.1.1-15101 update 1 today. My Xpenology (emulating DS3617xs) has not detected the availability of this update yet and tells me I've installed all important updates.

Any idea on when a beta (or non alpha) build of the DSM 6.1.1 loader might become available for the DS3617xs?

Thanks

 

Addendum: System detected the 6.1.1-15101 update 1 a couple of hours ago. Update went OK - no problems. System still apears stable and reliable. Just updated Plex to PlexMediaServer-1.5.5.3634-995f1dead-x86_64 and that too appears to be working reliably. Very happy with the whole system.

 

On your Xpenology box, if I am not mistaken you actually installed DSM 6.1.1 directly instead of updating DSM 6.1 to DSM 6.1.1. Is that correct?

 

Also I advise against going any further in applying updates. Read the other topics in the forum about the state of affairs concerning DSM 6.1.1. Jun's loader v1.02a2 doesn't seem to be handling properly DSM 6.1.1. So if I were you I stop updating DSM until Jun delivers an updated loader.

Also your link is not valid.

Link to post
Share on other sites

I'm running on bare metal with a stable Xeon-D build as well with the alpha loader from Jun, and the 2nd most recent update of DSM (not the one released 3 May). I have done my install from scratch using online installation not manual or as an upgrade.

 

I have no odd hardware either - straight Xeon-D SOC using integrated 10G NIC, integrated SATA and an LSI HBA in IT mode. so, it works well with hardware very similar to Synology (DS3617xs).

 

I'll steer clear of the latest 6.1.1 update.

 

Interested to note the SAMBA version is updated. wonder if it includes SMB multichannel now (not that I need it having just shelled out for 10GBe :razz:)

Link to post
Share on other sites
Hi Polanskiman, just to update you that my Supermicro X10SL7-F based system with Xeon E3-1241v3 has continued running reliably on Jun's loader v1.02a2Alpha on DSM 6.1.1-15101 since our last discussion some days back. System was last rebooted 4+ days ago. In meantime I have been building Photostation 6.7.1-3419 albums on it and doing intensive copy and backup operations.

Only issue I have noticed with Photostation is that it's screwing with .mov files. Earlier versions of that product had no problems displaying .mov, .mkv, .avi files. But it seems other people with genuine Synology boxes (like my DS1513+) have also been complaining of this issue.

BTW: I updated my DS1513+ to 6.1.1-15101 update 1 today. My Xpenology (emulating DS3617xs) has not detected the availability of this update yet and tells me I've installed all important updates.

Any idea on when a beta (or non alpha) build of the DSM 6.1.1 loader might become available for the DS3617xs?

Thanks

 

Addendum: System detected the 6.1.1-15101 update 1 a couple of hours ago. Update went OK - no problems. System still appears stable and reliable. Just updated Plex to PlexMediaServer-1.5.5.3634-995f1dead-x86_64 and that too appears to be working reliably. Very happy with the whole system.

 

On your Xpenology box, if I am not mistaken you actually installed DSM 6.1.1 directly instead of updating DSM 6.1 to DSM 6.1.1. Is that correct?

 

Also I advise against going any further in applying updates. Read the other topics in the forum about the state of affairs concerning DSM 6.1.1. Jun's loader v1.02a2 doesn't seem to be handling properly DSM 6.1.1. So if I were you I stop updating DSM until Jun delivers an updated loader.

Also your link is not valid.

 

Thanks for your reply Polanskiman. Yes, you are correct, I did a fresh install of Jun's suitably modified synoboot1.02a2-ds3617xs.img on April 25.

Have taken your warning on updates to 6.1.1 to heart; have turned off further updates pending arrival of a new 6.1.1 loader for 3615xs/3617xs.

Not sure what the link was about: sorry.

Link to post
Share on other sites
So 3617 is the most recommended, what's about the 917 loader?

 

Gesendet von meinem SM-G900F mit Tapatalk

 

Neither of the two. I recommend using 3615xs.

Ok, i will try again from scratch :smile:

 

Gesendet von meinem SM-G900F mit Tapatalk

Just to let you know, 3615 works directly for me now, thx

 

Gesendet von meinem SM-G900F mit Tapatalk

Link to post
Share on other sites

Just wanted to say a massive thank you.

 

Successfully installed DSM 6.1 on a new HP micro server gen8 from the Jun's Loader Everything working well. With a £70 money back offer on gen8s in April. I have a DS that **** all over my old 212j for about £100.

Link to post
Share on other sites
Just wanted to say a massive thank you.

 

Successfully installed DSM 6.1 on a new HP micro server gen8 from the Jun's Loader Everything working well. With a £70 money back offer on gen8s in April. I have a DS that **** all over my old 212j for about £100.

 

Which Version you installed? 6.1.XXXX ???

Link to post
Share on other sites
Just wanted to say a massive thank you.

 

Successfully installed DSM 6.1 on a new HP micro server gen8 from the Jun's Loader Everything working well. With a £70 money back offer on gen8s in April. I have a DS that **** all over my old 212j for about £100.

 

Which Version you installed? 6.1.XXXX ???

 

He said it: DSM 6.1

A fresh install of DSM 6.1.1 should also work without major issues.

Link to post
Share on other sites

I mean the number of update. I have installed the DSM 6.1-15047 Update 2 running with Loader: v1.02a

 

But i see a update available (Version: 6.1.1-15101-1) ... can I install or not and which loader can woking with this version?

I think the v1.02a2?

Link to post
Share on other sites
I mean the number of update. I have installed the DSM 6.1-15047 Update 2 running with Loader: v1.02a

 

But i see a update available (Version: 6.1.1-15101-1) ... can I install or not and which loader can woking with this version?

I think the v1.02a2?

 

Both loaders v1.02a (DS3615xs) and v1.02a2 (DS3617xs) can be used with DSM 6.1.1 as far as I can tell. I have tried fresh installs with both loaders and all went fine on VBox. However updating DSM 6.1 to DSM 6.1.1 did not work for me. But it seems this inability to update is mainly with VM installs and not with Baremetal installs, although one or two persons complained of having a bricked baremetal box after updating to DSM 6.1.1. That's why I do not recommend updating to DSM 6.1.1 until Jun updates the loader.

 

FYI, both loaders v1.02a and v1.02a2 are the same. v1.02a2 is a slightly modified version of v1.02a aimed at fixing the "time bomb" issue with DS3617xs. There is no v1.02a2 for DS3615xs

Link to post
Share on other sites

My new NAS looks good now with 1.02a and 6.1.15047 update 2. Now I bought a set of Mellanox MNPA19-XTR 10GbE to connect my ESXi with the new NAS over a second NIC. What is the best way to add a second NIC to the NAS?

 

Edit: Find it. Its easy. I have only edit at the USB the grub.cfg and add mac2 under mac1

Link to post
Share on other sites

REPORT: ASROCK C236 WSI working w/ DS3617xs 6.1 Jun's Mod V1.02-alpha2 on DSM 6.1.1-15101

 

MB: ASROCK C236 WSI

CPU: Intel E3-1240L v5 (no iGPU) but DSM recognized as INTEL Xeon D-1527.

Storage controler: Intel C236 w/ 8x SATA3 6Gb/s, support RAID 0,1,5,10

NIC: Intel® i210+Intel® i219

MEM: Kingston DDR4 8G 2133 ECC KVR21E15D8/8 X2

HDD: Seagate ironwolf 4TB ST4000VN008 X5

 

Installation process is quite simple to follow how-to guidance. Changed & updated grub.conf VID & PID, mac1 & mac2, Sataportmap set to 8. Then burn img to a Sandisk ultra fit 16GB pendisk. Boot with default boot option. Then router showed DS3617xs IP address. Then install DSM as on screen instruction.

Login & configuration and balabala....

 

 

Issues unresolved:

  • 1. Can't register Synology account via DSM but can register on synology website with SN which gen by
https://xpenology.github.io/serial_generator/serial_generator_new.html
2. NIC seems LAN1 switched as LAN2. maybe grub.conf mac1 & mac2 has issues.

 

PS: Did tried FreeNAS 11 nightly and want to leverage ZFS power but tried a day then quite. It's too difficult to use. Maybe because i had used DSM for years.

Link to post
Share on other sites

I am currently running dsm 6.1 15047 U2 bare metal on a HP Proliant gen8.

 

Everything seems to be working fine, except Synology assistent nor find find.synology.com is able to find the server.

 

In the manual from Polanskiman I read that it might be driver issues.

 

Does anybody know how to solve this?

Link to post
Share on other sites
agree to point 2. Have 2 NIC.

mac1=xxxxxxx86

mac2=xxxxxxx87

If I boot, one NIC gets MAC 87 and the other one the real MAC. But both are working

 

Try both mac to be odd or even last hex, dont remember. But since you said its 87 then i think its odd.

Link to post
Share on other sites

I try to migrate my ESXi 5.5 to 6.1

But all the time I get during my installation error 13. As there is no USB where I can change the VID and PID I'm not sure what to do now.

Any hints? Can I do a fresh installation and add the data-disks later and they get migrated?

Link to post
Share on other sites

Issues unresolved:

  • 1. Can't register Synology account via DSM but can register on synology website with SN which gen by
https://xpenology.github.io/serial_generator/serial_generator_new.html

 

Nothing much to be resolved here. I assume the purpose of registering an account with Synology is to rape their QuickConnect service. Let me repeat this for the thousand time. There is no need for QC or for registering any account with Synology. Using QC with Xpenology is an abuse of Synology's Services which leads to unnecessary attention from Synology to this project. Simply create a custom DDNS and you will have the same thing as what QC have.

Link to post
Share on other sites
I am currently running dsm 6.1 15047 U2 bare metal on a HP Proliant gen8.

 

Everything seems to be working fine, except Synology assistent nor find find.synology.com is able to find the server.

 

In the manual from Polanskiman I read that it might be driver issues.

 

Does anybody know how to solve this?

 

What network controller do you have? Many people are using the HP Proliant Gen8 and they don't seem to have problems.

Link to post
Share on other sites

Successfully updated to DSM 6.1.1-15101 Update 1 with loader 1.02a for DS3615xs from old version 1.01!

 

Hardware: MSI Z77A-GD65, Core i7 2600k, 4x4GB DDR3, 6x2TB onboard, LSI 9207-8i HBA with 4x2TB & 1x120GB SSD for caching

 

Procedure:

 

1.) unmounted SSD cache and shut down

2.) copied serial & mac from old loader stick (1.01)

3.) mounted 1.02a synoboot.img, adopted serial & mac, set sataportmap to "6" and wrote it to new loader stick

4.) started the system and let it boot normally

5.) logged in through webinterface (everything there)

6.) downloaded the PAT file directly from Synology (DSM_RS3617xs_15101.pat) and selected "manual update"

7.) rebooted, logged in and let DSM install Update 1

8.) another reboot, mounted SSD cache again and everything works fine

Link to post
Share on other sites
I am currently running dsm 6.1 15047 U2 bare metal on a HP Proliant gen8.

 

Everything seems to be working fine, except Synology assistent nor find find.synology.com is able to find the server.

 

In the manual from Polanskiman I read that it might be driver issues.

 

Does anybody know how to solve this?

 

What network controller do you have? Many people are using the HP Proliant Gen8 and they don't seem to have problems.

 

Strange, I have a standard gen 8, with g1610t processor. Did not change anything to the configuration.

Seem to be to be a lot of happy users with this configuration using dsm 6.1 indeed.

 

Its a Broadcom BCMS 5720

Link to post
Share on other sites
agree to point 2. Have 2 NIC.

mac1=xxxxxxx86

mac2=xxxxxxx87

If I boot, one NIC gets MAC 87 and the other one the real MAC. But both are working

 

Try both mac to be odd or even last hex, dont remember. But since you said its 87 then i think its odd.

 

The original MAC from Lun's loader is xxxxx85. I installed a second machine for test and need to change it, because same MAC at same network doesn't work. That was the reason why I count it up. Is there a relationship between MAC and Serial number? I don't want to use quickconnect. Can I use that way?

Link to post
Share on other sites
agree to point 2. Have 2 NIC.

mac1=xxxxxxx86

mac2=xxxxxxx87

If I boot, one NIC gets MAC 87 and the other one the real MAC. But both are working

 

Try both mac to be odd or even last hex, dont remember. But since you said its 87 then i think its odd.

 

The original MAC from Lun's loader is xxxxx85. I installed a second machine for test and need to change it, because same MAC at same network doesn't work. That was the reason why I count it up. Is there a relationship between MAC and Serial number? I don't want to use quickconnect. Can I use that way?

 

Then use mac xxxxxx89 instead 86. But IMO best option is to use hardware mac address, just change in grub.cfg to mac1= and mac2=. That should be enough.

 

You can use same serial on all xpeno you have or just change 1 number in it.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.