Jump to content
XPEnology Community

Can't install DSM - "Available system space is insufficient"


Recommended Posts

Hey guys


Update of my system using a new ARPL loader - i18 latest version. 4th gen i3 CPU.

Trying to build 2422, have booted file and connect to web interface. Selected to migrate my disks and information.
It downloads the PAT file but then comes up with the error above "Available system space is insufficient"

I was prepping the machine yesterday in advance of this. Had issues with system space when installing Packages, so I cleaned up a lot of logs. Rebooted fine and was working OK.
Obviously not enough stuff has been cleared out of System...


I tried the 3622 first (think it was that one - as was coming from ds3615), but that didn't work. Not sure if it's got the PAT file sitting on the system partition?

How do I clean up my system partition please?
I can Putty into the server, can connect to the web interface and obviously have the console direct to the server..

Many thanks!

Link to comment
Share on other sites

I can't get into DSM apart from at the limited install menu, SSH using putty or at the server itself.


In /Addons

I can find some large tgz files. Are these OK to remove? They look like old versions (with the exception of 7.2).






I can't see anything in /root  (says 'for system use only'). Is this the loader Im conneted to?


Loader has 'syno_hdd_detect=0'  - not sure if that's relevant?


edit. I've plugged back in my previous loader USB drive and I'm back in again to my DS3615. It didn't change anything.
I'll try a more thorough cleanup before attempting this again.


Motherboard is Asus H87i plus. Anyone any success with this - 6 HDDs - with ARPL 18i?

Edited by Hostilian
Link to comment
Share on other sites

I've been back in and cleaned up a LOT of log archives, any obvious system image files (for the updates) - and it's got some more room on the system partition.


What I don't know is where any not so obvious files would be placed - and how far I can go when it comes to cleaning stuff out..

Link to comment
Share on other sites

If anyone else is interested. I tried to clean up my system partition - and cleaned up a lot of logs (almost every log archive marked .xz) and other files.


df -h (putty) showed I had a total system partition size of only 2.5GB. With free space only about 500MB. Doesn't sound like an awful lot..


Tried again with the newest loader. Didn't work. Just said there was an issue with the download - corrupt or whatever.

I KNOW that it works on this sytem, as I had tested it with a new single SSD. Installed fine.

Put in my original loader USB drive and rebooted. Said I needed to reinstall DSM. Oh sh*t.
It said that it formatted the system partition - and continued to install the old DSM version that I used to have installed.

Thankfully the data was fine. I restored a configuration backup and all is good.


Checked the system partition again (after the system partition was reformatted) and now it's 7.9GB.. Basically tripled in size.

So I guess any upgrades will work fine now.. 😜

Link to comment
Share on other sites



I got the same error message with latest ARC red pill loader.

I got a HP gen 8 and was running latest DSM but the sboot usb stick got faulty and I couldnt boot dsm anymore. So I got a new usb stick with 8gigs and etched the latest arc on it. Then I opted for DS3622sx and came to the point the installer told me to update or reinstall DSM :( I thing it thinks its new hardware sicne I choose random MAC for my nics.

Anyway I cannot 'over' install the latest DSM .pat. I get the same error message as you did.


I need urgentliy some hints and help.

Link to comment
Share on other sites

Since my bootloder flashdrive got faulty I needed to flash a new flashdrive with latest RedPill loader. This generates at least new mac for the nics and I think also a 'general id'. However, I cannot recover just migrate via Synology Assistant. But then I run into the error mentioned above.

The only tip here seems to be until now to log into ssh. But that is in my case not possible. I think that I had terminal ssh active in option and I knwo that I changed the port that I still know but since DSM is not running I can not log in an 'clean stuff up'.


Is there no way I can recover my DSM via bootloader?

I found in ARC the option to force reinstall. Well, at least I backups and could try that but very time consuming since only the flashdrive got faulty and not my DSM install!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...