Sign in to follow this  
onur

DSM on debian KVM

Recommended Posts

im running DSM on debian KVM.

 

the only image i got working is DSM_DS3615xs_7393_boot.img from dynax,

viewtopic.php?f=2&t=16114&start=230#p67947

is it normal that booting takes about 5 minutes?

 

i cannot get any other image to run under debian.

 

is there an image for straight KVM (no vmware, no ESXi, no proxmox).

 

i tested on windows and vmware - no problem - found a lot of working images.

also boot time is fast.

 

regards, onur

Share this post


Link to post
Share on other sites

Hi,

I'm running DSM 6.1 on Unraid (KVM) as VM and it's working fine with synoboot.img from "DS3615xs 6.1 Jun's Mod V1.02-alpha.zip"(http://xpenology.com/forum/viewtopic.php?f=2&t=20216). For the loader (synoboot.img) I used "USB" type, for the virtual drive "SATA" and for the network "e1000".

Booting is really fast (~1 minute)

 

I hope this helps you...

Thomas

Share this post


Link to post
Share on other sites

@thomas

hi,

i dont have a gui on my server, and i dont have unraid.

 

i tried DS3615xs 6.1 Jun's Mod V1.02-alpha.zip

tried booting from ide and sata - both not working.

nic is not getting ip adress from DHCP.

 

how do you configure usb boot - do you have the xml part for me.

 

 

regards, onur

Share this post


Link to post
Share on other sites

Both OVMF and Seabios are working

First time you need to choose Bare metal Force Install option and after reboot first option...

 

hvm

 

 

 

 

 

 

Thomas

Share this post


Link to post
Share on other sites

@thomas,

hi, thanks for your help.

but its not working.

last ouptut is: ... parsng ELF and booting the kernel.

 

i tried UEFI and Bios KVM boot settings.

i activated nested boot param in host (do we need nested?)

 

maybe im doing something wrong?

im starting with "virsh start synology"

then i connect with VNC - and can see the boot menu.

then i select one of the menu items (tried all of them, i have even made own entries).

then on my DHCP server the nic should be listed(but isnt), or http://find.synology.com should find my DSM.

 

not working, but the KVM task is eating 100% CPU.

it looks like e1000 driver is not working.

do i have to set to specific MAC in xml?

 

can somebody explain the boot procedure?

is the DSM nested?

 

regards, onur

Share this post


Link to post
Share on other sites

I sent you the whole XML on PM. For me it's working fine.

any MAC will do

maybe you changed something in the img when you created your own entries...

after the menu it should go to a screen like this https://ibb.co/hy1hwF

Share this post


Link to post
Share on other sites

i have started with your xml.

then i had the problem that debian jessie was only able to do pc-q35-2.1, and that uefi files(OVMF_CODE-pure-efi.fd) are not present.

i fixed that with backport to stretch and manual download the uefi files from fedora.

after that i can do pc-q35-2.8 and also boot uefi boot like in your xml file.

 

the boot process is like in your image.

 

i have tested with stock image (did not change anything).

 

does anybody know if the image should also work with bios mode kvm?

is this a nested virtualization (virt in virt). maybe i have a problem with that?

 

my working image (DSM_DS3615xs_7393_boot.img from dynax) is not nested i think.

with that image i can see the whole loading processs like in normal linux.

 

onur

Share this post


Link to post
Share on other sites

Indeed, the image boots with OVMF, but it seems it has issues with Seabios... I deleted my other VM test with Seabios and now I can't replicate it...

I don't think this is a nested virtualization

I booted the image you're referring to and it only works in Seabios mode and you can see the whole process..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this