Jump to content
XPEnology Community

SCU passthrough disks won't show in DSM


Recommended Posts

Hi Guys,

Today I'm trying to install a vmware Xpenology nas.

The vmware server is ESXI 6.7 u3. The motherboard is supermicro x9sri-f-0. There is a 4 ports SCU controller on this board. I passthrough this controller to vm guests. I tried it in window 10 and ubuntu 20. The SCU controller shows in both system and the 4 disks could be used.


While in the Xpenology NAS, the DSM installation is successful, except the SCU controller won't show.

The load is Tinycore-Redpill, I downloaded the loader from



I followed the instruction of



The diskstation is DS3622xs+ and DSM version is 7.1.1.

And I think the passthrough to the Xpenology vmware is successful because if I boot to "tinycore image build", and run fdisk -l, I saw the 4 disks.


And if I run "satamap", the output shows:

Found "02:01.0 Vmware SATA AHCI controller" 30Ports/1 drives. Mapping SATABOOT drive after max disks.

Found "02:02.0 Vmware SATA AHCI controller" 30Ports/1 drives. Default 8 virtual ports for typical system compatibility.

Found SCSI/HBA" 03:00.0 Intel Corporation C602 chipset 4-Port SATA Storage Control Unit(rev 06)" (4 drives)


I did try to play with SataPortMap and DiskIdxMap. But I couldn't get these disks show in DSM.

Then I also ssh to the DSM and run lspci,

I found a PCI passthrough device without driver.


So I'm just wondering.

Do I need SCU driver for DSM to get the disks show? I have to install the driver for windows 10 and ubuntu seems support it by default. How about DSM 7.1.1? Does it have the driver?


BTW, I also have another two general question regarding use TCRP loader.

1. After modified user_config.json, do I need to rebuild the loader to make it take effect? I rebuilded every time. Just want to confirm it's must.

2. After rebuild the loader, do I need to reinstall DSM to make the changes take effect? I guess it shouldn't need to but I still reset the DSM and reinstall. However no luck to get the disks show.



Link to comment
Share on other sites

The SCU SAS ports seem to be managed by Intel's RSTe and doesn't use common extensions like AHCI. You need an extension called isci (not to be confused with iscsi) to activate them. See if disabling Option ROM from mobo BIOS can alter RSTe mode or else you need to compile an extension for the platform.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...