Jump to content
XPEnology Community

Tutorial: Install DSM 7.2 on vm-bhyve (FreeBSD).


Recommended Posts

Install DSM 7.2 on FreeBSD using vm-bhyve and TinyCoreRedPill




This guide is for installing DSM 7.2 on a Virtual Machine with a Virtual Disk using bhyve with TCRP Friend kernel.


To make this guide I used the main TCRP Guide, the ESXi Guide and I got most of my conf file from this Bhyve Guide

I didn't explain much, just some vm-bhyve relevant info, more in depth explanations can be found in those guides.


I used DSM 7.2.0-64570 and DS3622xs+

My CPU is Xeon so I used DS3622xs+


Download site for DSM 7.2 for DS3622xs+.

Direct link to download DSM_DS3622xs+_64570.pat

Link to Tiny Core RedPill Releases.

I used the uefi img tinycore-redpill-uefi.v0.9.4.9.img.gz






Step 1   -   (Config file)


After bhyve is installed use this "synology.conf" config file below.

It goes in with the rest of the vm-bhyve config files poossibly at "/pool/vm/.templates" directory.







Network type "virtio-net" driver did not work for version 7.1.1-42962 and I did not try it yet with friend, so I still used the e1000 driver instead. I also have not tried "virtio-blk" and "sparse-zvol" recently.






Step 2   -   (Create VM)


Create a VM named "synology" using the template synology.conf

sudo vm create -t synology synology


This creates two empty files, or two disks in the /pool/vm/synology/ directory.


disk0 named "tinycore-redpill-uefi.v0.9.4.9.img" - the boot disk.

disk1 named "disk0" - data disk.


I named the disk0 "tinycore-redpill-uefi.v0.9.4.9.img" because now the actual TCRP disk file needs to be copied to the VM directory to overwrite the empty disk with the same name.


Deflate the img.gz file using "gzip -d tinycore-redpill-uefi.v0.9.4.9.img.gz"


Copy the downloaded disk img file to the VM directory

sudo cp /pool/vm/.iso/tinycore-redpill-uefi.v0.9.4.9.img /pool/vm/synology


The config file uses UEFI bootloader and graphics so the VM will run on a VNC port.






Step 3   -   (Start VM)


Start the VM

sudo vm start synology


This will start the VM and boot the TCRP disk since TCRP is in the first place, the disk0 place. 


The disk1 is just named "disk0" but it still comes at second place after the TCRP disk.






Step 4   -   (Booting TCRP)


Boot will have one option.



When TCRP boots get the IP info by running "ifconfig" ssh into it with user "tc" and password "P@ssw0rd". 







Step 5   -   (Install DSM)


Below is the commands needed to install DMS from the TCRP Loader Guide. Type "y" and hit enter to update the json file.


  • One important point is to use "realmac" when running DSM in a VM as explained in the ESXi Guide . 
  • On "satamap" command type number "1" and hit enter. You can also just hit enter but if you hit enter without typing 1 it will say DSM install will fail but it does not fail. Probably because it's a VM. 


./rploader.sh update

./rploader.sh fullupgrade

./rploader.sh serialgen DS3622xs+ realmac

./rploader.sh satamap

./rploader.sh build ds3622xsp-7.2.0-64570

exitcheck.sh reboot



After reboot:


When TCRP boots choose "Tiny Core Friend" option, hit enter to boot. That option will be selected by default.



Then go to https://finds.synology.com/ and hit connect, or you can see the IP from Friend and add port :5000 to the IP.


Click install.


Select to manually upload the DSM pat file you downloaded earlier (DSM_DS3622xs+_64570.pat).


Wait up to 10 minutes.


DSM will install packages.


After you create an account select not to auto update DSM but to install them manually.









Notes and things I noticed:


Without Friend using tcrp I was able to install version 7.1.1-42962 by choosing the SATA option, but SATA option did not work for newer versions. 

I did actually install the latest version (7.2.0-64570) at first with SATA option but then after DSM is done it says "something went wrong" and it wants to rebuild, but then if I force shutdown the VM and start it again but with Friend option Synology continues to install the packages and installs.


After DSM is installed SATA option also works as well as Friend option.


While back I tried to manually update from version 42661 but it failed, but then I didn't have Friend.





If someone has additional useful things regarding vm-bhyve let me know.

Edited by atbla
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...