ihtiandr

один или несколько кэшей разделов/групп дисков неисправны

Recommended Posts

ну собственно выдает такую ошибку "один или несколько кэшей разделов/групп дисков неисправны рекомендуется заменить неисправные диски", смарт у всех дисков "ОК" стоит система на esxi 5.5 что делать ума не приложу, систему обновлял, e2fcsk делал не помогает.

Share this post


Link to post
Share on other sites

raw mapping из esxi, при чем хоть статус и говорит что перешел в degraded mode ограничений на запись нет.

Share this post


Link to post
Share on other sites

Нужно зайти в DSM по SSH и запустить cat /proc/mdstat и проверить что на самом деле происходит с RAID'ом.

 

Отправлено с моего LYO-L21 через Tapatalk

Share this post


Link to post
Share on other sites

Параметр при монтировании какой был? -r или -z? Надо с параметром -r монтировать. С -z проблемы наблюдаются. Сорри за долгий ответ

Share this post


Link to post
Share on other sites
Параметр при монтировании какой был? -r или -z? Надо с параметром -r монтировать. С -z проблемы наблюдаются. Сорри за долгий ответ

что Вы имеете ввиду?

 

DiskStation> cat /proc/mdstat

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]

md3 : active raid5 sdg6[0] sdf6[4] sde6[3] sdc6[1]

7813593344 blocks super 1.2 level 5, 64k chunk, algorithm 2 [5/4] [uUU_U]

 

md2 : active raid5 sde5[6] sdf5[8] sdg5[4] sdc5[5] sdd5[7]

3888110592 blocks super 1.2 level 5, 64k chunk, algorithm 2 [5/5] [uUUUU]

 

md1 : active raid1 sdc2[3] sdd2[4] sde2[1] sdf2[5] sdg2[2]

2097088 blocks [12/5] [_UUUUU______]

 

md0 : active raid1 sdc1[3] sdd1[4] sde1[1] sdf1[5] sdg1[2]

2490176 blocks [12/5] [_UUUUU______]

 

unused devices:

Share this post


Link to post
Share on other sites

если вот эту команду vmkfstools -z /vmfs/devices/disks/<имя t10.ATAитп> rdm_WD2DWCAVU0477582.vmdk то да -z и работало нормально больше 2х лет

Share this post


Link to post
Share on other sites
если вот эту команду vmkfstools -z /vmfs/devices/disks/<имя t10.ATAитп> rdm_WD2DWCAVU0477582.vmdk то да -z и работало нормально больше 2х лет

Именно

У меня с -z сразу проблемы возникли. С параметром -r все чудесно работает. Попробуйте перемонтировать

Share this post


Link to post
Share on other sites

а информация не пропадет? массив восстановится, если перемонтировать?

или сделать поочередно с каждым диском с перестроением массива?

Edited by Guest

Share this post


Link to post
Share on other sites

или сделать поочередно с каждым диском с перестроением массива?

Share this post


Link to post
Share on other sites

выключаете виртуалку. размонтируете диски, удаляете RDM-ссылки. заново монтируете диски. инфа на дисках остается в неприкосновенности. вы только перемонтируете диски в виртуалке. по крайней мере, у меня все гладко прошло.

Share this post


Link to post
Share on other sites

а можно более подробно последовательность действий с командами?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now