• 0
kaku

[Help] 2TB External HDD blank but ext4 works

Question

I already posted this in jun loader forum but, thought it should be a separate thread. I am on DSM6 update 9 on Baremetal PC.

 

A 2TB NTFS formatted external HDD (Seagate BUP slim) when connected shows as blank in file Explorer. I can create folders in it, but none will be "visible" in the usbshare. You can confirm if the HDD is read by creating a new folder which already exist and DSM will not create the folder with existing folder name.

 

But they DO get created and shown properly in DSM if I format the HDD as ext4. Why is this so? Cant seem to find an explanation. Can anybody help?

 

I do need it to be formatted as NTFS so that I can use it in windows also.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Its because in DSM6 there is no ntfs-3g driver installed. Im not sure if this gonna to work but you can try to mount this USB drive with this command from CLI(* is drive number):

 

mount -o rw,mount,rw -t ntfs /dev/sdc* /mnt/ntfs/

Share this post


Link to post
Share on other sites
  • 0

Indeed it seems like ntfs is not supported at all.

mount -t ntfs

always fails with an unknown filesystem error. I actually tried this on actual Synology hardware too, a DS413j running DSM 6.1, and same problem, so it's not an xpenology problem. It have something to do with GPT partitions, but the other partitions mount fine so I don't know...

Share this post


Link to post
Share on other sites
  • 0

hi.

 

4tb seagate expansion usb disk, mbr (not gpt) nfts

no problem with dsm 6.1 (usb3, virtualbox, usb device hand over to vm)

disk/partition is recognised, writing over network and local dsm filemanager works and created folders are intantly seen on both "views", so diiference so see how it worked with dsm 5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.