Jump to content
XPEnology Community

Virtual machine fail to start DSM 7 Redpill


Recommended Posts

Hi everyone,


I recently installed DSM7 using automated redpill loader. Which is an amazing improvement from previous DSM 7 install methods BTW. Anyway, most things are working well. But I can't get virtual machine manager to work. I have tried ubuntu, virtual DSM and home assistant virtual machine and all of them wont power on. When I try to power them on I get an error that says "Failed to power on the virtual machine". Another thing I can't get to work is webdav, but I'm not sure if this is related?


There isn't much help in the VMM log - all it says is VM failed to start. 


I get an error which shows up for about a second in VMM before it says it failed which says "Powering on (no network connection is available)"


What I have tried so far:

turn on Intel VT in motherboard BIOS

changing all the settings I can find within VMM 

tried private and external network switch in VMM


Current hardware:

Intel i5 7500


I'm using a PCI NIC which I believe has an intel chip. I can't find the exact name as I bought it a while ago. I was using the same NIC in a different system running DSM6.1 and VMM worked fine. All the network interfaces are showing as normal in the control panel


I've been stuck on this for a while and would appreciate any suggestions. 

Link to comment
Share on other sites

Firstly, thanks for the reply. And secondly, I have a bit of an update. I was using the DS2422+ loader. So I tried the DVA3221 loader and VMM worked fine. I then tried DS1621+ loader and it also didn't work. So I guess its a loader issue. To be honest I'm not sure what your first point means. I tried Googling it but that didnt really help. But it may be the underlying cause?


For me I had 7 drives in my NAS and since I couldn't get DSM installed on any of the DS36XX loaders I guess I will either go to a 4 bay NAS or try something else. 


If anyone else had any suggestions on how to fix this on the DS2422+/DS1612+ loader that would be greatly appreciated. 

Edited by harbdans
Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)

Interesting topic as I ran into the same issues!

I've been running DSM 7.1.1-42962 | DS923+ through automated redpill loader.

My hardware is as follows:

Intel NUC12WSHi3
i3 1220P
32 GB DDR4 3200hz

Everything works fine, including Docker. I chose the DS923+ 'version' because it supports NVMe volumes. I have exactly the same issues with the VMM as you describe and also troubleshooted by altering options until I ran out of ideas. I have the feeling it might have to do with my network driver (Intel® Ethernet Controller i225-V) or anything related to Open vSwitch. 

Also tried 'CPU compatibility mode' btw. No luck!

Sidequestion: I've been wondering if using Intel hardware creaters underlying issues as the DS923+ version has been created for a AMD Ryzen R1600 chip. But since evertying but VMM seems to be working fine, I didn't bother. Also the VMM software shows the right amount of CPU threads etc so I figured it supports the multicore functionality etc.

Edited by theoxis
Link to comment
Share on other sites

After some troubleshooting, it seems to me that Synology VMM only works when you have an intel processor matched with an intel DSM bootloader.

So, that would mean one of these:
- DS3615xs
- DS3617xs
- DS3622xs+
- DS918+
- DS920+
- DVA1622
- DVA3221

Unfortunately, none of these supports 'native' NVMe storage. This apparently gets increased under DSM 7.2, but that is still in beta. Moreover, some don't even officially have NVMe ports (also not for cache) not supporting this kind of storage at all.

Anyway, seems to me like the DS1621xs+ would be the best of both worlds, but unfortunately that one is not available...

Scherm­afbeelding 2023-03-17 om 22.05.16.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...