Sign in to follow this  
uabuner

(solved) dsm 4.3 rsync and segmentation vault problem

Recommended Posts

I have 16 lines of rsync job scheduled to run via scheduled task, total size to be sync is about 50gigs or so.

( to be exact it mount cifs from other nas to this dsm 4.3 and then rsync from it to another folder inside hdd on this nas)

my machine is intel atom 1,6 with 1gig of ram. Other nas is wd cloud gen 2.

it run just fine in first few minutes but it will lead to segmentaion fault in 10-15 minutes..and than it will freeze my dsm.

I have to force reboot it and sometime it work just fine ,

but someothertime it boot longer than usual and it will flood my dev/md0 and leave no space for even start smb..

it started, but I can mount its share, as smb failed to start , ssh and web gui running just fine and no error warning also.

I have tried this config twice on 4.3 and 5.2, anyway it was running just fine on omv before (but it was a month ago)

 

So my problem is rsync reliability on this box.

 

I suspect that my hdd is developing a bad sector but test shows just fine on DSM...

 

the log info for failed smb is : /lib/util/tdb_wrap.c:65: [2017/01/31 17:42:14.344633, all 0, pid=6805] tdb_wrap_log

tdb(/var/run/group_mapping.tdb): expand_file write of 4096 bytes failed (No space left on device)

bassically its just saying that my disc is flood with temp files...

 

Any clue ? I m open to suggestion but please be detailed in script as I am a noob

At the moment I'm trying to copy paste via win : copy from wd to dsm using simple copy paste

 

Thanks

Edited by Guest

Share this post


Link to post
Share on other sites

solved :so its a hardware problem ...figured it out after hook a monitor to dsm box.

my motherboard is dying before and now its dead.

As for HDD I dont know...need to find another board to check..

 

thanks

Share this post


Link to post
Share on other sites
Sign in to follow this