Sign in to follow this  
firstfreak

Anfänger-Fragen - DSM Version Abhängigkeit

Recommended Posts

Hallo Leute,

 

ich habe mich mal mit dem DSM beschäftigt und bei mir läuft nun auch eine.

DS3615xs

Installierte DSM-Version:

DSM 5.2-5967

 

Hardware:

Intel Atom 330 ION 4 GB Ram

 

Das gibt mir die System Info aus:

DS3615xs

Prozessor

INTEL Core i3-4130

Prozessor-Taktrate

1.6 GHz

Prozessorkerne

2

Arbeitsspeicher insgesamt

4096 MB

 

Nun habe ich das Problem das ich hier ein Mix-System zu erstellen, wo ich noch Node.js 4.x brauche.

Leider erhalte ich nur Node.js 0.12.x und ein Update ist nicht möglich.

Ich kenne mich bei Syno nicht so aus, aber warum ist das bei mir jetzt eine

 

DS3516XS, wird das aus der CPU generiert oder wie muss ich das verstehen?

Kann ich das auch wechseln auf eine andere Version als DS3516xs, die z.b. Node.js 4.x unterstützt?

z.B.: hiervon eine andere http://download.synology.com/download/D ... /5.2/5967/ ???

 

THX all.

Share this post


Link to post
Share on other sites

DS3615xs ist das Synology-Model auf dem der Bootloader aufsetzt.

Wenn Deine Hardware unterstützt wird, würde ich gleich June' Bootloader 1.0.1 verwenden und DSM 6.0.2-8451 installieren.

 

Und statt Dich von den verfügbaren SPK-Paketen für Node.js abhängig zu machen, kannt Du eine beliebige Version als Docker-Container laufen lassen.

Share this post


Link to post
Share on other sites

Meine Kiste läuft auf DSM 6.0.2-8451 Update 9 und in den Paketen gibt es ein Node.js v4.4.2-0160 direkt von Synology.

 

Ich würde an deiner Stelle mittels Jun's Bootloader auf diese Version updaten, dann bekommst du auch das entsprechende Paket.

Share this post


Link to post
Share on other sites

Du kann deine XPE 5.2 installation nach Umstellung auf June's Bootloader auf DSM6 migrieren.

 

Auf Dockerhub gibt es 4.7.2, 6.9.4 und 7.4.0 als offizielle Node.js-Container.

 

Ich setzte sogut wie gar kein SPK-Paket ein, weil oftmals veraltete Versionen und/oder seltene bis keine Updates und die Trennung zwischen "NAS" und Applikation nicht immer sauber ist.

Share this post


Link to post
Share on other sites

Hi, danke erstmal.

 

Also erst den Loader wechseln und dann nach dem booten:

 

Install / upgrade im Loader ?

 

Oder

 

Im DSM, im Updatecenter, manuell ?

 

Sorry, bin froh das es bis hierher schon so gut läuft.

Gibt es einen Link mit Doku zu Docker, sagt mir leider gar nichts.

 

Thx

Share this post


Link to post
Share on other sites

So danke nochmals,

 

ich habe alles so gemacht wie es in der Anleitung stand, editiert etc.

 

dann habe ich den NAS gestartet, aber ich finde unter find.synology.com den Server nicht.

In meiner Fritzbox ist er auch nicht.

 

Kann mir da noch jemand zu helfen ?

 

THX

Share this post


Link to post
Share on other sites

Alles richtig konfiguriert? VID und PID und MAC-Adresse? Sieht ja mal so aus, als würde der Bootloader nicht gehen. Steck nen Monitor an und beobachte was passiert beim Start.

Share this post


Link to post
Share on other sites

Vid und co alles richtig. Wenn er startet dann habe uch schon alle Optionen probiert. Er startet und dann steht geh auf find.syn..... keine Fehler. Kann es sein das er die Netzwerkkarte nicht mag, Treiber ???

Share this post


Link to post
Share on other sites

Hallo, brauch nochmal bei einer Sache Hilfe, weil ich verstehe da was nicht.

 

Ich habe nun einen anderen Rechner genommen und über Force Install das DSM installiert.

Lief durch und startete neu !

 

Dann auf Option 1 und dann kommt:

Fehler auf Festplatten gefunden (3,4) hab aber nur eine.

 

Hab auch schon an der SataPortMap gespielt aber es funktioniert nicht.

 

Mac stimmt

und VIP / PID auch.

 

Versucht habe ich SataPortMap=1 / 422 / 444444

Ich weiß da nicht weiter.

 

Vielen Dank

Share this post


Link to post
Share on other sites
So danke nochmals,

 

ich habe alles so gemacht wie es in der Anleitung stand, editiert etc.

 

dann habe ich den NAS gestartet, aber ich finde unter find.synology.com den Server nicht.

In meiner Fritzbox ist er auch nicht.

 

Kann mir da noch jemand zu helfen ?

 

THX

 

Hatte ich auch, lade Dir den SynoAssi runter und für ihn dann auf einem Rechner im selben "Offline-Netzwerk"

wie die DS aus. Damit hat er meine DS erkannt.

 

Zu Deinem HDD-Prob habe ich aber auch keinen Rat...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this