Esxi DSM 6 ovf deploy - Jun's loader

Recommended Posts!dxgDjCpD!CNc0upEGoN3VGbZhAdM1MYpgxVq-yv5L8j_MGvyS1JQ

ovf with static address, same user and pass.

Just now when I started the vm to modify the ip settings the syno app and didn't find any address to connect to in my lan (I had 3); i looked in the router status page and all the ip's were listed there.

dsm network.JPG

Link to post
Share on other sites

Thank you for help.

I tested the OVF you provided with static address.unfortunately, it does not worked too.

I looked at deeper in the router what kind of exchange there is between the syno ant the router.

I see that the syno sent a DHCPDISCOVER.

The router send a DHCPOFFER

But after nothing else...

even the syno try again several time to initiate a new DHCP IP request.

I don't know what is wrong.

If someone have an idea to help debugging, I'd be very happy.

Link to post
Share on other sites
  • 2 weeks later...

I've found from playing around with this on ESXi 6.5 that I've had the most success when I set my VM to use EFI and not BIOS. EFI is in the VMX supplied with Jun's loader zip, but if you are creating your own VM then probably haven't set specifically to EFI.


I have the 50mb synoboot, an 8GB "system" drive VMDK on SSD, 2x 750GB HDs passed thru to the VM as RDMs, and 2x USB3 drives passed thru via ESXi (not Direct I/O)

Added a 2nd 8GB disk as VMDK on SSD and added this as SSD Cache in DSM.


Network-wise, I added 2x VMXNET3 NICs and bonded them in DSM :smile:


Love the way I can mount Windows shares on the Syno, and then share them out via NFS/AFP so it acts as a gateway.


Loving this software :smile:

Link to post
Share on other sites
  • 2 weeks later...



Thanks for the ovf template, it made deploying DSM 6.1 a breeze.

Tested on ESXi 6.5 U1, updated DSM via config panel to 6.1.3-15152 Update 3 without any issue.

Please verify you have set MAC to 00:11:32:2C:A7:85 if having DHCP issue.


However, I noticed SMART status was not working as expected.

I first though it was due to disk being in physical RDM mode and incorrect SMART handling in VMware stack, which I expected.

I installed an IBM 1015 (flashed to 9211-8i IT mode) and setup passthrough to the virtual machine, but still had problem with SMART. My disks are 6TB Ironwolf, but ironwolf health monitoring was not working either.


symptoms :

- health info show as "unavailable" in storage manager UI for every disk, be it physical RDM or connected via a passthrough HBA in IT mode.

- /var/log/messages complain a lot about /dev/sda & /dev/sdb while in the storage manager UI


resolution :

- add a SATA controler to the virtual machine

- attach disk 1 as SATA 0:0  (this disk is 50MB, independant / non-persistant, provided with the ovf)

- attach disk 2 as SATA 0:1 (this disk is 8GB, independant / persistant, provided with the ovf). Both disk must be attached to the SATA controler or DSM won't boot.


caveat :

the paravirtual SCSI adapter is not used anymore (except if you have added disk to it on your own).

notice that the volume and raid group hosted on the 2nd disk won't be available anymore. You will have to reinstall some package (such as open-vm-tools-bromolow) to another volume. As I am new to xpenology, that might not be a best practice ? I have not yet figured it out.



As a side note, I also have an horror story to share about the 9211-8i :

symptoms :

- disk and RAID group are recognized, but soon after it is pure chaos as one or more disk are faulted.

- /var/log/messages show hundreds of SCSI sense code error

- RAID group and volume eventually become bricked as all error are randomized against all disk connected to the SAS HBA.

- rebooting or reconstructing the RAID is a no go as disk error will again show up very soon after.

- disk manager show system partition of one or more disk as faulted

- after erasing the faulty partition (use "benchmark" for a quick erase", disk is available again and SMART status show disk as healthy


resolution :

- figure if you have an overheat issue. The SAS 2008 chip can be very hot in small enclosure and do bad thing to your RAID group.

- do not use firmware Flash it to !

Edited by Exo7
Link to post
Share on other sites

Thanks so much to koroziv! After a failed update from DSM 6.0 to DSM 6.1, giving up on trying to restore I also failed to boot Jun's loader under ESXI to create a new VM.

I was panicking for a while (have backups of important stuff, but would take forever to restore) this saved my ass, and was so easy to setup!


After importing the ovf and vmdks I recreated my users and config everything is working great, but now I'm facing a different issue. I need to increase the max disks, trying to follow the idmedia guide on YouTube (going for 36 disks). The same guide worked perfectly with my previous install.
However with this template after I edit the synoinfo.conf file and reboot, the VM pulls a new address via DHCP (I set a static one previously) and forces me to reinstall DSM. I can reinstall and my data, config and packages remain intact, but the max drives is reset to 12.


This is what I'm doing:

- ssh in to the VM deployed from koroziv's template

- pull the synoinfo.conf file via scp to my destop

- edit values following the idmedia guide

- rename synoinfo.conf on the VM for backup

- scp the edited file in place of the orignal

- cat the contents to make confirm the new file is in the correct place and has new values

- reboot via DSM web gui


What is the "proper" way to increase max disks?


Thanks for any help!




Running the VM under ESXI 6.5 with 2 cores and 4GB RAM and a Dell RAID card flashed to HBA mode

These are the values I'm trying:

maxdisks 36

0000 0000 0000 1111 1111 0000 0000 0000 0000 0000 0000 0000 0000 0000   -   esataportcfg
0000 0000 0011 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000   -   usbportcfg
0000 0000 0000 0000 0000 1111 1111 1111 1111 1111 1111 1111 1111 1111   -   internalportcfg


Hex (writen to file):

ff000000000   -   esataportcfg
300000000000   -   usbportcfg
fffffffff   -   internalportcfg

Link to post
Share on other sites
  • 4 weeks later...

hi guys

i will migrate from 5.2 to 6.1 with "koroziv" ovf. i have esxi 6.5u1, please can enyone help me what i can do for don't loosing my files on RAID1 disks?

the disks are configured in vmdk mode. i create 2 disks, 1 on datastore1 and 2 on datastore2.

thanks in advanced

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
  • 3 weeks later...
  • 2 weeks later...
On 18/11/2017 at 7:42 PM, codedmind said:

Please inform, I have a vm that I deploy with the ovf here that have Jun version 1.01alpha

- can the loader be updated to Jun 1.01b ? If not can anyone share an ovf with 1.01b?



Correction, i have 1.02alpha and the question, is possible to upgrade to 1.02b

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
On 10/12/2017 at 1:38 AM, mistralst said:

Anyone can share a OVA that works? Without the DHCP/getting IP issue, for VMware ESX.




Bump. Can't access the Webinterface.

ESXI 6.5 and tested serveral loaders :(

Link to post
Share on other sites
  • 2 weeks later...

Just so you know man, I just installed your image on ESXi 6.5U1, latest build. 

It has worked flawlessly (dsm 6.1.3-15152 update 1with Hardware version 13).

And, it has also been possible to upgrade to the last .pat file from Synology at this time (DSM_DS3615xs_15217).

Which means, I'm runing now DSM 6.1.4-15217 Update 1v


I thought it would have been complicated and painfull ot install, but you made it too easy.

In a way, it's a pitty to not have to struggle with it. 


Thanks a lot, man.

Link to post
Share on other sites

Hi All,

I have a XPenology DSM that was running on 5.2-5967 fairly happily, with a bunch of data and shares configured.


Someone has updated it and broken the thing.


I have used this OVF loader to install and it's working fine. Should I be able to just map the VMDK's to this new Synology instance and it should pick up the disks?

Link to post
Share on other sites

It should take the old vmdk-s with no issues, at most you will get an disk error at first boot, solved by a simple repair from dsm. I recommend adding one vmdk at a time, starting with the least critical one; that way you minimize the risk of a potential problem.

I'm still using the same vm that I posted here with no issues, updated to the latest dsm availeble.  

Link to post
Share on other sites
  • 2 weeks later...

Hello guys,


Thank you very much for uploading the OVF and the vmdks! It made it so much easier for a first comer to start the install and start configuring.


I have a question though: I have never used XPEnology nor Synology before, and my current Gen8 is running a RAID5 array with 4 disks in a single 8TB datastore for Vmware.


I have deployed the Virtual Machine, it worked fine, then I have increased the disk space for the 8GB file to 16GB, but I can't get the increased space in the system disk to show (to install additional Synology packages).

I'm also trying to add an additional SCSI O:2 disk, but XPEnology doesn't "detect" it.


I'm using the Control Panel - Shared Folder to do it, but can't find any options.


Is there a different location that I should go to, in order to increase the disk space on the system drive and get the XPenology system to detect it?

Also, is there a specific set of instructions that I should follow in order to get XPEnology to detect and format a new virtual hard disk attached to the machine? (Should I keep using virtual SCSI disks or should I switch to SATA?)


Thank you!

Link to post
Share on other sites

Ok, I was able to figure out how to add the additional drives, but I still cannot, for the sake of me, understand why the system disk drive has 16GB of total space allocated, but the system only detects 3.27GB as usable...

Any way to increase the system disk space to be able to use the 16GB that are available?


Thank you

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.