Trantor

Drivers requests for DSM 5.2

Recommended Posts

This is an updated synoobot file which include several updates/fixes.

 

Link : http://xpenology.trantor.be/beta/synobo ... v1.1_v3.7z

 

Known issues:

- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot)

- Volume containing drives attached to SCSI/SAS controller is "broken" on each reboot, you must click repair.

 

Changelog:

v3 (21/12/2013)

- Add more drivers for KVM / virtio / virtualization support
- Add patched r8169 driver (realtek chips which are not working with the r8168 driver will work with this one)
- Add latest version of sk98lin driver (Marvell Yukon / SysKonnect SK-98xx/SK-95xx support)
- Update Broadcom bnx2 driver to latest version


v2 (05/12/2013)

- AX88179 Gigabit Ethernet USB 3.0
- Latest driver version for RocketRAID 3xxx/4xxx Controller
- Latest (aacraid) driver version for Adaptec
- Support XFS filesystem (no idea if DSM will automount this)


v1

- Update synobios.ko (by k3dt ; fix "buzzer stop button pressed" warning)


SCSI
----

Highpoint Rocketraid 2720SGL
LSI mpt2sas v17
Adaptec aacraid
Intel C600 Series Chipset SAS


NETWORK
-------

3Com 3c590/3c900, 3cr990
Alteon AceNIC/3Com 3C985/NetGear GA620
QLogic QLA3XXX
SiS 900/7016 SiS190/SiS191


USB
---

USB to serial / Prolific 2303 driver


PATA
----

ATI PATA (PATA_ATIIXP)
AMD/NVidia PATA (PATA_AMD)
CMD64x PATA (PATA_CMD64X)
JMicron PATA (PATA_JMICRON)
Marvell PATA (PATA_MARVELL)
Promise PATA 2027x (PATA_PDC2027X)
Intel SCH PATA (PATA_SCH)
CMD / Silicon Image 680 PATA (PATA_SIL680)
SiS PATA (PATA_SIS)
VIA PATA (PATA_VIA)
Winbond SL82C105 PATA (PATA_WINBOND)
Legacy PATA support (PATA_LEGACY)

 

 

I have test this version,but I cannot shut down the machine, must shut down the machine second time.I find the problem is VPN server,I Uninstall VPN server,the machine can normal shutdown

How to solve this problem?

but vision v1 is OK!

Share this post


Link to post
Share on other sites

Hello,

Does this cure the infinite reboot loop with 4.3 and 4.2v3 ?

I was happy to see that my SATA device was recognized and it hasn't mess with the data on my raid, but it has wrapped all the usefull data on the "useless" disc on the last SATA port ! Loose 1Gb of data...

Not confident anymore in your beta !

Or I will start with no disc except a loosy spare...

Share this post


Link to post
Share on other sites

Fix NFS support : http://xpenology.trantor.be/beta/nfsd-fix.7z

 

 

Hello,

I was happy to see that my SATA device was recognized and it hasn't mess with the data on my raid, but it has wrapped all the usefull data on the "useless" disc on the last SATA port ! Loose 1Gb of data...

Not confident anymore in your beta !

Or I will start with no disc except a loosy spare...

 

As already said:

This is not an official synology product

This is only design for testing purpose not for production.

No warranty for any damages, loss of data or anything else.

 

Don't use XPEnology, go buy a really awesome Synology product :wink:

Share this post


Link to post
Share on other sites

Ok, but why does it wiped the last disk on the sata controler ? :'(

should display something before doing anything !

There was a disc out of the sata controler directly plugged to the mobo !

Share this post


Link to post
Share on other sites

Hi Trantor

 

I have an ASROCK FM2A88x-ITX motherboard and i have installed DSM 3. The software is working for the most part, what is not working is the wake on lan, the power on after power failure and the CPU usage. Might be more but i did not see anything else yet. Would it be possible to get these drivers added?

 

If there is an update how would i update the the system without lossing data?

 

This is my first time using this software so please bare with me as i am learning al of this.

 

Thank you.

Share this post


Link to post
Share on other sites

I test my Promise SuperTrak EX12350 and the system dont boot and i get an segfault error! :sad:

Share this post


Link to post
Share on other sites

Hi Trantor

 

Thank you for relesing the XPEmology package first!

 

I installed the XPEnology 4.3 on "PROWare Nas", but the sas raid controller card cant't work.

 

And the server shutdown again and again because the card doesn't work.

 

Product Name: LSI MegaRAID® SAS 8704EM2

Driver Link : http://www.lsi.com/downloads/Public/Meg ... Driver.tgz

Company Website: http://www.lsi.com/pages/default.aspx

 

If it can be included in next XPEnology version that will be a great thing~

 

Thanks

Share this post


Link to post
Share on other sites

Could you please add ax88178 USB2 gigabyte ethernet ?

 

Here the driver : http://xpenology.trantor.be/beta/asix.ko

- Copy it to /lib/modules/

- insmod usbnet.ko and then asix.ko

 

 

Christmas present:

 

I use kernel backports 3.12 to compil more than 60 wifi drivers.

Link : http://xpenology.trantor.be/beta/

 

Enjoy :wink:

 

 

 

Hi Trantor,

 

Regarding WiFi driver, how will I know which wifi driver I will copy to modules. Im using 4.3

My motherboard is zotac h87 with an onboard wifi. Also can you have driver for bluetooth.

Merry Christmas.

 

Thank you.

limayne

Share this post


Link to post
Share on other sites

Hello, I'm having an issue with the synoboot pre v1.1_v3, I got this message (after .pat installation) , and xpenology doesn't boot :

 

 

Share this post


Link to post
Share on other sites

Hi Trantor,

 

I am using DSM 4.3, and found JMB363 PATA drive is not supported. Can you please post the jmicron ko file? Thanks!

Share this post


Link to post
Share on other sites
with synoboot pre v1.1 v3

 

driver for ax8879 is not present

driver fro rt28000usb doesn't work :sad:

 

I will add all modules in next beta.

 

Regarding WiFi driver, how will I know which wifi driver I will copy to modules. Im using 4.3

My motherboard is zotac h87 with an onboard wifi. Also can you have driver for bluetooth.

 

Boot on ubuntu livecd to find out which modules you need.

 

Hello, I'm having an issue with the synoboot pre v1.1_v3, I got this message (after .pat installation) , and xpenology doesn't boot :

It works very fine with the 'stable' synoboot, but PATA drivers for my MB are not included, and I have one IDE disk.

 

Can you try without your SYBA controller (based on ASMedia ASM1061) ? If the error still present remove the IDE drive to test.

 

I am using DSM 4.3, and found JMB363 PATA drive is not supported. Can you please post the jmicron ko file? Thanks!

 

Will be added in next beta

 

I test my Promise SuperTrak EX12350 and the system dont boot and i get an segfault error! :sad:

I installed the XPEnology 4.3 on "PROWare Nas", but the sas raid controller card cant't work.

And the server shutdown again and again because the card doesn't work.

Product Name: LSI MegaRAID® SAS 8704EM2

 

See next post about SCSi/SAS controllers

Share this post


Link to post
Share on other sites

As you know XPEnology have issues with SCSI/SAS controllers:

 

Known issues:
- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot).
- Volume containing drives attached to SCSI/SAS controllers is "broken" on each reboot, you must click repair.
- On some system segfault on boot

 

I spent three crazy days of testing this shit with my LSI 9211-4i (mpt2sas) controller.

Trying to understand the way DSM boot, detect, format drives.

After hours of hard work (and too many coffees) I finally get it works.... DSM install & working on disks connected to the LSI controller :mrgreen:

 

Simple configuration works : DSM on 2disks SHR RAID1 connected to lsi controller (no more volume "broken" on boot :smile:)

 

I'm currently testing hybrid setup : install DSM on 2disks SHR RAID1 connected to lsi card (this part is OK), then add a third disk on the motherboard and expand the volume (SHR RAID5) on it.

Reshaping in progress.... (wait & see tomorrow morning)

Share this post


Link to post
Share on other sites
As you know XPEnology have issues with SCSI/SAS controllers:

 

Known issues:
- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot).
- Volume containing drives attached to SCSI/SAS controllers is "broken" on each reboot, you must click repair.
- On some system segfault on boot

 

I spent three crazy days of testing this shit with my LSI 9211-4i (mpt2sas) controller.

Trying to understand the way DSM boot, detect, format drives.

After hours of hard work (and too many coffees) I finally get it works.... DSM install & working on disks connected to the LSI controller :mrgreen:

 

Simple configuration works : DSM on 2disks SHR RAID1 connected to lsi controller (no more volume "broken" on boot :smile:)

 

I'm currently testing hybrid setup : install DSM on 2disks SHR RAID1 connected to lsi card (this part is OK), then add a third disk on the motherboard and expand the volume (SHR RAID5) on it.

Reshaping in progress.... (wait & see tomorrow morning)

 

 

You are the man Trantor!!!!! Great work, thanks.

Looking forward to trying it :smile:

 

Any news on doing a build with the RS10613xs+? The Storage GUI on this one i sweet!!!

Share this post


Link to post
Share on other sites
with synoboot pre v1.1 v3

 

driver for ax8879 is not present

driver fro rt28000usb doesn't work :sad:

 

I will add all modules in next beta.

 

Regarding WiFi driver, how will I know which wifi driver I will copy to modules. Im using 4.3

My motherboard is zotac h87 with an onboard wifi. Also can you have driver for bluetooth.

 

Boot on ubuntu livecd to find out which modules you need.

 

Hello, I'm having an issue with the synoboot pre v1.1_v3, I got this message (after .pat installation) , and xpenology doesn't boot :

It works very fine with the 'stable' synoboot, but PATA drivers for my MB are not included, and I have one IDE disk.

 

Can you try without your SYBA controller (based on ASMedia ASM1061) ? If the error still present remove the IDE drive to test.

 

I am using DSM 4.3, and found JMB363 PATA drive is not supported. Can you please post the jmicron ko file? Thanks!

 

Will be added in next beta

 

I test my Promise SuperTrak EX12350 and the system dont boot and i get an segfault error! :sad:

I installed the XPEnology 4.3 on "PROWare Nas", but the sas raid controller card cant't work.

And the server shutdown again and again because the card doesn't work.

Product Name: LSI MegaRAID® SAS 8704EM2

 

See next post about SCSi/SAS controllers

 

 

thx for your answers, i have tested your new wifi beta rt2800usb driver, it make some error, so i'm waiting for your next :smile:

 

thx for your good job

Share this post


Link to post
Share on other sites
As you know XPEnology have issues with SCSI/SAS controllers:

 

Known issues:
- You can't install DSM on a drive connected to a SCSI/SAS controller (configuration lost on reboot).
- Volume containing drives attached to SCSI/SAS controllers is "broken" on each reboot, you must click repair.
- On some system segfault on boot

 

I spent three crazy days of testing this shit with my LSI 9211-4i (mpt2sas) controller.

Trying to understand the way DSM boot, detect, format drives.

After hours of hard work (and too many coffees) I finally get it works.... DSM install & working on disks connected to the LSI controller :mrgreen:

 

Simple configuration works : DSM on 2disks SHR RAID1 connected to lsi controller (no more volume "broken" on boot :smile:)

 

I'm currently testing hybrid setup : install DSM on 2disks SHR RAID1 connected to lsi card (this part is OK), then add a third disk on the motherboard and expand the volume (SHR RAID5) on it.

Reshaping in progress.... (wait & see tomorrow morning)

 

You and me both....

 

Just spent 4 days frigging around....

 

Using a Gigabyte P55-UD3R board, xeon x3450 and 8 gig ram

Dell H310 flashed to Dell 6gbpssas (IT) firmware

 

Hooked up 12 x 1tb drives

6 to onboard sata ports

6 to sas controller

 

Tried all versions I could find

2668

3112

3810

 

And all modified versions in between, from yourself and also Andy

 

Some find the controller, other find it and xpenology finds the drives.....

Some let you install, but then crashes at boot etc

 

Modified all manner of /etc/synoinfo.cfg files

 

Drank way too much coffee like yourself.

 

Damn I want this to work :twisted:

 

Can you give any hints as to how you got it working?

 

.

Share this post


Link to post
Share on other sites

Same Problem here... (Synoboot pre v1.1 v3, DSM 4.3 3810 V1.0)

N54l Microserver

4x SAS on unmodified Perc h310

2x Sata on internal Bay

 

Actually ive got an Shutdown so I cant configure anything...

Share this post


Link to post
Share on other sites

This morning SHR RAID5 volume of 3 drives (2 on lsi, 1 on motherboard) is OK, reboot OK, System Health OK :grin:

Then I test the system with 3 "profiles" (The disks were formatted before each tests, so no trace of previous DSM install):

 

- Standard (2disk on motherboard) : install OK, System Health OK

- Controller (2disks on lsi controller) : install OK, System Health OK

- Hybrid (1disk on motherboard, the other one on lsi controller) : install OK, System Health OK

 

When DSM is installed, I can change "profile" (Standard <-> Controller <-> Hybrid) without loosing anything (config, data) or reinstall DSM :ugeek:

 

I will soon post this :wink:

 

Any news on doing a build with the RS10613xs+? The Storage GUI on this one i sweet!!!

 

No enought time for this... like the x86 version

 

thx for your answers, i have tested your new wifi beta rt2800usb driver, it make some error, so i'm waiting for your next :smile:

 

This is why I didn't want to add wifi drivers in the first place. The wifi stack on linux is not easy to use.

All the wifi drivers are the latest from kernel 3.12.

Like I said wifi modules have often dependency, you need to load them in a particular order:

 

insmod cfg80211.ko
insmod mac80211.ko
insmod rt2x00lib.ko
insmod rt2x00usb.ko
insmod rt2800lib.ko
insmod rt2800usb.ko

 

You get your wifi card detected.

Share this post


Link to post
Share on other sites

ok interesseting :smile:

 

i'll take care of that to test, cause now i'm just looking if module was up cause it's normaly works with synology classic firmware.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.